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About This Guide
This manual introduces the KDE desktop of your SUSE® Linux Enterprise Desktop
and a variety of applications you will encounter when working with the KDE desktop.
It guides you through using these applications and helps you perform key tasks. It is
intended mainly for end users who want to make efficient use of KDE in everyday life.

The manual is subdivided into the following parts:

KDE Desktop
Get to know your KDE desktop and learn how to cope with basic and daily tasks,
using the central KDE applications and some small utilities. Get an impression of
the numerous possibilities KDE offers to modify and individualize your desktop
according to your needs and wishes.

Office and Collaboration
Use the office and collaboration software your SUSE Linux Enterprise Desktop
offers, such as the OpenOffice.org suite, several e-mailing and calendaring programs,
and applications for online conversations. Also find vital information concerning
the management and exchange of data on your system: how to share files on the
network, how to effectively search and encrypt data, and how to manage printers.

Internet
Find out how to use the Internet applications included in your SUSE Linux Enter-
prise Desktop, such as Konqueror or the Firefox Web browser, a download manager,
or a news feed reader.

Multimedia
Find topics such as graphics applications, digital cameras, sound applications, and
CD and DVD writers.

1 Feedback
We want to hear your comments and suggestions about this manual and the other doc-
umentation included with this product. Please use the User Comments feature at the
bottom of each page of the online documentation and enter your comments there.



2 Additional Documentation
There are other manuals available on this SUSE Linux Enterprise Desktop product. If
you want to have a look at the other end user documentation for SUSE Linux Enterprise
Desktop, the following manuals might be interesting:

Installation Quick Start
Lists the system requirements and guides you step-by-step through the installation
of your SUSE Linux Enterprise Desktop.

GNOME User Guide
This manual introduces the GNOME desktop of your SUSE Linux Enterprise
Desktop and a variety of applications you will encounter when working with the
GNOME desktop. It guides you through using these applications and helps you
perform key tasks. It is intended mainly for end users who want to make efficient
use of applications running on the GNOME desktop.

For an overview of all manuals shipped with SUSE Linux Enterprise Desktop, refer to
http://www.novell.com/documentation/sled10/, where you can also
download the manuals. You can also access the information online in the Help Center
of your desktop.

3 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd: filenames and directory names

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH

• ls, --help: commands, options, and parameters

• user: users or groups

• Alt , Alt + F1 : a key to press or a key combination; keys are shown in uppercase
as on a keyboard

x KDE User Guide
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• File, File → Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Reference): This is a reference to a chapter
in another book.
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Part I. KDE Desktop





1Getting Started with the KDE
Desktop
This chapter assists you in becoming familiar with the KDE desktop of your SUSE®
Linux Enterprise Desktop. If you have not yet installed your system, see Installation
Quick Start at http://www.novell.com/documentation/sled10/.

KDE stands for K Desktop Environment and is a graphical user interface that has many
applications designed to help you in your daily work. KDE also offers many choices
to modify your desktop according to your needs and wishes. Read more about config-
uring your desktop in Chapter 2, Customizing Your Settings (page 61).

The following description is based on the default configuration of the KDE desktop
shipped with your product. If you or your system administrator has modified the defaults,
some aspects may be different, such as appearance or keyboard shortcuts.

1.1 Logging In and Selecting a
Desktop

If more than one user account is configured on your computer, all users must authenti-
cate. When you start your system, you are prompted to enter your username and pass-
word. This is the username and password you created when you installed your system.
If you did not install your system, check with your system administrator for your user-
name and password.

Getting Started with the KDE Desktop 15
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NOTE: Auto Login

If your computer is not run in a networking environment and you are the only
person using it, you can automatically log in to the desktop environment on
boot. In this case, you do not see any login screen. This feature, called auto
login, can be enabled or disabled during installation or at any time using the
YaST user management module.

The program managing the login process depends on the desktop environment installed
on your system. For KDE, it is KDM. If additionally the GNOME desktop is installed
on your system, it may be GDM.

As shown in Figure 1.1, “A KDM Login Screen” (page 16), the default KDM login
screen provides input fields for username and password and two menu items. To start
a normal login, just enter your username and password.

Figure 1.1 A KDM Login Screen

The KDM login screen has input fields for username and password and the following
menu items:
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Session Type
Specifies the desktop to run when you log in. If desktops other than KDE are in-
stalled, they appear in the list. Make changes only if you want to use a session type
other than your default (usually KDE). Future sessions are automatically of the
same type unless you change the session type manually.

System
Performs a system action, such as shutting down the computer or starting different
login actions. Remote Login enables you to log in on a remote machine.

NOTE: Connecting to an Active Directory Server

To access shared network resources, you can also authenticate a KDE client
machine against an Active Directory server. For further details, refer to Chap-
ter 9, Accessing Network Resources (page 167). If your machine is configured
for this kind of authentication, the login screen also provides an additional
field. In this case, proceed as follows during login:

1. Select the domain from the list.

2. Enter your Windows username.

3. Enter your Windows password and press Enter .

1.1.1 Controlling a Session
The Session Manager starts after your username and password are authenticated by the
login process. The Session Manager lets you save certain settings for each session. It
also lets you save the state of your most recent session and return to that status the next
time you log in.

The Session Manager can save and restore the following settings:

• Appearance and behavior settings, such as fonts, colors, and mouse settings.

• Applications that you were running, such as a file manager or OpenOffice.org.
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IMPORTANT: Saving and Restoring Applications

You cannot save and restore applications that Session Manager does not
manage. For example, if you start the vi editor from the command line in
a terminal window, Session Manager cannot restore your editing session.

For information about configuring session preferences, see Section 2.2.4, “KDE Com-
ponents” (page 70).

1.1.2 Switching Desktops
If you installed both the KDE and the GNOME desktops, use the following instructions
to switch desktops.

1 If you are logged in to KDE, select Log Out → End Current Session from the
main menu. On the login screen, click Session Type.

2 Select the GNOME desktop.

3 Enter your username.

4 Enter your password. The GNOME desktop is started.

SeeGNOMEUser Guide http://www.novell.com/documentation/
sled10/ for more information about using the GNOME desktop.

5 To switch back to KDE again, click Desktop → Log Out on the panel of the
GNOME desktop then click OK. The session is closed and the login screen
reappears.

6 Before logging in again, click Session Type and select KDE in the login screen.
If you do not select a new session type, your next session will be of the same
type (GNOME) as the session before.

1.1.3 Locking Your Screen
To lock the screen, do either of the following:
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• From the main menu, select Lock Session.

• Use the keyboard shortcut defined in the KDE Control Center. Usually, this is Ctrl
+ Alt + L .

TIP: Looking Up KDE Keyboard Shortcuts

If you want to look up the keyboard shortcuts defined in KDE, select Per-
sonal Settings → Regional & Accessibility → Keyboard Shortcuts from the
main menu. See also Section 2.2.6, “Regional & Accessibility” (page 72).

For quick access, you can also add the Lock and Logout icons to the panel. To do so,
right-click the panel then click Add Applet to Panel. In the following window, select
Lock/Logout Buttons and click Add to Panel.

When you lock your screen, the screensaver starts. To unlock the screen, move your
mouse to display the locked screen dialog. Enter your username and password then
press Enter .

For information about configuring your screensaver, see Section 2.2.1, “Appearance
& Themes” (page 65).

1.2 Logging Out
When you are finished using the computer, you can log out and leave the system running
or restart or shut down the computer. If your system provides power management, you
can also suspend the computer, making the next system start much faster than a complete
boot.

To log out and leave the system running, do one of the following:

• From the main menu, select Log Out → End Current Session.

• Use the keyboard shortcut that is defined in the KDE Control Center, described in
Section 2.2.6, “Regional & Accessibility” (page 72). Usually, to log out with
confirmation, this is Ctrl + Alt + Del . In the following dialog you still have the
choice to cancel the logout process. If you want to log out without any confirmation,
press Ctrl + Alt + Shift + Del .
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• Click the Logout icon in the panel. If your panel does not include the logout icon,
you can add it to the panel as described in Section 1.1.3, “Locking Your Screen”
(page 18).

1.3 Desktop Components
The graphical desktop environment should not pose any problems for former Windows
or Macintosh users. The main components of the desktop are the icons on the desktop
and the panel at the bottom of the screen.

Figure 1.2 An Example KDE Desktop

Desktop icons represent files, directories, applications, functions, and removable media,
like CDs or DVDs.

The desktop has the following icons by default:

Trash
Contains files and folders that have been deleted. For information about using the
trash bin, see Section 1.3.4, “Managing the Trash Bin” (page 29).
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My Computer
Displays information about hardware, network status, operating system, hard disks,
common folders, and removable devices. For more information, refer to Sec-
tion 1.3.3, “Accessing Removable Media” (page 26).

Network Browsing
Displays network services you can access. Some of the services might require au-
thentication. To learn more, refer to Chapter 9, Accessing Network Resources
(page 167).

Printer
Opens KJobViewer that displays print jobs you have sent to printers. See Sec-
tion 12.4, “Starting Print Jobs in KDE” (page 202) for more information.

Firefox
Opens the Firefox Web browser. For more information, refer to Chapter 14,
Browsing with Firefox (page 217).

Office
Opens a new OpenOffice.org document. For an introduction to this office suite,
refer to Chapter 3, The OpenOffice.org Office Suite (page 77).

The panel (in KDE also called “Kicker”) is a bar, typically located at the top or the
bottom of the screen. It is designed to provide information about running applications
or the system and easy access to some important functions or applications. If you hold
your pointer over an icon, a short description is displayed.

Figure 1.3 KDE Panel (Kicker)

The panel typically consists of the following areas:

Main Menu Icon
By default, the left end of the panel has an icon that opens the main menu, similar
to the start button on the MS Windows desktop. The main menu has a well-ordered
structure for accessing the main applications. It also contains menu items for major
functions like logging out or searching for applications. For more information, see
Section 1.3.1, “Accessing the Main Menu” (page 22).
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Quick Launcher
Next to the main menu icon, find the quick launcher. It holds some icons for the
most important functions or applications to enable you to start them without going
through the main menu. It also contains an icon for the Help Center, which provides
online help for your system.

Desktop Previewer
Next to the quick launcher, find the desktop previewer, which shows your different
desktops. These virtual desktops enable you to organize your work. If you use many
programs simultaneously, you might want to run some programs in one desktop
and other programs in the other desktop. To switch between desktops, click the
desktop symbol in the panel.

Taskbar
The taskbar is located next to the desktop previewer. By default, all started appli-
cations and open windows are displayed in the taskbar, which allows you to access
any application regardless of the currently active desktop. If you click a window
title in the taskbar, the application is moved to the foreground. If it is already in
the foreground, clicking minimizes the application.

System Tray
The rightmost part of the panel usually holds the system clock, the volume control,
and several other helper applications.

To learn how to configure the appearance and behavior of your desktop, including the
main menu, desktop icons, or the panel, refer to Changing Panel Elements (page 62).

1.3.1 Accessing the Main Menu
Open the main menu by clicking the icon to the far left of the panel. Alternatively, press
Alt + F1 . The main menu is subdivided into these sections: Most Used Applications,
All Applications (a menu with all applications sorted according to categories), and Ac-
tions. Applications that you start most often appear in the Most Used Applications
section.

The function-oriented menu structure makes it easy to find the right application for
your purpose even if you do not know the application names yet. If you already know
the name of an application (or at least a part of its name) but are not sure how to start
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it from the main menu, you can use the search function provided in the All Applications
section.

Figure 1.4 Main Menu Search Function

Just type a part of the application name into the search field without pressing the Enter
key afterwards. If the application is installed on your system, the menu structure leading
to this application is highlighted in the main menu.

The following section provides information about a number of actions that can be trig-
gered from the main menu.

Recent Documents
Lists the most recently opened files or folders. When you select a document, the
application to view or edit this document is started. You can also clear the history
of documents.

My System
Gives quick access to some places often needed, such as your home directory or
media devices.

Run Command
Opens a dialog where you can enter an command to start the application. The name
of the command is often (but not always) the application name written in lowercase.
You can use autocompletion of the command by typing the first letters then pressing
→| . If the command was executed before and can be uniquely identified, it is
completed to full length.

Switch User
To start a second session with a graphical user interface on your machine, select
Start New Session. Your current session remains active while you are taken to the
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login screen where you can log in as a different user. You can access the first session
by pressing Ctrl + Alt + F7 . To access a new session, press F8 instead of F7 . Ad-
ditional sessions can be accessed by pressing Ctrl + Alt + F9 to F12 .

Lock Session
If you leave your computer you can prevent unauthorized access by others by
locking your screen. After locking, a screensaver starts. Access to the session can
only be regained with a password. To unlock, enter your normal login password.

Log Out
Opens a dialog with several options: you can end the current session, turn off the
computer, restart the computer, or cancel the logout. End Current Session leaves
your system running and restores the applications for your next login. If your system
provides power management, you are also offered to suspend the computer, making
the next system start much faster than a complete boot.

1.3.2 Inserting or Connecting Removable
Media

If you insert or connect removable media to your computer (such as CD-ROMs, digital
cameras, or USB sticks), these are usually automatically detected. In KDE, a dialog
appears, showing the medium type detected and offering several options of what to do
with the new medium. The list of options depends on the type of medium inserted.

Figure 1.5 Autodetection of a USB Stick in KDE
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To view the data with a file manager, select Open in New Window and click OK. The
Konqueror file manager appears, showing the contents of the removable device.

Figure 1.6 Viewing the Contents of an USB Stick

If you want the same action to be performed every time you insert a removable medium
of that type, activate Always do this for this type of media in the autodetection dialog
before clicking OK.

Procedure 1.1 Configuring How to Handle Removable Media

In the autodetection dialog, you can also configure how KDE should handle several
types of removable media. For example, if you know that a certain type of medium
that you use often always contains photos, you can configure it to open an image
viewer application automatically:

1 In the autodetection dialog, click Configure.

2 A configuration dialog appears, showing a list of all available actions.

3 Click the Medium types drop-down list and select the type of medium for which
to configure a certain action. The list of available actions now only shows actions
applicable to the medium type selected.

4 Select the action to apply and click Toggle as Auto Action.
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Figure 1.7 KDE Configuration Dialog for Removable Media

5 Click the Advanced tab and make sure the Enable medium application autostart
after mount check box is selected.

6 Click OK to apply the changes and close the configuration dialog. Now every
time you insert a medium of this type, the configured action is executed automat-
ically and the autodetection dialog does not appear any more.

To reset the action assigned to the type of medium and restore the default options,
proceed as follows:

1 Start the KDE Control Center from the main menu by selectingPersonal Settings.

2 In the left-hand navigation bar, click Peripherals → Storage Media. The confi-
guration dialog appears on the right.

3 Click Default and Apply. The next time you insert a medium, the autodetection
dialog appears again, leaving you the choice of what to do with the medium.

1.3.3 Accessing Removable Media
KDE offers several ways to access removable media at any time. ClickingMyComputer
on the desktops opens a view as shown in Figure 1.8, “My Computer” (page 27).
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Figure 1.8 My Computer

If you start Konqueror as a file manager (see Section 1.4, “Managing Folders and Files
with Konqueror” (page 29)) and click Storage Media on the start window or enter
media:/ in the location bar, Konqueror displays the storage devices as shown in
Figure 1.9, “Displaying Media in Konqueror” (page 28).
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Figure 1.9 Displaying Media in Konqueror

You can also name removable devices, such as USB sticks, with Konqueror. Right-
click the USB stick in Konqueror and select Properties. On the General tab, enter a
name in the input field and click OK. When inserting the stick the next time, Konqueror
displays the name of the stick.

A small green arrow indicates that a medium has been mounted (integrated into your
file system, which is necessary to access the data on the medium). In SUSE Linux En-
terprise Desktop, you normally do not have to care about mounting removable devices
because this is done automatically by default.

NOTE: Removing Media Safely

If you want to remove or disconnect a medium from your computer, make
sure that the data on the medium is currently not accessed by any application
or user. Otherwise risk a loss of data. To safely remove the medium, proceed
as follows:

1. Open a view that displays all removable media.
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2. Right-click the medium to remove and select Safely Remove or Eject.
Safely Remove unmounts the medium after which you can disconnect
the medium from your computer. Eject automatically opens the CD or
DVD drive of your computer.

1.3.4 Managing the Trash Bin
The trash bin is a directory for files marked for deletion. Drag icons from the file
manager or the desktop to the trash bin icon by keeping the left mouse button pressed.
Then release to drop them there. Alternatively, right-click an icon and select Move to
Trash from the menu. Click the trash bin icon to view its contents. You can retrieve an
item from the trash if desired.

Files removed with Delete are not moved to the trash bin, but deleted completely. To
delete the files in the trash bin completely, right-click the trash bin icon then click
Empty Trash Bin.

1.4 Managing Folders and Files with
Konqueror

Konqueror is a unified Web browser, file manager, document viewer, and image
viewer. The following sections cover using Konqueror for file management. For infor-
mation about Konqueror as a Web browser, see Chapter 13, Browsing with Konqueror
(page 209).

Start Konqueror as a file manager by clicking the house icon in the panel. Konqueror
displays the contents of your home directory.
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Figure 1.10 The File Manager Konqueror

The Konqueror file manager window consists of the following elements:

Menu Bar
The menu bar holds menu items for actions like copying, moving, or deleting files,
changing views, starting additional tools, defining your settings, and getting help.

Toolbar
The toolbar provides quick access to frequently used functions that can also be
accessed through the menu. If you hover the pointer over an icon, a short description
is displayed. To the right, the toolbar features the Konqueror icon, which is animated
while a directory or Web page is loaded.

Location Bar
The location bar shows the path to the directory or file in your file system. You
can enter a path to a directory directly by typing it in or by clicking one of the di-
rectories in the display field. Delete the contents of the line by clicking the black
symbol with a white X located left of the location bar. After typing an address,
press Enter or click Go to the right of the input line.

Unlike a Windows operating system, Linux does not use drive letters. In Windows,
you would address the floppy drive as A:\, Windows system data is under C:\,
and so on. In Linux, all files and directories are located in a tree-like structure. The
topmost directory is referred to as the file system root or just /. All other directories
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can be accessed from it. In the following, find a short overview of the most important
directories in a Linux file system:

/home holds the private data of every user who has an account on your system.
The files located here can only be modified by their owner or the system adminis-
trator. Your e-mail directory is located here, for example.

NOTE: Home Directory in a Network Environment

If you are working in a network environment, your home directory may
not be called /home but can be mapped to any directory in the file system.

/media generally holds any type of drive except the hard drive of your system.
Your USB flash drive appears under /media once you have connected it, as do
your digital camera (if it uses USB) and DVD or CD drive.

Under /usr/share/doc, find any kind of documentation on your Linux system
and the installed packages. The manual subdirectory holds a digital copy of this
manual as well as the other manuals and the release notes of the installed version
of your Linux system. The packages directory holds the documentation included
in the software packages.

/windows only appears if you have both MS Windows and Linux installed on
your system. It holds the MS Windows data.

Learn more about the Linux file system concept and find a more comprehensive
list of directories in Section 14.1.2, “Linux Directory Structure” (Chapter 14,
Working with the Shell, ↑Deployment Guide).

Navigation Panel
You can hide and show the navigation panel by pressing F9 . The navigation panel
displays your information in a tree view. Determine which contents you want to
see by clicking one of the symbols in the tab at the left of the navigation panel. If
you hold your mouse pointer over an icon, a short description is displayed. For
example, you can show the file system as a tree starting at the root folder or at your
home folder.

Display Field
The display field shows the contents of the selected directory or file. In the View
menu, choose between different view modes to display the contents, such as Icon
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View, Tree View, or Detailed List View. If you click a file, Konqueror shows a
preview of the contents or loads the file into an application for further processing.
If you hold the mouse pointer over the file, Konqueror shows a tool tip with detailed
information about the file, such as owner, permissions, or last modification date.

By default, Konqueror does not show any hidden files, which are often system files
that you usually do not want to access or see. In Linux, hidden files are indicated
by a dot in front. You can toggle the view to see or hide hidden files by selecting
View → Show Hidden Files.

1.4.1 Copying, Moving, or Deleting Files
For performing actions like copying, moving, or deleting files, you need appropriate
permissions to the folders and files involved in your action. Read more about changing
access permissions in Section 1.4.3, “Changing Access Permissions” (page 33).

TIP: Selecting Objects in Konqueror

Clicking a file or a folder in Konqueror directly starts an action: a preview of
the file is displayed or the folder is opened. To former users of MS Windows,
this behavior may be rather unusual. If you just want to select one or several
files without any other action, press Ctrl then click the object. Alternatively,
alter your mouse settings in the KDE Control Center (see Section 2.2.6, “Regional
& Accessibility” (page 72)).

To copy or move a file or folder, proceed as follows:

1 Right-click the object and select Copy or Cut from the context menu. The object
is kept in the clipboard.

2 Navigate to your destination folder under which you want to insert the object.
Right-click the destination folder and select Paste. The object is copied or moved
there.

The quickest way to perform actions like copying or moving objects in Konqueror is
the drag-and-drop method. For instance, you can easily move objects from one window
to another by simply dragging them. When dropping the object, you are asked whether
the objects should be moved or copied.
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To delete a file or folder, proceed as follows:

• Select the object and press Del or right-click the file then select Move to Trash
from the context menu. The object is moved to the trash bin. If necessary, you can
restore the file or folder from there or delete it completely. See also Section 1.3.4,
“Managing the Trash Bin” (page 29).

• To delete the object irretrievably, click Edit → Delete or press Shift + Del . If you
want to add Delete to the context menu, configure this behavior in Konqueror by
clicking Settings→Configure Konqueror→ Behavior and activating the respective
check box.

1.4.2 Creating a New Folder
To create a new folder in Konqueror, proceed as follows:

1 Right-click the folder to which to add a subfolder.

2 Select Create Folder.

3 In the New Folder dialog, enter a name for the new folder and click OK.

1.4.3 Changing Access Permissions
Because Linux is a multiuser system, every file in a Linux file system belongs to a user
and a group. All users, including the superuser, have their own home directories where
private data, like documents, bookmarks, or e-mail, are stored. Write access to these
home directories is strictly limited to the owner by default. As an owner of a file or di-
rectory, you can change the access permissions to your files. For example, you can
protect files holding sensitive data against read access by other users and you can au-
thorize other users to write, read, or execute several of your files where appropriate.

Traditionally, three permission sets are defined for each file object on a Linux system.
These sets include the read (r), write (w), and execute (x) permissions for each of three
types of users—the file owner, the group, and other users. For detailed information
about the user concept of Linux, refer to Section 14.2, “Users and Access Permissions”
(Chapter 14, Working with the Shell, ↑Deployment Guide). Instead of using the “tradi-
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tional” way to change access permissions in a shell, you can also use the graphical user
interface Konqueror provides.

To set permissions for a file, choose from the following options in Konqueror:

Forbidden
Users can see the filename in the file system but cannot open the file and read it.

Can Read
Users can open and read the file but cannot change it.

Can Read & Write
Users can open, read, and change the file.

To set permissions for a folder, the following options are available in Konqueror:

Forbidden
Users can see the folder name in the file system but cannot open the folder.

Can View Content
Users can see the folder contents.

Can View & Modify Content
Users can see the folder contents and create new files or subfolders.

To change access permissions:

1 Open Konqueror and select the file or folder for which to change access permis-
sions.

2 Right-click the file and select Properties. A new dialog opens.

3 Click the Permissions tab. It shows the ownership of the file or folder in the
lower part. The upper part shows the current access permissions.

4 From the lists for Owner, Group, and Others, select the permissions to set for
the file or folder.

5 Click OK to apply the changes.

Apart from this traditional permission concept for file system objects, you can also use
access permission lists (ACLs) with Konqueror. With ACLs, permissions can be defined
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more flexibly than the traditional permission concept allows. They allow assigning
permissions to individual users or groups even if these do not correspond to the original
owner or the owning group. For more in-depth information about ACLs, refer to
Chapter 12, Access Control Lists in Linux (↑Deployment Guide).

To grant certain users or groups access permission to a file or folder, proceed as fol-
lows:

1 Open Konqueror and select the file or folder for which to change access permis-
sions.

2 Open the Properties dialog for the file or folder and click the Permissions tab.

3 ClickAdvanced Permissions. The following dialog shows the current permissions
for the object.

Figure 1.11 Advanced Permissions for a File or Folder

4 Click Add Entry.

5 To grant a certain user access permission to the file or folder, select Named User
and select a user from the list.

To grant a certain group access permission to the file or folder, select Named
Group and select a group from the list.

6 In the Advanced Permissions dialog, the added user or group appears in the list
showing the current permissions. The green check marks in the columns r, w,
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and x indicate that the user has read, write, and execute access to the file or
folder.

Figure 1.12 Assigning Permissions to a Certain User

7 You can modify the access rights for the user by clicking the corresponding check
marks for this user in the column r, w, or x.

8 When all access permissions are set according to your wishes, click OK to close
the dialog.

9 Click OK to apply your changes and to close the Properties dialog.

1.4.4 Changing File Associations
With Konqueror, you can decide which application should be used to open a file.
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Figure 1.13 Configuring File Associations in Konqueror

1 In Konqueror, click Settings → Configure Konqueror → File Associations.

2 To search for an extension, enter the extension in Find Filename Pattern. Only
file types with a matching file pattern appear in the list. For example, to modify
the application for *.png files, enter png in Find Filename Pattern.

3 In the Known Types list, click the file type to open the setting dialog for this file
type. You can change the icon, the filename patterns, description, and the order
of the applications.

If your tool is not listed, click Add in Application Preference Order then enter
the command.

To change the order of the list entries, click the program to move then give it a
higher or lower priority by clicking Move Up or Move Down. The application
listed at the top is used by default when you click a file of this type.

4 If you need a file type that is not listed in the Known Types list, click Add to open
a dialog where you can select a group and enter a type name. The group deter-
mines the main type, for example, audio, image, text, or video. Your file type
can usually be assigned to one of these.
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a Click OK then determine the extensions of the filename.

b Specify a description in the text field and select which application to use.

5 Click OK.

1.4.5 Saving View Profiles
You can temporarily change the view of certain folders by selecting a different View
Mode in the Viewmenu. To apply these changes to all folders, you can save your options
to a view profile. To do so, change the view according to your wishes and click Settings
→ Configure View Profiles. Enter a name for the profile to save and click Save. The
view is changed for all folders and saved in this profile. You can now load this profile
at any time by clicking Settings → Load View Profile. By default, Konqueror contains
several view profiles designed for various tasks. You can also take one of these profiles
as a draft and modify it according to your needs.

1.4.6 Accessing Digital Cameras with
Konqueror

With Konqueror, you can also access your digital camera. Connect your camera to the
USB port. A camera icon should appear on the desktop. Click this icon to open the
camera in Konqueror. The camera can also be accessed by entering the URL camera:
/ in Konqueror. Navigate through the camera's directory structure until the files are
shown. Use the usual Konqueror file management features to copy the files as desired.

1.4.7 Viewing Images with Konqueror
You can also easily use Konqueror as image viewer. For a quick and comfortable
overview of all images in a directory, select the directory and click the Image View icon
in the toolbar. Konqueror generates thumbnails and shows them on the left-hand side
of the window. Click a thumbnail to see the full-size view of the picture on the right-
hand side of the window. A number of additional icons appears in the toolbar for navi-
gating back and forth, zooming or rotating the pictures, or creating a slide show. To
toggle to “normal” view again, click Icon View or Tree View in the toolbar.
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Apart from this functionality, you can also create image galleries that show your images
in an album-like fashion. Open your image directory in Konqueror and click Tools →
Create Image Gallery. A dialog opens where you can specify the background and
foreground colors, the page title, the location to save the gallery, and other settings.
Click OK to start the action. By default, a file called index.html is created. If you
click this file in Konqueror, your images are displayed in a miniaturized, organized
view. Click an image to access its full-size view.

Figure 1.14 Creating an Image Gallery with Konqueror

For viewing your images, you can also use Gwenview. To start Gwenview, press Alt
+ F2 and entergwenview. For further information about Gwenview, see the Gwenview
online help.

For downloading photographs from digital cameras, you can use Digikam as described
in Chapter 18, Using Digital Cameras with Linux (page 241).

1.5 Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
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SUSE Linux Enterprise Desktop offers various different ways of accessing and creating
network-shared resources. Given that the network structure and the configuration of
your computer allow for it, you can easily browse your network for shared resources
and services with your file manager, Konqueror.

To do so, click the Network Browsing icon on the desktop. The window displays the
network share types that you can access. Click a network resource type then click the
network share to access. You might be required to authenticate to the resource by pro-
viding a username and password.

Figure 1.15 Workgroups on a Windows Network

1.6 Opening or Creating Documents
with OpenOffice.org

The office suite OpenOffice.org offers a complete set of office tools including a word
processor, spreadsheet, presentation, vector drawing, and database components. Because
OpenOffice.org is available for a number of operating systems, you can use the same
data across different computing platforms. You can also open and edit files in Microsoft
Office formats then save them back to this format, if needed.
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To start OpenOffice.org, press Alt + F2 and enter OOo or click the Office icon on the
desktop.

For an introduction to OpenOffice.org, see Chapter 3, The OpenOffice.org Office Suite
(page 77) or view the help in an OpenOffice.org program.

1.7 Finding Data on your Computer
or in the File System

KDE provides more than one application for finding data on your computer or in the
file system. With Kerry, you can very easily search your personal information space
(usually your home folder) to find documents, e-mails, Web history, IM/ITC conversa-
tions, source code, images, music files, applications, and much more. For more infor-
mation, refer to Chapter 11, Searching with Kerry (page 195).

With KFind, you can locate files on your computer or in the file system using a variety
of search criteria, such as file content, dates, owner, or file size. Start it from the main
menu with Find Files/Folders. Alternatively, press Alt + F2 and enter kfind.

Figure 1.16 Finding Files with KFind

1.7.1 Finding Files
To perform a search for certain filenames, proceed as follows:
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1 Start KFind from the main menu or command line.

2 Click the Name/Location tab to perform a basic search.

3 Specify the name of the file to find in Named. You can use the following wild
cards:

Asterisk
The asterisk (*) stands for any number of missing characters (even zero).
For example, searching for marc* can find the files marc, marc.png, and
marc_must_not_read_this.kwd. Searching for mar*.kwd can find market-
place.kwd and marc_must_not_read_this.kwd.

Question Mark
The question mark (?) stands for exactly one character. For example,
searching for mar? can find marc, but marc? cannot find anything if your
files are named marc and marc.png. You can put as many question marks
in the search term as you want. It finds exactly that number of characters.

You can combine those two wild card symbols in any search term.

4 Specify the folder to search in Look In or click Browse to find the folder you
want. Select Include Subfolders to also search all subfolders starting from your
specified folder.

5 Press Enter or click Find.

1.7.2 Performing an Advanced File Search
For a more detailed search, you can also specify further options, such as a text the file
to find must contain:

1 Start KFind from the main menu or the command line.

2 Click the Name/Location tab.

3 Specify the name of the file to find in Named.
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4 Specify the folder in which to search in Look In or click Browse to find the
folder.

5 Click the Contents tab.

6 In File Type, specify the type of file to find.

7 In Containing Text, enter the word or phrase the file you are searching for must
contain.

8 If you want to specify further options, click the Properties tab and choose the
options you want. If you hold the mouse pointer over the options or fields, a short
description is displayed.

9 Click Find to perform the search.

For detailed information about the search options available, refer to the KFind online
help.

For advanced searches, you may want to use search patterns or regular expressions.
KRegExpEditor offers search options based on regular expressions. You can install
KRegExpEditor with YaST as the packagekdeutils3-extra. For more information
about search patterns and the use of wild cards or regular expressions, refer to Sec-
tion 14.1, “Getting Started with the Bash Shell” (Chapter 14, Working with the Shell,
↑Deployment Guide).

1.8 Exploring the Internet
In KDE, the default Web browser is Konqueror. To start Konqueror, click the Konqueror
icon on the panel or press Alt + F2 and enterkonqueror. Learn more about Konqueror
as a Web browser in Chapter 13, Browsing with Konqueror (page 209).

In addition to Konqueror, you can use a Mozilla-based browser, Firefox. Start Firefox
from the main menu or by pressing Alt + F2 and entering firefox. You can type an
address into the location bar at the top or click links in a page to move to different pages,
just like in any other Web browser. For more information about Firefox, see Chapter 14,
Browsing with Firefox (page 217) .
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1.9 E-Mail and Scheduling
KMail is an e-mail client that supports e-mail protocols like POP3 and IMAP. It also
has multiple e-mail account support, powerful filters, PGP/GnuPG privacy, and online
attachments. Start KMail from the main menu or press Alt + F2 and enter kmail.

Kontact is a personal information management (PIM) tool that combines well-known
applications like KMail, KOrganizer, and KAddressBook into a single interface. This
lets you have easy access to your e-mail, calendar, address book, and other PIM func-
tionality. To start Kontact, press Alt + F2 and enter kontact. For detailed information
about using Kontact, see Chapter 4, Kontact: E-Mailing and Calendaring (page 111).

1.10 Moving Text between
Applications

To copy text to the clipboard and insert it again, former MS Windows users automati-
cally try the shortcut keys Ctrl + C and Ctrl + V , which often work in Linux as well.
Copying and inserting texts is even easier in Linux: to copy a text to the clipboard, just
select the text with the mouse then move the mouse cursor to the position where you
want the text copied. Click the middle button on the mouse to insert the text (on a two-
button mouse, press both mouse buttons simultaneously).

With some applications, if a text is already selected in the application where you want
to insert the text, this method does not work because the text in the clipboard is over-
written by the other selected text. For such cases, the KDE application Klipper is very
useful. Klipper “remembers” the last entries you have moved to the clipboard. By default,
Klipper is started when KDE is loaded and appears as a clipboard icon in the panel. To
view the clipboard contents, click the Klipper icon. The most recent entry is listed on
top and is marked as active with a black check mark. If an extensive text was copied
to Klipper, only the first line of the text is displayed.

To copy an older text fragment from Klipper to an application, select it by clicking it,
move the mouse pointer to the target application, then middle-click. For further infor-
mation about Klipper, see the Klipper online help.
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1.11 Important Utilities
The following pages introduce a number of small KDE utilities intended to assist in
daily work. These applications perform various tasks, such as managing your Internet
connections and your passwords, creating data archives, and viewing PDF files.

1.11.1 Managing Internet Connections
To surf the Internet or send and receive e-mail messages, connect an ISDN or ethernet
card or a modem to your machine and configure it. This can be done with the help of
the YaST system assistant. You can establish Internet connections with NetworkMan-
ager or KInternet. In YaST, select whether to use NetworkManager.

For further details, refer to Network Connectivity Guide. It includes a list of criteria that
help you to decide whether to use NetworkManager or other applications and describes
the usage of the applications.

1.11.2 Managing Passwords with KWallet
Manager

Remembering all the passwords for protected resources to which you need to log in
can be problematic. KWallet remembers them for you. It collects all passwords and
stores them in an encrypted file. With a single master password, open your wallet to
view, search, delete, or create entries. Normally you do not need to insert an entry
manually. KDE recognizes if a resource requires authentication and KWallet starts au-
tomatically.

IMPORTANT: Protect Your KWallet Password

If you forget your KWallet password, it cannot be recovered. Furthermore,
anyone who knows your password can obtain all information contained in the
wallet.
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Starting KWallet
When KWallet starts for the first time (for example, when you access a Web site where
you must enter a password to log in), a dialog appears with the welcome screen. Choose
between Basic setup (recommended) and Advanced setup. If you choose Basic setup,
in the next screen you can choose whether to store personal information. Some KDE
applications, such as Konqueror or KMail, can use the wallet system to store Web form
data and cookies. Select Yes, I wish to use the KDE wallet to store my personal infor-
mation to activate KWallet and leave with Finish.

If you choose Advanced setup, you have an additional security level screen. The default
settings are generally acceptable for most users, but others may wish to change them.
Automatically close idle wallets closes wallets after a period of inactivity. To separate
network passwords and local passwords, activate Store network passwords and local
passwords in separate wallet files. Close with Finish.

You can alter the settings at any time by right-clicking the KWallet icon in the panel
and selectingConfigureWallet. A dialog box opens where you can select several options.
By default, all passwords are stored in one wallet, kdewallet, but you can also add new
wallets. Once configured, KWallet appears in the panel.

The KWallet Manager
To store data in your wallet or view its contents, click the KWallet icon in the panel.
A dialog box opens, showing the wallets that are accessible on your system. Click the
wallet to open. A window prompts for your password.

After a successful login, the KWallet Manager window opens. It is divided into four
different parts: the top left part displays a summary, the top right part displays subfolders,
the lower left part shows a list with folder entries, and the lower right part shows the
contents of a selected entry.

In the KWallet Manager, you can change your master password for KWallet at any
time with File → Change Password.
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Figure 1.17 The KWallet Manager Window

You can add or delete folders. Selecting a folder updates the folder entry list and the
summary display. Selecting a folder entry updates the entry contents pane and allows
you to edit that entry. Entries can also be created or deleted using the context menu for
the folder contents.

To insert a new entry, proceed as follows:

Procedure 1.2 Inserting New Entries in Your Wallet

1 In the top right part of the window, select the subfolder to which to add an entry.

The lower left part shows a list of entries belonging to the subfolder. You can
add a new entry to Maps or Passwords. Use Maps if you have key and value
pairs. Passwords can contain multiline entries.

2 To add a new password, right-click the Passwords entry then select New from
the context menu.

3 Specify a name for the new entry then click OK. Your new entry is sorted under
your folder entry.

4 Click the new entry to display it on the right side (the folder is initially empty).

5 Click Show Contents to open an input field where you can enter your new pass-
word.
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6 Type in your password and click Save. KWallet saves your password to the
subfolder selected.

Copying Your Wallet to Another Computer
For the most part, KWallet resides silently in the panel and is automatically activated
if needed. However, you can copy your wallet files to another computer (for example,
your laptop). To simplify this task, wallets can be dragged from the manager window
to a file browser window. This let you easily package a new wallet for transfer to another
environment. For example, a new wallet could be created and copied onto a removable
flash memory device. Important passwords could be transferred there, so you have them
available in other locations.

1.11.3 Displaying, Decompressing, and
Creating Archives

To save space on the hard disk, use a packer that compresses files and directories to a
fraction of their original size. The application Ark can be used to manage such archives.
It supports common formats, such as zip, tar.gz, tar.bz2, lha, and rar.

Start Ark from the main menu or from the command line with ark. If you already have
some compressed files, move these from an open Konqueror window to the Ark window
to view the contents of the archive. To view an integrated preview of the archive in
Konqueror, right-click the archive in Konqueror and select Preview in Archiver. Alter-
natively, select File → Open in Ark to open the file directly.
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Figure 1.18 Ark: File Archive Preview

Once you have opened an archive, perform various actions. Action offers options such
as Add File, Add Folder, Delete, Extract, View, Edit With, and Open With.

To create a new archive, select File → New. Enter the name of the new archive in the
dialog that opens and specify the format using Filter. After confirming with Save or by
pressing Enter , Ark opens an empty window. You can drag and drop files and directories
from the file manager into this window. As the final step, Ark compresses everything
into the previously selected archive format. For more information about Ark, select
Help → Ark Handbook.

1.11.4 Taking Screen Shots
With KSnapshot, you can create snapshots of your screen or individual application
windows. Start the program from the main menu or by pressing Alt + F2 and entering
ksnapshot. The KSnapshot dialog consists of two parts. The upper area (Current
Snapshot) contains a preview of the current screen and three buttons for creating and
saving the screen shots. The lower area contains further options for the actual creation
of the screen shot.
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Figure 1.19 KSnapshot

To take a screen shot, use Snapshot Delay to determine the time (in seconds) to wait
between clicking New Snapshot and the actual creation of the screen shot. If Only Grab
the Window Containing the Pointer is selected, only the window containing the pointer
is saved. To save the screen shot, click Save Snapshot and designate the directory and
filename for the image in the subsequent dialog. Click Print Snapshot to print the screen
shot.

You can also use The GIMP to take screen shots. To open The GIMP, press Alt + F2
and enter gimp. When you run GIMP for the first time, it installs some files in your
home directory and displays dialogs that give you the opportunity to adapt it to your
environment. For information about using The GIMP, refer to Chapter 17,Manipulating
Graphics with The GIMP (page 233) or see its help. You may need to install the help
with YaST (kdeutils3-extra).

1.11.5 Viewing PDF Files with KPDF
PDF is probably one of more important formats. KPDF is a KDE program that can view
and print them.

Start KPDF by pressing Alt + F2 and entering kpdf. Load a PDF file with File →
Open. KPDF displays it in its main window. On the left side, there is a sidebar with
thumbnails and a contents view. Thumbnails give an overview of the page. The contents
view contains bookmarks to navigate in your document. Sometimes it is empty, meaning
bookmarks are not supported by this PDF.
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To view two pages in the main window, select View → Two Pages. The view depends
on what last two options you activate in the View menu.

Another nice option is to select the area in which you are interested with the select tool
from the toolbar. Draw a rectangle and choose from the pop-up menu whether you need
the selected area as text or as a graphic. It is copied to the clipboard. You can even save
the area to a file.

1.11.6 Font Administration with KFontinst
By default, SUSE® Linux Enterprise Desktop provides various fonts commonly
available in different file formats (Bitmap, TrueType, etc.). These are known as system
fonts. Users can additionally install their own fonts from various collections on CD-
ROM. Such user-installed fonts are, however, only visible and available to the corre-
sponding user.

The KDE control center provides a comfortable tool for administering system and user
fonts. It is shown in Figure 1.20, “Font Administration from the Control Center”
(page 51).

Figure 1.20 Font Administration from the Control Center
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To check which fonts are currently available, type the URL fonts:/ into the address
field of a Konqueror session. This displays two windows: Personal and System.
User-installed fonts are installed to the folder Personal. Only root can install to the
System folder.

To install fonts as a user, follow these steps:

1. Start the Control Center and access the appropriate module with System Admin-
istration → Font Installer.

2. Choose Add Fonts from the toolbar or from the menu available when right-
clicking the list.

3. In the dialog that opens, select one or more fonts for installation.

4. The marked fonts are then installed to your personal font folder. Selecting a font
shows a preview.

To update system fonts, first select Administrator mode and enter your root password.
Then proceed as described for user font installation.

1.11.7 Controlling Sound with KMix
YaST identifies and configures the sound cards of your computer automatically. Other-
wise, start the YaST Hardware module and configure the sound card manually. When
your sound card has been configured, you can control the volume and balance of the
sound with a mixer.

TIP: Starting the Mixer

If the mixer icon (a loudspeaker symbol) is not visible in the panel of your
desktop, press Alt + F2 and enter kmix or start the mixer from the main menu.
You usually find it under Volume Control.

By default, clicking the KMix icon in the system tray shows the master controller where
you can increase or decrease the overall volume. To switch off the sound, click the
green LED, which darkens when it is muted. Toggle this option by clicking the LED
again. To fine-tune your sound settings for several channels, right-click the KMix icon
and select Show Mixer Window. In the main window, you can configure Output, Input,
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and Switches. Each of the devices featured there has its own context menu that is opened
by right-clicking the device icon. You can mute or hide each one of them separately.
For further information about KMix, refer to the online help.

Figure 1.21 The KMix Mixer

1.12 Managing Software
SUSE Linux Enterprise Desktop comes with a set of small helper applications that assist
you in managing your software collection. You can install, remove and update software
packages with just a few clicks.

1.12.1 Obtaining Software Updates
Novell offers a continuous stream of software security updates for your product. Using
the Software Updater applet in your desktop panel, you can easily apply security updates
with just a few clicks. Whenever you connect to the Internet, Software Updater auto-
matically checks whether updates for your system are available from the updated sources
specified in the Software Updater configuration and those set up during installation.

The Software Updater resides in the notification area (GNOME) or the system tray
(KDE) of your panel as an icon depicting a globe, which changes color depending on
the availability of a network link and new updates.
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Left-click the panel icon to launch the updater window where you can select the software
updates to be applied. Right-click the panel icon to access a menu with the following
items:

Configure
Select and configure additional update services and subscribe to additional catalogs.
See Section “Configuring Additional Packages Sources” (page 54) and Section
“Selecting Update Catalogs” (page 55).

Refresh
Poll the update server for pending updates.

TIP

For background information on the underlying rug command and its configu-
ration options, see Section 7.12, “Update from the Command Line” (Chapter 7,
System Configuration with YaST, ↑Deployment Guide) or refer to the rug man
page.

Configuring Additional Packages Sources
Apart from the official update source provided by Novell, you can configure Software
Updater to check additional package sources for updates. Ask your system administrator
for additional package sources that are available for your product and for connection
details.

To add a new package source, proceed as follows:

1 Right-click the Software Updater icon and click Configure.

Figure 1.22 Adding an Additional Package Source
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2 Click Add Service.

Figure 1.23 Determining the Service Type

3 Select the type of update repository from the drop-down list. Software Updater
currently supports YUM, RCE, ZENworks, and user-mounted sources.

4 Add the connection details for the source type you selected (server URI and
registration key) and click Add.

The source is listed in the Services tab and is ready to be used and checked for
available update packages.

Selecting Update Catalogs
The officially supported update catalogs were automatically selected when you registered
at the Novell update server. However, if you have added any custom installation sources,
you can select a set of catalogs from those sources to be checked in addition to the
preselected ones. There may be, for example, a catalog containing all the software that
came with the original release of the product and another one containing all the update
packages released since.

To select additional update catalogs, proceed as follows:

1 Right-click Software Updater and select Configure.

2 Select the Catalogs tab.
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Figure 1.24 Selecting a Catalog

3 Select the catalogs you want or deselect those you do not need and close the
configuration window by clicking the X in the upper right corner.

Selecting and Applying Updates
When updates are available, the panel icon changes color.

To review and apply updates, proceed as follows:

1 Click the panel icon.

2 Select from the list which updates you want to apply. Click Details for more in-
formation about the selected update.

Figure 1.25 Selecting the Software Updates
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3 Click Update.

1.12.2 Installing Software
Software Installer lets you install software on your machine.

To install software, proceed as follows:

1 Select Install Software from the main menu.

Figure 1.26 Selecting the Packages to Install

2 Select the software from the list that you want to install or search for software
by typing a search term in the search field and clicking Search. Click Details for
information about the selected software. You can select all available software
by clicking All.

3 Click Install.

Configuring Additional Packages Sources
You can add package sources from which you can install software.

To add a package source, proceed as follows:

1 Select Install Software from the main menu.

2 Click Configure.
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Figure 1.27 Adding an Additional Package Source

3 Click Add Service.

Figure 1.28 Determining the Service Type

4 Select the type of the update repository from the drop-down list. Software Installer
currently supports YUM, RCE, ZENworks, and user-mounted sources.

5 Add the connection details for the source type you selected (server URI and
registration key) and click Add.

The source is listed in the Services tab and is ready to be used and checked for
available packages.

Selecting Installation Catalogs
You can configure your Software Installer to accept additional catalogs.

To select additional installation catalogs, proceed as follows:

1 Select Install Software from the main menu.
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2 Click Configure.

3 Select the Catalogs tab.

Figure 1.29 Selecting a Catalog

4 Select the catalogs you want or deselect those you do not need and close the
configuration window by clicking the X in the upper right corner.

1.12.3 Removing Software
Software Remover lets you remove software from your machine.

To remove software, proceed as follows:

1 Select Remove Software from the main menu.
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Figure 1.30 Selecting the Software Packages to Remove

2 Select the software you want to remove. You can click Details for more informa-
tion about the selected software.

3 Click Remove.

1.13 For More Information
As well as the applications described here for getting started, KDE can run a lot of
other applications. Find detailed information about many important applications in the
other parts of this manual.

• To learn more about KDE and KDE applications, also refer to http://www.kde
.org/ and http://www.kde-apps.org/.

• To report bugs or add feature requests, go to http://bugs.kde.org/.
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2Customizing Your Settings
You can change the way your KDE desktop looks and behaves to suit your own personal
tastes and needs. If you only want to change the appearance of individual desktop objects,
you can usually access a configuration dialog by right-clicking the object. For customiz-
ing certain groups of desktops elements or changing the overall appearance of your
KDE desktop, refer to Section 2.2, “Configuring Your Desktop with the Control Center”
(page 64).

2.1 Changing Individual Desktop
Elements

In the following, find some examples of how to change individual desktops elements.

Procedure 2.1 Creating New Desktop Objects

To add a new desktop object, proceed as follows:

1 Right-click an empty space on the desktop and select Create New.

2 From the submenu, choose the type of object to create on the desktop: a folder
or one of several types of files or links.

3 Enter the name of the new object when prompted to do so and click OK.
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4 To change the properties of the new object, right-click the new icon and select
Properties. A dialog appears, showing four tabs where you can change the
properties of the object, such as the permissions.

5 Apply your changes and leave the dialog with OK.

Procedure 2.2 Changing Panel Elements

Add new elements to the quick launch area and the system tray in the panel as follows:

1 Right-click an empty patch of the panel.

2 To add a new application to the panel:

a From the context menu, select Add Application to Panel.

b Select the application to add from one of the categories of the submenu.
The application icon is inserted into the panel.

c To change the icon for the application, right-click the button and select
Configure Application Button. By clicking the application icon in the dialog
box that appears, open a new window in which to select a different icon.

d To remove the icon from the panel, right-click the icon and select Remove
Button.

3 To add a new applet to the panel:

a From the context menu select Add Applet to Panel.

b In the dialog box that appears, you can restrict the number of applets shown
by selecting a special type of applet in Show or by typing a part of the applet
name in Search.
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Figure 2.1 Adding an Applet to the Panel

c Select the applet to add and click Add to Panel. The applet is inserted into
the panel.

d To remove the applet from the panel, right-click the icon and select Quit.
When the context menu of the applet does not provide a Quit menu item,
hold the mouse pointer over the left-side boundary of the area and right-
click the small black arrow displayed there. Select Remove.

4 To move an application icon to a different position in the panel, right-click the
icon and select Move. The mouse pointer changes into a crosshair. Drag the
pointer to the place in the panel where you want to insert the icon then press the
left mouse button. The icon is inserted at the new position.

5 In the same way, you can also move areas of the panel, such as the desktop pre-
viewer, the taskbar, and the system tray: Hold the mouse pointer over the
boundary of the area and click the small black arrow displayed there. From the
context menu, select Move. Click again to insert the area at the new position.

Customizing Your Settings 63



2.2 Configuring Your Desktop with
the Control Center

With KDE, you can personalize your desktop to a very high degree. You can change a
variety of settings, such as the desktop background, screen saver, fonts, keyboard and
mouse configuration, and sounds. Adjust these settings with the modules of the KDE
Control Center. Start the Control Center from the main menu by selecting Personal
Settings or press Alt + F2 and enter kcontrol.

Figure 2.2 KDE Control Center

The sidebar provides different categories with a subset of settings each. Just click a
category icon and explore the possibilities provided there. You can always return to
the higher-level category by clicking Back. For an overview of all categories, switch
to a tree view. Change the view by selecting View → Mode → Tree View.

Clicking an item displays the corresponding settings on the right. Change the settings
as desired. No changes take effect until you click Apply. If you have changed an option
then decide that you want to leave the settings as they were, click Reset to discard the
changes. Reset all items on the page to the default values by clickingDefault. Changing
some settings may require root permissions. Log in as root if prompted to do so.
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The following sections introduce the major categories and contain procedures for some
common changes you may want to apply to your KDE desktop. Detailed information
about the settings of each category is provided by the Help button on each page of set-
tings or in the help center.

2.2.1 Appearance & Themes
This category lets you change the way your KDE desktop and applications look. You
can access a number of settings.

Background holds options for the background of your desktop, such as colors, pictures,
or slide shows. If you configured multiple virtual desktops, you can set different options
for each. See Section 2.2.2, “Desktop” (page 67).

Colors lets you manage and edit color schemes for your desktop. There are a variety
of color schemes installed by default, but you can also create your own color scheme
using a predefined scheme as starting point.

With Fonts, all fonts and font attributes used on the KDE desktop can be configured.
You can also modify antialiasing settings. By default, antialiasing is activated for all
fonts. Antialiasing is a software technique for diminishing jagged edges that should be
smooth. Although it reduces the jagged appearance of the lines, it also makes them
fuzzier. To deactivate or customize antialiasing, select the corresponding options.

In the Icons section, control the icon style for the entire KDE desktop. Icons are used
on the desktop, panel, and toolbars of applications. You can choose icon themes, adjust
icon sizes, assign effects to icons (for example, you can make them semitransparent or
colorize them), and configure settings for each of the different places icons are used.

Launch Feedback allows you to modify what kind of cursor and taskbar feedback you
want for starting applications. For example, instead of a bouncing cursor indicating that
an application is loading, you can set a blinking cursor.

A screen saver automatically appears if you do not use your computer for a specific
time. In the Screensaver section, change the screen saver or configure the time-out before
it starts.

In the Splash Screen section, you can change the splash screen that displays on KDE
start-up.
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Style holds options for user interface elements (called widgets) in KDE, such as buttons,
menus, and scroll bars. You can choose a certain style and see a preview of it.

With Theme Manager, choose, install, or modify configuration sets (themes) for your
KDE desktop.

Window Decorations provides options for the title bar of the windows and the style of
the borders around windows.

Procedure 2.3 Changing Your Desktop Background

If you want to change your desktop background, for example, proceed as follows:

1 Start the Control Center from the main menu or press Alt + F2 and enter
kcontrol.

2 Click Appearance & Themes → Background.

3 In Settings for Desktop select the virtual desktop to which the changes should
apply.

Figure 2.3 Changing the Background Picture

4 If you want to change the picture on the background, click Picture and select one
of the pictures provided by the list. To use a custom picture, click the folder
button beneath the list and select an image file from the file system.
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5 Choose a certain Position for your picture in the Options group.

6 If you do not want a certain picture on the background, click No picture.

7 From the Options group, click the left button below Colors to select the color
for your background. For a multicolor background, set Colors to an option other
than Single Color and click the right button below to select a second color.

Figure 2.4 Setting a Background Color for your Desktop

8 When all options are set according to your wishes, click Apply.

2.2.2 Desktop
The Desktop settings configure the appearance and behavior of your KDE desktop.

In Behavior, configure options such as showing or hiding desktop icons, showing tool
tips, and icon layout. You can also specify if you want to see previews of particular file
types on the desktop and which devices have icons.

InMultiple Desktops, increase or reduce the number of virtual desktops to use and enter
a name for each desktop. By default, two virtual desktops are configured on your system.
You can switch between the desktops with the desktop previewer in the panel or by
using the mouse wheel.
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Panels controls panel options such as size, position, length, and display. You can also
change the appearance of the panel with transparency, background images, and icon
zooming. Because the main menu is also part of the panel, also configure various menu
options here, including the applications shown in your main menu.

In the Taskbar section, configure options such as whether to show windows from all
desktops on the taskbar, grouping of similar tasks, and what action on the taskbar your
mouse buttons trigger.

Window Behavior customizes the default KDE window manager, kwin. Here, control
what happens when windows are moved, clicked, or resized. You can bind actions to
certain keys and mouse events.

Window-Specific Settings lets you customize settings that only apply to some windows.
It only takes effect if you use KWin as your window manager.

Procedure 2.4 Configuring the Main Menu

If you want to configure your main menu, proceed as follows:

1 Start the Control Center from the main menu or press Alt + F2 and enter
kcontrol.

2 Click Desktop → Panels.

Figure 2.5 Editing the Main Menu
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3 Click the Menus tab.

4 You can define whether you want to see the applications names or the descriptive
text (or both) in the main menu. Select from Name only, Name (Description),
Description only, and Description (name).

5 If you want to change a menu item, clickEdit KMenu. The K Menu Editor shows
a list of menu items on the left.

a Click the item in the list and change its options on the right.

b You can add new menu items, submenus, or separators with the File menu
or the toolbar.

c To cut, copy, paste, or delete objects in the main menu, use the Edit menu
or the icons in the toolbar.

d To apply your changes in the K Menu Editor, click File → Quit.

6 To apply all of your changes in the Menus tab and close the KDE Control Center,
click Apply .

2.2.3 Internet & Network
The Internet & Network category helps you configure Internet and networking options.

Two sections deal with how to manage your Bluetooth devices and services: Paired
Bluetooth Devices and Bluetooth Services. To learn more about Bluetooth, refer to
Section 28.2, “Bluetooth” (Chapter 28,Wireless Communication, ↑Deployment Guide).
In the Connection Preferences section, KDE lets you change the time-out values for
different connections.

Desktop Sharing is useful if you want to invite other people to your desktops. Only let
trustworthy users take part in your session.

File Sharing allows you to configure Samba (Windows) and NFS (UNIX) file sharing.
The settings can only be changed if you are an administrator. If you log in as root,
you can add, change, or remove folders to share with others.
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Use Local Network Browsing if you want to browse a local network. It is like “Network
Neighborhood.” Take into account that you may need some additional software, espe-
cially the LISa daemon (see package kdenetwork3-lisa).

In Proxy, you can customize proxy and SOCKS servers. Normally, if your administrator
does not tell you to use this, it is probably not useful for you.

The settings in Samba should only be configured with YaST.

Web Browser offers settings for the default KDE browser, Konqueror. For example,
you can customize fonts, manage cookies, and determine Web behavior, such Web
shortcuts. For more information about how to use Web shortcuts, refer to Section 13.5.2,
“Using Web Shortcuts” (page 212).

2.2.4 KDE Components
This category holds advanced KDE options, such as the default application to open
when clicking a link.

The Component Chooser module handles basic tasks. You can change the default e-
mail client, text editor, messenger, terminal, and Web browser. Whenever a KDE appli-
cation needs to start an application of these types, it always calls the default component
set here.

KDE uses File Associations to identify a file type and start an appropriate application.
Here, you can also choose which icon represents each file type and whether to show
files of a certain type in an embedded or a separate viewer.

The File Manager module configures the behavior of Konqueror as a file manager.
Here, define which fonts and font sizes to use, the path to your home directory, if pre-
views are allowed, and if quick copy and move actions are allowed.

In KDE Performance , you can optimize the performance of your KDE desktop.

An overview of all plug-ins of the KDE daemon is shown in Service Manager. This
module shows two different types: services invoked on start-up and services called on
demand. Normally, do not change the settings of this module, because it is vital for
KDE.
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In Session Manager, define how KDE handles sessions on login and shutdown. By
default, KDE remembers your previous session and restores the applications you were
using the next time you login. You can define different options here, such as excluding
individual applications from being restored.

Spell Checker lets you modify what spell checker to use, what types of errors to check
for, and the default dictionary to use. The KDE spell checking system (KSpell) provides
support for several spell checking utilities: the most commonly used are ASpell and
ISpell. For more information, see also ASpell [http://aspell.sourceforge
.net] and ISpell [http://fmg-www.cs.ucla.edu/fmg-members/geoff/
ispell.html].

2.2.5 Peripherals
This category holds settings for various devices that can be plugged in to your computer,
such as a digital camera, display, keyboard, and mouse.

Digital Camera lets you configure support for your digital camera. You can add your
camera model and define the type of port by which it is connected to your computer.

With Display, modify your display options, such as screen size and power control if
supported by your display.

Joystick helps to check whether your joystick is working correctly. You can adjust the
calibration.

The Keyboard section allows you to modify basic keyboard settings such as keyboard
repeat delay.

You can also adjust many Mouse settings, such as actions to trigger by single or double
clicking, cursor themes, and double-click intervals.

With OBEX Devices, configure OBEX connections for your devices, such as PDAs.

Remote Controls allows you to configure bindings between your remote controls and
KDE applications.
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2.2.6 Regional & Accessibility
This category holds regional settings as well as options for handicapped users.

In Accessibility, configure functions that can help individuals with difficulties in hearing
or motor function. These include certain sound and keyboard options.

The Country/Region & Language section lets you configure options that are specific
for your location, such as language, currency, and number and date format.

In Input Actions, configure mouse gestures and keyboard shortcuts for starting applica-
tions and running commands.

In the Keyboard Layout section, find multiple layouts for different languages. If Enable
Keyboard Layouts is selected, you can add and activate several keyboard layouts, such
as English and German, and switch between them. Fine-tune them in the Xkb Options
tab.

In theKeyboard Shortcuts section, you can define global KDE shortcuts. For an overview
of the currently active shortcuts, refer to the list of Global Shortcuts. You can also
choose a different, predefined shortcut scheme, such as a Windows or Mac scheme.

2.2.7 Security & Privacy
This category holds settings for personal security certificates, KWallet, password
treatment, and privacy settings.

To make KDE more secure, Crypto allows you to configure SSL (secure socket layer).
This is used in most KDE applications as well as others. There is also a possibility to
manage your personal certificates.

KDEWallet allows you to configure the KDE Wallet system, KWallet. It saves sensitive
information, such as passwords and form data, for several applications in a strongly
encrypted file, protected with a master password that you define. For information about
using KWallet, see Section 1.11.2, “Managing Passwords with KWallet Manager”
(page 45).

To change your personal settings, go to Password & User Account. Here, set a new
name, organization, e-mail address, SMTP server, or password.
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The Privacy module manages personal Web browsing data. For example, use it to clear
the cache, delete the history of visited Web sites, or remove unwanted cookies.

2.2.8 Sound & Multimedia
Use this category to perform all settings for the playback of audio CDs and for the
sound system.

In Audio CDs, configure encoding and device settings.

With Sound System, configure aRts, KDE's sound server. This allows you to hear your
system sound while simultaneously listening to a music CD.

With System Bell, switch from system notifications (default) to a system bell and
specify the volume, pitch, and duration of the bell.

The System Notifications section defines how the system should inform you in the event
of a problem, when a task is performed, or if an event requiring your immediate attention
occurs. In the upper part of the dialog, select the application for which to configure the
system notifications. As soon as you select a program, all events the application can
send to the user are listed in the lower window. Determine the notification type for each
notification in the Actions dialog.

The default view of the system notification dialog only offers Play a sound for audible
notification. Click More Options to access other action modes. You can log the notifi-
cation to a file, execute a program, or show the message in a pop-up window. In the
lower part of the dialog under Quick Controls, globally activate or deactivate the actions
for all programs.

2.2.9 System Administration
This category offers options for central system tasks. Most of the sections require root
permission to make changes.

With Font Installer, you can install personal or systemwide fonts. To change system
fonts, click Administrator Mode.
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The module Linux Kernel only takes effect if you have installed the source of your
kernel. It is only useful if you are a developer compiling a new kernel and want to
customize some options.

Login Manager configures the KDE login manager, KDM. You can change the appear-
ance, fonts used, background shown, shutdown behavior, what users are displayed at
login, and some convenience issues for the login screen.

The Path section defines the paths to some important directories for your data:
desktop, autostart, and documents.
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Part II. Office and Collaboration





3The OpenOffice.org Office
Suite
OpenOffice.org is a powerful open-source office suite that provides tools for all types
of office tasks, such as writing texts, working with spreadsheets, or creating graphics
and presentations. With OpenOffice.org, you can use the same data across different
computing platforms. You can also open and edit files in other formats, including Mi-
crosoft Office, then save them back to this format, if needed. This chapter covers infor-
mation about the Novell® edition of OpenOffice.org and some of the key features you
should be aware of when getting started with the suite.

OpenOffice.org consists of several application modules (subprograms), which are de-
signed to interact with each other. They are listed in Table 3.1, “The OpenOffice.org
Application Modules” (page 77). A full description of each module is available in the
online help, described in Section 3.8, “Finding Help and Information About OpenOf-
fice.org” (page 108).

Table 3.1 The OpenOffice.org Application Modules

PurposeModule

Word processor application moduleWriter

Spreadsheet application moduleCalc

Presentation application moduleImpress

Database application moduleBase
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PurposeModule

Application module for drawing vector graphicsDraw

Application module for generating mathematical formulasMath

The appearance of the application varies depending on the desktop or window manager
you use. Regardless of the appearance, the basic layout and functions are the same.

3.1 Understanding OpenOffice.org
This section contains information that applies to all of the application modules in
OpenOffice.org. Module-specific information can be found in the sections relating to
each module.

3.1.1 What’s New in OpenOffice.org 2.0
OpenOffice.org 2.0 contains many improvements and features that were not included
in earlier versions. The biggest new feature is the Base database module. There have
been many other changes since the previous version, such as enhanced PDF export and
improved word count capabilities. For a complete list of features, fixes, and enhance-
ments, go to the OpenOffice.org Web site (http://www.openoffice.org/dev
_docs/features/2.0/).

3.1.2 Enhancements in the Novell Edition of
OpenOffice.org 2.0

The Novell Edition of OpenOffice.org included with SUSE® Linux Enterprise Desktop
contains enhancements that are not available in the standard edition. These include:

3.1.2 Integration with SUSE Linux Enterprise Desktop
The Novell Edition of OpenOffice.org features redesigned tool bar icons for maximum
consistency with SUSE Linux Enterprise Desktop, including support for desktop ap-
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pearance or theme changes. These features provide a consistent interface across the
Linux desktop, which enhances overall usability and helps minimize enterprise training
and support requirements.

3.1.2 Native Desktop Dialogs
The Novell Edition of OpenOffice.org uses your desktop’s native file dialogs rather
than those in the standard edition. This provides the same look and feel of other appli-
cations in your environment, giving you a consistent, familiar experience.

3.1.2 Enhanced Support for Microsoft Office File
Formats

OpenOffice.org supports import and export of Microsoft Office file formats, even taking
advantage of compatible fonts to match document length. Transparent document sharing
makes OpenOffice.org the best choice if you are deploying Linux desktops in a mixed
Linux/Windows environment.

3.1.2 E-Mail as Microsoft Office Document
The standard edition of OpenOffice.org supports e-mailing of files as PDF files from
within the OpenOffice.org application. With the Novell Edition of OpenOffice.org, you
can also e-mail any document as a Microsoft Office file. For example, you can e-mail
a Writer file as a Microsoft Word file. If that option is selected, the file is automatically
converted and attached to an e-mail in your default e-mail application.

3.1.2 Excel VBA Macro Interoperability
The Novell Edition of OpenOffice.org eases the migration of many macros from Mi-
crosoft Excel. Although not all macros can be successfully migrated, this interoperabil-
ity offers more than the standard edition, which does not support migration of macros.

3.1.2 Enhanced Fonts
For the Novell Edition of OpenOffice.org, Novell licensed fonts from AGFA that use
the same or similar names as the fonts available in Microsoft Office. The fonts also
look similar to those used by Microsoft. This allows OpenOffice.org to match fonts
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when opening documents originally composed in Microsoft Office, and very closely
match pagination and page formatting.

3.1.2 Integration with Novell Evolution
The Novell Edition of OpenOffice.org is tightly integrated with Novell Evolution™,
allowing users to send documents as e-mail and to perform mail merges using the
Evolution address book as a datasource.

3.1.2 Improved File Access
Files are available from any source available to the computer. Network files open and
save seamlessly.

3.1.2 Anti-aliased Presentation Graphics
With hardware acceleration enabled (the default), the Novell Edition of OpenOffice.org
provides higher-quality graphics in Impress slide shows.

3.1.2 Faster Start-up Times
The Novell Edition of OpenOffice.org includes an improved built-in quickstarter that
loads OpenOffice.org components at system startup and thus improves the application’s
start-up time. Subsequent document load times have also been improved.

3.1.3 Using the Standard Edition of
OpenOffice.org

The standard edition of OpenOffice.org also works with SLED. If you install the latest
version of OpenOffice.org, all of your Novell Edition files remain compatible. However,
the standard edition does not contain the Novell enhancements.
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3.1.4 Compatibility with Other Office
Applications

OpenOffice.org can work with documents, spreadsheets, presentations, and databases
in many other formats, including Microsoft Office. They can be seamlessly opened like
other files and saved back to the original format. Because the Microsoft formats are
proprietary and the specifications are not available to other applications, there are occa-
sionally formatting issues. If you have problems with your documents, consider opening
them in the original application and resaving in an open format such as RTF for text
documents or CSV for spreadsheets.

TIP

For good information about migrating from other office suites to OpenOf-
fice.org, refer to the OpenOffice.org Migration Guide (http://
documentation.openoffice.org/manuals/oooauthors2/
0600MG-MigrationGuide.pdf).

Converting Documents to the OpenOffice.org Format
OpenOffice.org can read, edit, and save documents in a number of formats. It is not
necessary to convert files from those formats to the OpenOffice.org format to use those
files. However, if you want to convert the files, you can do so. To convert a number of
documents, such as when first switching to OpenOffice.org, do the following:

1 Select File → Wizard → Document Converter.

2 Choose the file format from which to convert.

There are several StarOffice and Microsoft Office formats available.

3 Click Next.

4 Specify where OpenOffice.org should look for templates and documents to
convert and in which directory the converted files should be placed.
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IMPORTANT

Documents from a Windows partition are usually in a subdirectory of
/windows.

5 Make sure that all other settings are appropriate, then click Next.

6 Review the summary of the actions to perform, then start the conversion by
clicking Convert.

The amount of time needed for the conversion depends on the number of files
and their complexity. For most documents, conversion does not take very long.

Sharing Files with Users of Other Office Suites
OpenOffice.org is available for a number of operating systems. This makes it an excellent
tool when a group of users frequently need to share files and do not use the same system
on their computers.

When sharing documents with others, you have several options.

If the recipient needs to be able to edit the file: Save the document in the format
the other user needs. For example, to save as a Microsoft Word file, click File → Save
As, then select the Microsoft Word file type for the version of Word the other user
needs.

If the recipient only needs to read the document: Export the document to a PDF
file with File → Export as PDF. PDF files can be read on any platform using a viewer
like Adobe Acrobat Reader. ,

If you want to share a document for editing: Use one of the standard document
formats. The default formats comply with the OASIS standard XML format, making
them compatible with a number of applications. TXT and RTF formats, although limited
in formatting, might be a good option for text documents. CSV is useful for spreadsheets.
OpenOffice.org might also offer your recipient's preferred format, especially Microsoft
formats.

If you want to e-mail a document as a PDF: Click File → Send → Document as
PDF Attachment.Your default e-mail program opens with the file attached.
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If you want to e-mail a document to a Microsoft Word user: Click File → Send
→ Document as MS-Doc Attachment. Your default e-mail program opens with the file
attached.

3.1.5 Starting OpenOffice.org
1 Start the application in one of the following ways:

•
On the menu bar, click .

This opens Writer. To open a different module, click File → New from the
newly opened Writer document, then choose the module you want to open.

• From the Computer menu, click Computer → More Applications → Office,
then click the name of the OpenOffice.org module you want to start.

• In a terminal window, enter ooffice. The OpenOffice.org window opens.
Click File → New, then choose the module you want to open.

2 Select the module you want to open.

If any OpenOffice.org application is open, you can open any of the other applications
by clicking File → New → Name of Application.

3.1.6 Improving OpenOffice.org Load Time
To speed up the load time of OpenOffice.org by preloading the application at system
startup:

1 Click Tools → Options → Memory.

2 Select Start at Startup.

The next time you restart your system, OpenOffice.org will preload. When you open
an OpenOffice.org application module, it will open faster.
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3.1.7 Customizing OpenOffice.org
You can customize OpenOffice.org to best suit your needs and working style. Toolbars,
menus, and keyboard shortcuts can all be reconfigured to help you more quickly access
the features you use the most. You can also assign macros to application events if you
want specific actions to occur when those events take place. For example, if you always
work with a specific spreadsheet, you can create a macro that opens the spreadsheet
and assign it to the Start Application event.

This section contains simple, generic instructions for customizing your environment.
The changes you make are effective immediately, so you can see if the changes are
what you wanted and go back and modify them if they weren’t. See the OpenOffice.org
help files for detailed instructions.

Customizing Toolbars
Use the Customize dialog to modify OpenOffice.org toolbars.

1 Click the arrow icon at the end of any toolbar.

2 Click Customize Toolbar.

3 Select the toolbar you want to customize.

4 Select the check boxes next to the commands you want to appear on the toolbar,
and deselect the check boxes next to the commands you don’t want to appear.

5 Select whether to save your customized toolbar in the OpenOffice.org module
you are using or in the document.

• OpenOffice.org module

The customized toolbar is used whenever you open that module.

• Document filename

The customized toolbar is used whenever you open that document.

6 Repeat to customize additional toolbars.
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7 Click OK.

You can quickly choose the buttons that appear on a particular toolbar.

1 Click the arrow icon at the end of the toolbar you want to change.

2 Click Visible Buttons to display a list of buttons.

3 Select the buttons in the list that appears to enable (check) or disable (uncheck)
them.

Customizing Menus
You can add or delete items from current menus, reorganize menus, and even create
new menus.

1 Click Tools → Customize → Menu.

2 Select the menu you want to change, or click New to create a new menu.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete menu items as desired.

4 Click OK.

Customizing Keyboard Shortcuts
You can reassign currently assigned keyboard shortcuts and assign new shortcuts to
frequently used functions.

1 Click Tools → Customize → Keyboard.

2 Select the keys you want to assign to a function, or select the function and assign
the keys or key combinations.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete keyboard shortcuts as desired.
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4 Click OK.

Customizing Events
OpenOffice.org also provides ways to assign macros to events such as application
startup or the saving of a document. The assigned macro runs automatically whenever
the selected event occurs.

1 Click Tools → Customize → Events.

2 Select the event you want to change.

Click Help for more information about the options in the Customize dialog box.

3 Assign or remove macros for the selected event.

4 Click OK.

Changing the Global Settings
Global settings can be changed in any OpenOffice.org application by clicking Tools
→ Options on the menu bar. This opens the window shown in the figure below. A tree
structure is used to display categories of settings.

Figure 3.1 The Options Window
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The following table lists the settings categories along with a brief description of each
category:

Table 3.2 Global Setting Categories

DescriptionSettings Category

Various basic settings, including your user data (such as your
address and e-mail), important paths, and settings for printers
and external programs.

OpenOffice.org

Includes the settings related to the opening and saving of
several file types. There is a dialog for general settings and

Load/Save

several special dialogs to define how external formats should
be handled.

Covers the various settings related to languages and writing
aids, such as your locale and spell checker settings. This is
also the place to enable support for Asian languages.

Language Settings

Includes the dialogs to configure any proxies and to change
settings related to search engines.

Internet

Configures the global word processing options, such as the
basic fonts and layout that Writer should use.

Text Document

Changes the settings related to the HTML authoring features
of OpenOffice.org.

HTML Document

Changes the settings for Calc, such as those related to sort
lists and grids.

Spreadsheet

Changes the settings that should apply to all presentations.
For example, you can specify the measurement unit for the
grid used to arrange elements.

Presentation

Includes the settings related to the vector drawing module,
such as the drawing scale, grid properties, and some print
options.

Drawing
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DescriptionSettings Category

Provides a single dialog to set special print options for formu-
las.

Formula

Defines the default colors used for newly created charts.Chart

Defines how external data sources should be accessed.Data Sources

IMPORTANT

All settings listed in the table are applied globally. They are used as defaults
for every new document you create.

3.1.8 Finding Templates
Templates greatly enhance the use of OpenOffice.org by simplifying formatting tasks
for a variety of different types of documents. OpenOffice.org comes with a few tem-
plates, and you can find additional templates on the Internet. You can also create your
own. Creating templates is beyond the scope of this guide, but detailed instructions are
found in the OpenOffice.org help system and in other documents and tutorials available
online.

In addition to templates, you can find other extras and add-ins online. The following
table lists a few of the prominent places where you can find templates and other extras.
(Because Web sites often close or their content changes, the information in the following
table might not be current when you read it.)

Table 3.3 Where to Find OpenOffice.org Templates and Extras

What You Can FindLocation

Templates for Calc spreadsheets,
CD cases, seed packets, fax cover
sheets, and more

OpenOffice.org documentation Web site
(http://documentation.openoffice
.org/Samples_Templates/User/
template_2_x/index.html)
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What You Can FindLocation

Templates for many types of labelsWorldlabel.com (http://www
.worldlabel.com/Pages/
openoffice-template.htm)

For more information about templates, see Section 3.2.4, “Using Templates to Format
Documents” (page 94) and Section 3.3.2, “Using Templates in Calc” (page 100).

3.2 Word Processing with Writer
OpenOffice.org Writer is a full-featured word processor with page and text formatting
capabilities. Its interface is similar to interfaces for other major word processors, and
it includes some features that are usually found only in expensive desktop publishing
applications.

This section highlights a few key features of Writer. For more information about these
features and for complete instructions for using Writer, look at the OpenOffice.org help
or any of the sources listed in Section 3.8, “Finding Help and Information About
OpenOffice.org” (page 108).

NOTE

Much of the information in this section can also be applied to other OpenOf-
fice.org modules. For example, other modules use styles similarly to how they
are used in Writer.

3.2.1 Creating a New Document
There are two ways to create a new document:

To create a document from scratch, click File → New → Text Document.

To use a standard format and predefined elements for your own documents, try a wizard.
Wizards are small utilities that let you make some basic decisions then produce a ready-
made document from a template. For example, to create a business letter, click File →
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Wizards → Letter. Using the wizard's dialogs, easily create a basic document using a
standard format. A sample wizard dialog is shown in Figure 3.2, “An OpenOffice.org
Wizard” (page 90).

Figure 3.2 An OpenOffice.org Wizard

Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use theFilemenu or the relevant buttons
in the toolbar to print and save your document. With the options under Insert, add extra
items to your document, such as a table, picture, or chart.

3.2.2 Sharing Documents with Other Word
Processors

You can use Writer to edit documents created in a variety of other word processors.
For example, you can import a Microsoft Word document, edit it, and save it again as
a Word document. Most Word documents can be imported into OpenOffice.org without
any problem. Formatting, fonts, and all other aspects of the document remain intact.
However, some very complex documents—such as documents containing complicated
tables, Word macros, or unusual fonts or formatting—might require some editing after
being imported. OpenOffice.org can also save in many popular word processing formats.
Likewise, documents created in OpenOffice.org and saved as Word files can be opened
in Microsoft Word without any trouble.
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So, if you use OpenOffice.org in an environment where you frequently share documents
with Word users, you should have little or no trouble exchanging document files. Just
open the files, edit them, and save them as Word files.

3.2.3 Formatting with Styles
OpenOffice.org uses styles for applying consistent formatting to various elements in a
document. The following types of styles are available:

Table 3.4 About the Types of Styles

What it DoesType of
Style

Applies standardized formatting to the various types of paragraphs in
your document. For example, apply a paragraph style to a first-level

Paragraph

heading to set the font and font size, spacing above and below the
heading, location of the heading, and other formatting specifications.

Applies standardized formatting for types of text. For example, if you
want emphasized text to appear in italics, you can create an emphasis
style that italicizes selected text when you apply the style to it.

Character

Applies standardized formatting to frames. For example, if your doc-
ument uses sidebars, you can create frames with specified graphics,

Frame

borders, location, and other formatting so that all of your sidebars have
a consistent appearance.

Applies standardized formatting to a specified type of page. For exam-
ple, if every page of your document contains a header and footer except

Page

for the first page, you can use a first page style that disables headers
and footers. You can also use different page styles for left and right
pages so that you have bigger margins on the insides of pages and
your page numbers appear on an outside corner.

Applies standardized formatting to specified list types. For example,
you can define a checklist with with square check boxes and a bullet

List
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What it DoesType of
Style

list with round bullets, then easily apply the correct style when creating
your lists.

Opening the Styles and Formatting Window
The Styles and Formatting window (called the Stylist in earlier versions of OpenOf-
fice.org), is a versatile formatting tool for applying styles to text, paragraphs, pages,
frames, and lists. To open this window, click Format Styles and Formatting. OpenOf-
fice.org comes with several predefined styles. You can use these styles as they are,
modify them, or create new styles.

TIP

By default, the Styles and Formatting window is a floating window; that is, it
opens in its own window that you can place anywhere on the screen. If you
use styles extensively, you might find it helpful to dock the window so that it
always present in the same part of the Writer interface. To dock the Styles and
Formatting window, press Control while you double-click on a gray area in the
window. This tip applies to some other windows in OpenOffice.org as well, in-
cluding the Navigator.

Applying a Style
To apply a style, select the element you want to apply the style to, and then double-
click the style in the Styles and Formatting window. For example, to apply a style to a
paragraph, place the cursor anywhere in that paragraph and double-click the desired
style.

Using Styles Versus Using Formatting Buttons and
Menu Options
Using styles rather than the Format menu options and buttons helps give your pages,
paragraphs, texts, and lists a more consistent look and makes it easier to change your
formatting. For example, if you emphasize text by selecting it and clicking the Bold
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button, then later decide you want emphasized text to be italicized, you need to find all
of your bolded text and manually change it to italics. If you use a character style, you
only need to change the style from bold to italics and all text that has been formatted
with that style automatically changes from bold to italics.

Text formatted with a menu option or button overrides any styles you have applied. If
you use the Bold button to format some text and an emphasis style to format other text,
then changing the style does not change the text that you formatted with the button,
even if you later apply the style to the text you bolded with the button. You must man-
ually unbold the text and then apply the style.

Likewise, if you manually format your paragraphs using Format → Paragraph, it is
easy to end up with inconsistent paragraph formatting. This is especially true if you
copy and paste paragraphs from other documents with different formatting.

Changing a Style
Styles are powerful because you can change formatting throughout a document by
changing a style, rather than applying the change separately everywhere you want to
apply the new formatting.

1 In the Styles and Formatting window, right-click the style you want to change.

2 Click Modify.

3 Change the settings for the selected style.

For information about the available settings, refer to the OpenOffice.org online
help.

4 Click OK.

Creating a Style
OpenOffice.org comes with a collection of styles to suit many users’ needs. However,
most users eventually need a style that does not yet exist. To create a new style:

1 Right-click in any empty space in the Styles and Formatting window.
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Make sure you are in the list of styles for the type of style you want to create.
For example, if you are creating a character style, make sure you are in the
character style list.

2 Click New.

3 Click OK.

4 Name your style and choose the settings you want applied with that style.

For details about the style options available in any tab, click that tab and then
click Help.

3.2.4 Using Templates to Format Documents
Most word processor users create more than one kind of document. For example, you
might write letters, memos, and reports, all of which look different and require different
styles. If you create a template for each of your document types, the styles you need
for each document are always readily available.

Creating a template requires a little bit of up-front planning. You need to determine
what you want the document to look like so you can create the styles you need in that
template. You can always change your template, but a little planning can save you a
lot of time later.

NOTE

You can convert Microsft Word templates like you would any other Word
document. See Section “Converting Documents to the OpenOffice.org Format”
(page 81) for information.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system, and detailed how-tos are found at the
OpenOffice.org Documentation page (http://documentation.openoffice
.org/HOW_TO/index.html).
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Creating a Template
A template is a text document containing only the styles and content that you want to
appear in every document, such as your address information and letterhead on a letter.
When a document is created or opened with the template, the styles are automatically
applied to that document.

To create a template:

1 Click File → New → Text Document.

2 Create the styles and content that you want to use in any document that uses this
template.

3 Click File → Templates → Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.

3.2.5 Working with Large Documents
You can use Writer to work on large documents. Large documents can be either a single
file or a collection of files assembled into a single document.

Navigating in Large Documents
The Navigator tool displays information about the contents of a document. It also lets
you quickly jump to different elements. For example, you can use the Navigator to get
a quick overview of all images included in the document.

To open the Navigator, click Edit → Navigator. The elements listed in the Navigator
vary according to the document loaded in Writer.
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Figure 3.3 Navigator Tool in Writer

Click an item in the Navigator to jump to that item in the document.

Creating a Single Document from Multiple
Documents
If you are working with a very large document, such as a book, you might find it easier
to manage the book with a master document, rather than keeping the book in a single
file. A master document enables you to quickly apply formatting changes to a large
document or to jump to each subdocument for editing.

A master document is a Writer document that serves as a container for individual
Writer files. You can maintain chapters or other subdocuments as individual files col-
lected in the master document. Master documents are also useful if multiple people are
working on a document. You can separate each person’s portion of the document into
subdocuments collected in a master document, allowing multiple writers to work on
their subdocuments at the same time without fear of overwriting other people’s work.

NOTE

If you are coming to OpenOffice.org from Microsoft Word, you might be ner-
vous about using master documents because the master document feature in
Word has a reputation for corrupting documents. This problem does not exist
in OpenOffice.org Writer, so you can safely use master documents to manage
your projects.
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To create a master document:

1 Click New → Master Document.

or

Open an existing document and click File → Send → Create Master Document.

2 Insert subdocuments.

3 Click File → Save.

The OpenOffice.org help files contain more complete information about working with
master documents. Look for the topic entitled “Using Master Documents and Subdoc-
uments.”

TIP

The styles from all of your subdocuments are imported into the master docu-
ment. To ensure that formatting is consistent throughout your master document,
you should use the same template for each subdocument. Doing so is not
mandatory; however, if subdocuments are formatted differently, you will
probably need to do some reformatting to successfully bring subdocuments
into the master document without creating inconsistencies. For example, if two
documents imported into your master document include different styles with
the same name, the master document will use the formatting specified for that
style in the first document you import.

3.2.6 Using Writer as an HTML Editor
In addition to being a full-featured word processor, Writer also functions as an HTML
editor. Writer includes HTML tags that can be applied as you would any other style in
a Writer document. You can view the document as it will appear online, or you can
directly edit the HTML code.

Creating an HTML Document
1 Click File → New → HTML Document.
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2 Click the arrow at the bottom of the Formatting and Styles window.

3 Select HTML Styles.

4 Create your HTML document, using the styles to tag your text.

5 Click File → Save As.

6 Select the location where you want to save your file, name the file, and select
HTML Document (.html) from the Filter list.

7 Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created
when you edited the HTML file as a Writer document, click View → HTML Source.
In HTML Source mode, the Formatting and Styles list is no longer available.

NOTE

The first time you switch to HTML Source mode, you are prompted to save the
file as HTML, if you have not already done so.

3.3 Using Spreadsheets with Calc
Calc is the OpenOffice.org spreadsheet application. Create a new spreadsheet with File
→ New → Spreadsheet or open one with File → Open. Calc can read and save in Mi-
crosoft Excel's format, so it is easy to exchange spreadsheets with Excel users.

NOTE

Calc can process many VBA macros in Excel documents; however, support for
VBA macros is not yet complete. When opening an Excel spreadsheet that
makes heavy use of macros, you might discover that some do not work.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data
from other cells to generate a value for the cell in which it is inserted. You can also
create charts from cell values.
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3.3.1 Using Formatting and Styles in Calc
Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses,
you will probably find it useful to create styles for your own frequently used formatting
preferences.

Creating a Style
1 Click Format → Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click in the Formatting and Styles window, then click New.

4 Specify a name for your style and use the various tabs to set the desired formatting
options.

5 Click OK.

Modifying a Style
1 Click Format → Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click the name of the style you want to change, then click Modify.

4 Change the desired formatting options.

5 Click OK.
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3.3.2 Using Templates in Calc
If you use different styles for different types of spreadsheets, you can use templates to
save your styles for each spreadsheet type. Then, when you create a particular type of
spreadsheet, open the applicable template and the styles you need for that template are
available in the Formatting and Styles window.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system and detailed how-tos are found at the OpenOf-
fice.org Documentation page (http://documentation.openoffice.org/
HOW_TO/index.html).

Creating a Template
A Calc template is a spreadsheet that contains styles and content that you want to appear
in every spreadsheet created with that template, such as headings or other cell styles.
When a spreadsheet is created or opened with the template, the styles are automatically
applied to that spreadsheet.

To create a template:

1 Click File → New → Spreadsheet.

2 Create the styles and content that you want to use in any spreadsheet that uses
this template.

3 Click File → Templates → Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.
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3.4 Using Presentations with Impress
Use OpenOffice.org Impress to create presentations for screen display or printing, such
as slide shows or transparencies. If you have used other presentation software, you can
move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft Powerpoint presentations, which means you can
exchange presentations with Powerpoint users, as long as you save your presentations
in Powerpoint format.

3.4.1 Creating a Presentation
1 Click File → New → Presentation.

2 Select the option to use for creating the presentation.

There are two ways to create a presentation:

• Create an empty presentation

Opens Impress with a blank slide. Use this option to create a new presentation
from scratch, without any preformatted slides.

• Create a presentation from a template

Opens Impress with your choice of template. Use this option to create a new
presentation with a predesigned OpenOffice.org template or a template you’ve
created or installed yourself, such as your company’s presentation template.
Impress uses styles and templates the same way other OpenOffice.org mod-
ules do. See Section 3.2.4, “Using Templates to Format Documents”
(page 94) for more information about templates.

3.4.2 Using Master Pages
Master pages give your presentation a consistent look by defining the way each slide
looks, what fonts are used, and other graphical elements. Impress uses two types of
master pages:
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• Slide master

Contains elements that appear on all slides. For example, you might want your
company logo to appear in the same place on every slide. The slide master also
determines the text formatting style for the heading and outline of every slide that
uses that master page, as well as any information you want to appear in a header
or footer.

• Notes master

Determines the formatting and appearance of the notes in your presentation.

Creating a Slide Master
Impress comes with a collection of preformatted master pages. Eventually, most users
will want to customize their presentations by creating their own slide masters.

1 Start Impress, then create a new empty presentation.

2 Click View → Master → Slide Master.

This opens the current slide master in Master View.

3 Right-click the left-hand panel, then click New Master.

4 Edit the slide master until it has the desired look.

5 Click Close Master View or View → Normal to return to Normal View.

TIP

When you have created all of the slide masters you want to use in your presen-
tations, you can save them in an Impress template. Then, any time you want
to create presentations that use those slide masters, open a new presentation
with your template.

Applying a Slide Master
Slide masters can be applied to selected slides or to all slides in the presentation.
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1 Open your presentation, then click View → Master → Slide Master.

2 (Optional) If you want to apply the slide master to multiple slides, but not to all
slides, select the slides that you want to use that slide master.

To select multiple slides, in the Slides Pane, Control-click on the slides you want
to use that slide master.

3 In the Task Pane, right-click the master page you want to apply.

If you do not see the Task Pane, click View → Task Pane.

4 Apply the slide master by clicking one of the following:.

• Apply to All Slides

Applies the selected slide master to all slides in the presentation.

• Apply to Selected Slides

Applies the selected slide master to the current slide, or to any slides you
select before applying the slide master. For example, if you want to apply a
different slide master to the first slide in a presentation, select that slide, then
change to Master View and apply a slide master to that slide.

3.5 Using Databases with Base
OpenOffice 2.0 introduces a new database module, Base. Use Base to design a database
to store many different kinds of information, from a simple address book or recipe file
to a sophisticated document management system.

Tables, forms, queries, and reports can be created manually or using convenient wizards.
For example, the Table Wizard contains a number of common fields for business and
personal use. Databases created in Base can be used as data sources, such as when
creating form letters.

It is beyond the scope of this document to detail database design with Base. More infor-
mation can be found at the sources listed in Section 3.8, “Finding Help and Information
About OpenOffice.org” (page 108).
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3.5.1 Creating a Database Using Predefined
Options

Base comes with several predefined database fields to help you create a database. The
steps in this section are specific to creating an address book using predefined fields,
but it should be easy to follow them to use the predefined fields for any of the built-in
database options.

The process for creating a database can be broken into several subprocesses:

Creating the Database
First, create the database.

1 Click File → New → Database.

2 Select Create a new database, then click Next.

3 Click Yes, register the database for me to make your database information
available to other OpenOffice.org modules, select both check boxes in the bottom
half of the dialog, then click Finish.

4 Browse to the directory where you want to save the database, specify a name for
the database, then click OK.

Setting Up the Database Table
Next, define the fields you want to use in your database table.

1 In the Table Wizard, click Personal.

The Sample tables list changes to show the predefined tables for personal use.
If you had clicked Business, the list would contain predefined business tables.

2 In the Sample tables list, click Addresses.

The available fields for the predefined address book appear in the Available
fields menu.
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3 In the Available fields menu, click the fields you want to use in your address
book.

You can select one item at a time, or you can shift-click multiple items to select
them.

4 Click the single right-arrow to move the selected items to the the Selected
fields menu.

To move all available fields to the Selected fieldsmenu, click the double right-
arrow.

5 Use the up-arrow and down-arrow to adjust the order of the selected fields.

The fields appear in the table and forms in the order in which they are listed.

6 Click Next.

7 Make sure each of the fields is defined correctly.

You can change the field name, type, whether the entry is required, and the
maximum length of the field (the number of characters that can be entered in
that field. For this example, leave the settings as they are.

8 Click Next.

9 ClickCreate a primary key, click Automatically add a primary key, click Auto
value, then click Next.

10 Accept the default name for the table, selectCreate a form based on this table,
then click Finish.

Creating a Form
Next, create the form to use when entering data into your address book.

1 In the Form Wizard, click the double right-arrow to move all available fields to
the Fields in the form list, then click Next twice.

2 Select how you want to arrange your form, then click Next.
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3 Select the option to use the form to display all data and leave all of the check
boxes empty, then click Next.

4 Apply a style and field border, then click Next.

For this example, accept the default selections.

5 Name the form, select the Modify the form option, then click Finish.

Modifying the Form
After the form has been defined, you can modify the appearance of the form to suit
your preferences.

1 Close the form that opened when you finished the previous step.

2 In the main window for your database, right-click the form you want to modify
(there should be only one option), then click Edit.

3 Arrange the fields on the form by dragging them to their new locations.

For example, move the First Name field so it appears to the right of the Last
Name field, and then adjust the locations of the other fields to suit your preference.

4 When you have finished modifying the form, save it and close it.

What’s Next?
After you have created your database tables and forms, you are ready to enter your data.
You can also design queries and reports to help sort and display the data.

Refer to OpenOffice.org online help and other sources listed in Section 3.8, “Finding
Help and Information About OpenOffice.org” (page 108) for additional information
about Base.
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3.6 Creating Graphics with Draw
Use OpenOffice.org Draw to create graphics and diagrams. You can save your drawings
in today’s most common formats and import them into any application that lets you
import graphics, including the other OpenOffice.org modules. You can also create Flash
versions of your drawings.

The OpenOffice.org documentation contains complete instructions on using Draw. See
Section 3.8, “Finding Help and Information About OpenOffice.org” (page 108) for more
information.

To use a Draw graphic in a document:

1 Open Draw, then create the graphic.

2 Save the graphic.

3 Copy the graphic and paste it into the document, or insert the graphic directly
from the document.

One particularly useful feature of Draw is the ability to open it from other OpenOf-
fice.org modules so you can create a drawing that is automatically imported into your
document.

1 From an OpenOffice.org module (for example, from Writer), click Insert →
Object → OLE Object → OpenOffice.org 2.0 Drawing → OK.

This opens Draw.

2 Create your drawing.

3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.
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3.7 Creating Mathematical Formulas
with Math

It is usually difficult to include complex mathematical formulas in your documents.
The OpenOffice.org Math equation editor lets you create formulas using operators,
functions, and formatting assistants. You can then save those formulas as objects that
can be imported into other documents. Math functions can be inserted into other
OpenOffice.org documents like any other graphic object.

NOTE

Math is not a calculator. The functions it creates are graphical objects. Even if
they are imported into Calc, these functions cannot be evaluated.

3.8 Finding Help and Information
About OpenOffice.org

OpenOffice.org contains extensive online help. In addition, a large community of users
and developers support it. As a result, it is seldom hard to find help or information about
using the OpenOffice.org. The following table shows some of the places where you
can go for additional information. (Because Web sites often close or their content
changes, the information in the following table might not be current when you read it.)

Table 3.5 Where to Get Information About OpenOffice.org

What You Can FindLocation

Extensive help on performing any task
in OpenOffice.org

OpenOffice.org online help menu

Manuals, tutorials, user and developer
forums, users@openoffice.org mailing
list, FAQs, and much more

Official OpenOffice.org support page
(http://support.openoffice
.org/index.html)
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What You Can FindLocation

Information about migrating to
OpenOffice.org from other office suites,
including Microsoft Office

OpenOffice.org Migration Guide
(oooauthors.org/en/authors/
userguide2/migration/
OtherMSOFiles_25_June_PK.sxw)

Books, news, tips and tricksTaming OpenOffice.org (http://www
.taming-openoffice-org.com/)

Extensive information about creating
and using macros

OpenOffice.org Macros (http://www
.pitonyak.org/oo.php)
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4Kontact: E-Mailing and
Calendaring
Kontact combines the functionality of a number of KDE applications into a convenient,
single interface for personal information management. These applications include KMail
for e-mail, KOrganizer for the calendar, KAddressbook for contacts, and KNotes for
notes. It is also possible to sync data with external devices, such as a PalmPilot or other
handheld device. Kontact integrates easily with the rest of the KDE desktop and connects
to a variety of groupware servers. It includes extra features, such as spam and virus
filtering and an RSS reader.

Start Kontact from the main menu. Alternatively, enter kontact in a command line
or in the Run Command dialog. You can also open the individual components instead
of the combined application if you only need partial functionality.

4.1 Kontact Overview
The default window view, which shows the Summary, is shown in Figure 4.1, “The
Kontact Window Showing the Summary” (page 112). Use the buttons in the left section
to access the different components.

The Summary provides basic information, including upcoming birthdays and to-dos
and the number of new mail messages. The news section can access RSS feeds to provide
updated news of interest to you. Use Settings → Configure Summary View to configure
the information displayed.
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Figure 4.1 The Kontact Window Showing the Summary

4.1.1 Mail
The folder area to the left contains a list of your mail folders (mail boxes) indicating
the total number of messages and how many are still unread. To select a folder, simply
click it. The messages in that folder appear in the top right frame. The number of mes-
sages in that folder is also shown in the status bar at the bottom of the application win-
dow.

The subject, sender, and time of receipt of each message are listed in the header area
to the right. Click a message to select it and display it in the message window. Sort the
messages by clicking one of the column headers (subject, sender, date, etc.). The contents
of the currently selected message are displayed in the message frame of the window.
Attachments are depicted as icons at the end of the message, based on the MIME type
of the attachment, or they can be displayed inline.

Messages can be marked with different status flags. Change the status with Message
→ Mark Message. You can use this feature to assign a status to a message, such as
important or ignored. For example, you can highlight important messages that you do
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not want to forget. Display only messages with a certain status using Status in the search
bar.

4.1.2 Contacts
The upper left frame of this component shows all addresses in the currently activated
address books. The lower left frame lists your address books and shows whether each
one is currently active. The right frame shows the currently selected contact. Use the
search bar at the top to find a particular contact.

4.1.3 Calendar
The calendar view is divided into a number of frames. By default, view a small calendar
of this month and a week view of the current week. Also find a list of to-dos, a detailed
view of the current event or to-do, and a list of calendars with the status of each. Select
a different view from the toolbar or the View menu.

4.1.4 To-Do List
To-do List shows your list of tasks. Click the field at the top to add a new item to the
list. Right-click in a column of an existing item to make changes to the value in that
column. An item can be broken into several subitems. Right-click and select New Sub-
to-do to create a subitem. You can also assign to-dos to other people.

4.1.5 Journal
The Journal provides a place for your reflections, occurences, or experiences. Choose
a date in the calendar frame and click Add Journal Entry to add a new entry. If a journal
entry already exists for the chosen date, edit it in the right frame.

4.1.6 Notes
Use the Notes component to keep sticky notes to yourself. If you are using KDE, use
the KNote icon in the system tray to make your notes visible on the desktop.
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4.1.7 Feeds
The Feeds window is divided into three frames—a tree view with RSS feeds on the
left, an article list on the top right, and the article view on the bottom right side. Click
a feed in the tree view to display it. Right-click a feed to update, edit, or delete it. Right-
click a folder in the tree view to open a menu where you can add a new feed or manip-
ulate existing feeds within this folder.

4.2 Mail
Kontact uses KMail as its e-mail component. To configure it, open the mail component
then select Settings → Configure KMail. KMail is a fully-featured e-mail client that
supports a number of protocols. Tools contains several useful tools for managing un-
wanted e-mails. Use Find to perform a detailed search for messages. Anti-SpamWizard
can help manage tools for filtering unwanted commercial e-mails. Anti-Virus Wizard
helps manage e-mail virus scanners. These two wizards work with external spam and
virus software. If the options are disabled, install additional packages for protection
against spam and viruses.

Figure 4.2 The Kontact Mail Component
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4.2.1 Configuring Identities and Accounts
Kontact can manage multiple e-mail accounts, such as your private e-mail address and
your business address. When writing an e-mail, select one of the identities previously
defined by clicking View → Identity. To create a new identity profile, select Settings
→ Configure KMail then Identities → Add. In the dialog that opens, give the new
identity a name, such as “private” or “office.” Click OK to open a dialog in which to
enter additional information. You can also assign an identity to a folder so that, when
replying to a message in that folder, the assigned identity is selected.

Under the General tab, enter your name, organization, and e-mail address. Under
Cryptography, select your keys to send digitally signed or encrypted messages. For the
encryption features to work, first create a key with KGpg, described in Chapter 10,
Encryption with KGpg (page 185).

Under Advanced, you can enter a default reply-to and a default blind carbon-copy ad-
dress, choose a dictionary, select the folders for drafts and sent messages, and define
how messages should be sent. Under Signature, decide if and how each of your messages
should be signed with an extra block of text at the end. For example, you might sign
each e-mail with your contact information. To activate this option, select Enable Signa-
ture and decide whether to obtain the signature from a file, an input field, or the output
of a command. With Picture, you can specify the path to a small (48x48 pixel)
monochrome icon to display in all your mails if the recipient's software supports this
feature. When you are finished with all your identity settings, confirm with OK.

The settings under Accounts decide how Kontact receives and sends e-mail. There are
two tabs, one each for sending and for receiving mail. Many of these settings vary de-
pending on the system and network in which your mail server is located. If you are not
sure about the settings or items to select, consult your ISP or system administrator.

To create outgoing mail boxes under the Sending tab, click Add. Choose between the
SMTP and sendmail transport types. SMTP is the correct choice in most cases. After
making this selection, a window appears in which to enter SMTP server data. Provide
a name and enter the server address (as given to you by your ISP). If the server wants
you to authenticate yourself, enable Server requires authentication. Security settings
are under the Security tab. Specify your preferred encryption method here.

Make settings for receiving e-mail under the Receiving tab. Use Add to create a new
account. Choose between different methods for retrieving mail, such as local (stored
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in Mbox or Maildir format), POP3, or IMAP. Make the settings appropriate for your
server.

4.2.2 Importing E-Mail from Other Mail
Programs

To import e-mail from other applications, select Tools → Import Messages from the
mail view in Kontact. It currently features import filters for Outlook Express, the mbox
format, e-mail text format, Pegasus Mail, Opera, Evolution, and more. The import
utility can also be started separately with the command kmailcvt.

Select the corresponding application and confirm with Continue. A file or a folder must
be provided, depending on the selected type. Kontact then completes the process.

4.2.3 Creating Messages
To compose new messages, selectMessage→NewMessage or click the corresponding
icon in the toolbar. To send messages from different e-mail accounts, select one of the
identities as described in Section 4.2.1, “Configuring Identities and Accounts” (page 115).
In To, enter an e-mail address or part of a name or address in your address book. If
Kontact can match what you enter to something in the address book, a selection list
opens. Click the desired contact or complete your input if none matches. To select di-
rectly from the address book, click the ... button next to the Address field.

To attach files to your message, click the paperclip icon and select the file to attach.
Alternatively, drag a file from the desktop or another folder to theNewMessagewindow
or select one of the options in the Attach menu. Normally, the format of a file is recog-
nized correctly. If the format is not recognized, right-click the icon. From the menu
that appears, select Properties. Set the format and filename in the next dialog and add
a description. In addition, decide whether the attached file should be signed or encrypted.

When you are finished composing your message, send it immediately with Message
→ Send or move it to the outbox with Message → Queue. If you send the e-mail, the
message is copied to sent-mail after having been sent successfully. Messages moved
to the outbox can be edited or deleted.
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4.2.4 Encrypted E-Mail and Signatures
To encrypt your e-mail, first generate a key pair as described in Chapter 10, Encryption
with KGpg (page 185). To configure the details of the encryption procedure, select Set-
tings → Configure KMail → Identities to specify the identity under which to send en-
crypted and signed messages. Then press Modify. After confirming with OK, the key
should be displayed in the corresponding field. Close the configuration dialog withOK.

4.2.5 Folders
Message folders help organize your messages. By default, they are located in the direc-
tory ~/.kde/share/apps/kmail/mail. When starting KMail for the first time,
the program creates several folders. inbox is where new messages fetched from a
server are initially placed. outbox is used for temporary storage of messages queued
for sending. sent-mail is for copies of messages sent. trash contains copies of all
e-mails deleted with Del or Edit → Delete. drafts is where you can save unfinished
messages. If you are using IMAP, the IMAP folders are listed below the local folders.
Each incoming mail server has its folders in the Folder list.

If you want to organize your messages in additional folders, create new folders by se-
lecting Folder → New Folder. This opens a window in which to specify the name and
format of the new folder.

Right-click the folder for a context menu offering several folder operations. Click Expire
to specify the expiration date for read and unread messages, what should happen with
them after expiration, and whether expired messages should be deleted or moved to a
folder. If you intend to use the folder to store messages from a mailing list, set the
necessary options under Folder → Mailing List Management.

To move one or several messages from one folder to another, drag them from the upper
window and drop them into the appropriate folder in the left window. Messages can
also be moved by highlighting the messages then pressing M or selecting Message →
Move to. In the list of folders that appears, select the folder to which to move your
messages.
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4.2.6 Filters
Filters are a convenient method of automatically processing incoming mail. They use
aspects of the mail, such as sender or size, to move mail to certain folders, delete un-
wanted mails, bounce mails back to the sender, or perform a number of other actions.

Setting Up a Filter
To create a filter from scratch, select Settings → Configure Filters. To create a filter
based on an existing message, right-click the desired message then select Create Filter
and the desired filter criteria.

Select the match method for filter criteria (all or any). Then select criteria that applies
only to the desired messages. In Filter Actions, set what the filter should do to the
messages that meet the criteria. Advanced Options provides control over when the filter
is applied and whether additional filters should be considered for these messages.

Applying Filters
Filters are applied in the order listed in the dialog accessed with Settings → Configure
Filters. Change the order by selecting a filter and clicking the arrow buttons. Filters
are only applied to new incoming messages or sent messages as specified in the filter's
advanced options. To apply filters to existing messages, right-click the desired messages
and choose Apply Filter and the desired filter.

If your filters do not act as expected, monitor them with Tools → Filter Log Viewer.
When logging is enabled in this dialog, it shows how messages are processed by your
filters and can help locate the problem.

4.3 Contacts
The contacts component uses KAddressBook. Configure it with Settings → Configure
KAddressBook. To search for a particular contact, use the search bar. With Filter, select
to display only contacts in a certain category. Right-click a contact to open a menu in
which to select from a variety of options, such as sending the contact information in an
e-mail.
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Figure 4.3 The Kontact Address Book

4.3.1 Adding Contacts
To add a contact with the name and e-mail address from an e-mail, right-click the address
in the mail component and select Open in Address Book. To add a new contact without
using an e-mail, select File → New Contact in the address component. Both methods
open a dialog in which to enter information about the contact.

In the General tab, enter basic contact information, such as name, e-mail addresses,
and telephone numbers. Categories can be used to sort addresses.Details contains more
specific information, such as birthday and spouse's name.

If your contact uses an instant messenger, you can add these identities in IM Addresses.
If you do this and have Kopete or another KDE chat program running at the same time
as Kontact, view status information about these identities in Kontact. In Crypto Settings,
enter the contact's encryption data, such as public key.

Misc has additional information, such as a photograph and the location of the user's
Free/Busy information. Use Custom Fields to add your own information to the contact
or address book.
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Contacts can also be imported in a variety of formats. Use File → Import and select
the desired format. Then select the file to import.

4.3.2 Making a Distribution List
If you frequently send e-mail messages to the same group of people, a distribution list
enables you to store multiple e-mail addresses as a single contact item so that you do
not need to enter each name individually in every e-mail you send to that group. First,
click Settings → Show Extension Bar → Distribution List Editor. In the new section
that appears, click New List. Enter a name for the list then click OK. Add contacts to
the list by dragging them from the address list and dropping them in the distribution
list window. Use this list like you would an individual contact when creating an e-mail.

4.3.3 Adding Address Books
IMPORTANT: Groupware Address Books

The best way to add groupware resources is with the Groupware Wizard, a
separate tool. To use it, close Kontact then run groupwarewizard in a
command line or from the Office group of the KDE menu. Select the server
type, such as SLOX, GroupWise, or Exchange, from the list offered then enter
the address and authentication data. The wizard then adds the available re-
sources to Kontact.

Kontact can access multiple address books, such as shared ones offered by Novell
GroupWise or an LDAP server. Select Settings → Show Extension Bar → Address
Books to view the current address books. Press Add to add one then select the type and
enter the required information.

The check boxes in front of the books show the activation status of each address book.
To prevent the display of a book without deleting it, uncheck it. Remove deletes the
selected book from the list.
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4.4 Calendar
Kontact uses KOrganizer as its calendar component. To configure it, use Settings →
Configure KOrganizer. With the calendar, enter appointments and schedule meetings
with others. If desired, you can be reminded of upcoming events. You can also import,
export, and archive calendars with the options in File.

Figure 4.4 The Kontact Calendar

4.4.1 Scheduling an Event
Add a new event or meeting with Actions→New Event. Enter the desired details. Under
Reminder, specify the exact time (minutes, hours, or days in advance) when the attendees
should be reminded of the event. If an event recurs, specify the appropriate interval.
Another way to create an event at a specific point in the calendar is to double-click the
corresponding field in one of the program's calendar views. This opens the same dialog
window as that available from the menu. Alternatively, select a time range in the Cal-
endar view and right-click.

Specify the attendees of an event by entering their data manually in the dialog or by
inserting data from the address book. To enter data manually, select New. To import
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data from the address book, click Select Addressee then select the corresponding entries
from the dialog. To schedule the event based on the participants' availability, go to
Free/Busy and click Pick Date.

Use the Recurrence tab to configure an event that happens on a regular basis. Attach-
ments can be convenient for linking other information with the event, such as an agenda
for a meeting.

4.4.2 Adding Calendars
IMPORTANT: Groupware Calendars

The best way to add groupware resources is with Groupware Wizard, a separate
tool. To use it, close Kontact then run groupwarewizard in a command line
or from the Office group of the KDE menu. Select the server type, such as
SLOX, GroupWise, or Exchange, from the list offered then enter the address
and authentication data. The wizard adds the available resources to Kontact.

The calendar module can connect to multiple calendars simultaneously. This is useful,
for example, to combine a personal calendar with an organizational one. To add a new
calendar, click Add then select the calendar type. Complete the necessary fields.

The check boxes in front of the calendars show the activation status of each. To prevent
the display of a calendar without deleting it, uncheck it. Remove deletes the selected
calendar from the list.

4.5 Syncing Data with a Handheld
Kontact is designed so its data can be synced with handheld devices, such as a Palm.
View information about the status of KPilot in the summary. Refer to Chapter 6, Syn-
chronizing a Handheld Computer with KPilot (page 143) for information about config-
uring and using KPilot.
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4.6 Kontact for GroupWise Users
If you are used to working in GroupWise, you should have very little trouble adjusting
to Kontact. The two programs share many concepts and provide many of the same
services. This section discusses notable terminology differences, as well as some tips
to help GroupWise users make the most of Kontact.

4.6.1 Terminology Differences
The following table lists some key terminology differences between Kontact and
GroupWise.

Table 4.1 Kontact and GroupWise Terminology Differences

KontactGroupWise

EventsAppointments

Free/BusyBusy search

Journal entriesNotes

An event without attendees is posted. If an
event has attendees, it is a Sent item.

Posted, nonposted items

To-dosTasks

4.6.2 Tips for GroupWise Users
This section contains hints to help GroupWise users work with some of the differences
between GroupWise and Kontact.
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Contact Information
You can add your GroupWise Messenger and e-mail contacts to your Kontact contact
information. Then you can create an e-mail or open an instant messaging session with
that contact by right-clicking the name in the Contact view.

Color Coding
It is helpful to color code GroupWise items, as well as items from other sources. Color
coding makes it easy to scan your e-mails, contacts, and other information for items
from a particular source.

Inviting Attendees to Events
Unlike GroupWise, Kontact does not automatically enter you as an attendee for events
you schedule. Make sure that you remember to invite yourself.

4.7 For More Information
Kontact includes help for itself and its various components. Access it with Help →
Kontact Handbook. The project's Web page, http://www.kontact.org, is also
informative.
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5GroupWise Linux Client:
E-Mailing and Calendaring
GroupWise® is a robust, dependable messaging and collaboration system that connects
you to your universal mailbox anytime and anywhere. This section gives you an intro-
ductory overview of the GroupWise client to help you start using the GroupWise Cross-
Platform client quickly and easily.

5.1 Getting Acquainted with the Main
GroupWise Window

Your main work area in GroupWise is called the Main Window. From the Main Window
of GroupWise, you can read your messages, schedule appointments, view your Calendar,
manage contacts, change the mode of GroupWise you’re running in, open folders, open
documents, and much more.

GroupWise Linux Client: E-Mailing and Calendaring 125



Figure 5.1 Groupwise Main Window

You can open more than one Main Window in GroupWise by clicking Window, then
clicking New Main Window. This is useful if you proxy for another user. You can look
at your own Main Window and the Main Window belonging to the person you are
proxying for. You might also want to open a certain folder in one window and look at
your Calendar in another. You can open as many Main Windows as your computer’s
memory allows.

The basic components of the Main Window are explained below.

5.1.1 Toolbar
The toolbar lets you quickly accomplish common GroupWise tasks, such as opening
the Address Book, sending mail messages, and finding an item. For information about
the toolbar, see Section 5.4, “Using the Toolbar” (page 136).
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5.1.2 Folder and Item List Header
The Folder and Item List header provides a drop-down list where you can select the
mode of GroupWise you want to run (Online or Caching), select to open your archived
or backup mailbox, and select a proxy mailbox.

5.1.3 Folder List
The Folder List at the left of the Main Window lets you organize your GroupWise
items. You can create new folders to store your items in. Next to any folder (except for
shared folders), the number of unread items is shown in square brackets. Next to the
Sent Items folder, the number in square brackets shows how many items are pending
to be sent from Caching mode.

Here is what you’ll find in each of the default folders:

• Section “User Folder” (page 127)

• Section “Mailbox Folder” (page 128)

• Section “Sent Items Folder” (page 128)

• Section “Calendar Folder” (page 128)

• Section “Contacts Folder” (page 129)

• Section “Checklist Folder” (page 129)

• Section “Documents Folder” (page 130)

• Section “Trash Folder” (page 131)

• Section “Shared Folders” (page 131)

User Folder

Your user folder (indicated by your name) represents your GroupWise database. All
folders in you Main Window are subfolders of your user folder.
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Mailbox Folder

The Mailbox displays all the items you have received, with the exception of scheduled
items (appointments, tasks, and reminder notes) you have accepted or declined. Accepted
scheduled items are moved to the Calendar.

Sent Items Folder

The Sent Items folder displays all sent items from the Mailbox and Calendar. The
Sent Items folder in versions prior to GroupWise 6.5 was a query folder, which had
some differences from the current Sent Items folder.

The following is a comparison between the previous Sent Items query folder and the
current Sent Items folder.

Table 5.1 Comparison Between Sent Items Query Folder and Sent Items Folder

Sent Items Query Folder (Previous)Sent Items Folder (Current)

No items actually reside in this folder. This
folder is a Find Results folder, which means

All sent items reside in this folder
unless they are moved to a folder

a Find is performed when you click the folderother than the Mailbox or Calendar.
and the results of the Find (all sent items) areIf a sent item is moved to another
displayed in the folder. If you delete an itemfolder, it no longer displays in the

Sent Items folder. from this folder, the original item remains in
its original folder and redisplays the next time
you open this folder.

You can resend, reschedule, and retract sent
items from this folder.

You can resend, reschedule, and re-
tract sent items from this folder.

Calendar Folder
The Calendar folder shows several calendar view options.
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Contacts Folder

The Contacts folder , by default, represents the Frequent Contacts address book in
the Address Book. Any modification you make in the Contacts Folder is also made in
the Frequent Contacts address book.

From this folder, you can view, create and modify contacts, resources, organizations
and groups.

Your proxies never see your Contacts folder.

Checklist Folder
Use the Checklist folder to create a task list. You can move any items (mail messages,
phone messages, reminder notes, tasks, or appointments) to this folder and arrange them
in the order you want. Each item is marked with a check box so that you can check
items off as you complete them.

The following is a comparison between the Checklist folder and the Task List query
folder (found in previous versions of GroupWise).

Table 5.2 Comparison Between Checklist Folder and Task List Folder

Task List FolderChecklist Folder

No items actually reside in this folder. This folder
is a Find Results folder, which means a Find is

This folder contains the follow-
ing items:

performed when you click the folder and the re-
• Items you have moved to

this folder
sults of the Find (all scheduled tasks) are displayed
in the folder. If you delete an item from this folder,
the original item remains in its original folder and
redisplays the next time you open this folder.• Items you have posted to this

folder

• Items that are part of a
checklist that you have creat-
ed in another folder
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Task List FolderChecklist Folder

Only tasks show in this folder. Tasks are sched-
uled items that are associated with a due date.

Any item type can reside in this
folder.

To mark an item completed, open the item, then
click Completed.

To mark an item completed, click
the check box next to the item in
the Item List.

Due dates are set by the person who sent you the
task. If you post a task for yourself, you can set a
due date.

To set the priority of an item, open the item, then
type a priority in the Priority field.

Tasks display in the Task List of the Calendar and
can be marked Completed from the Calendar.

Checklist items do not display in
the Task List of the Calendar.

Tasks that are past due show as red in the Calen-
dar.

Documents Folder

Your document references are organized in the Documents folder so you can locate
them easily.

The Documents folder can contain only documents. If any other type of item is moved
to this folder by a GroupWise client older than version 5.5, the item is deleted.

Cabinet Folder

The Cabinet contains all your personal folders. You can rearrange and nest folders
by clicking Edit→ Folders. You can change how the folders are sorted by right-clicking
the Cabinet folder, clicking Properties, then selecting what you want to sort by.
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Junk Mail Folder
All e-mail items from addresses and Internet domains that are junked through Junk
Mail Handling are placed in the Junk Mail folder . This folder is not created in the
folder list unless a Junk Mail option is enabled.

While Junk Mail options are enabled, this folder cannot be deleted. However, the
folder can be renamed or moved to a different location in the folder list. If all Junk Mail
options are disabled, the folder can be deleted. The folder can also be deleted if the
Junk Mail Handling feature is disabled by the system administrator.

To delete items from the Junk Mail Folder, right-click the folder, click Empty Junk
Mail Folder, then click Yes.

Trash Folder
All deleted mail and phone messages, appointments, tasks, documents, and reminder
notes are stored in the Trash folder . Items in the Trash can be viewed, opened, or
returned to your Mailbox before the Trash is emptied. (Emptying the Trash removes
items in the Trash from the system.)

You can empty your entire Trash, or empty only selected items. Items in the Trash are
automatically emptied according to the number days entered in the Cleanup tab in En-
vironment Options, or you can empty the Trash manually. The system administrator
might specify that your Trash is emptied automatically on a regular basis.

Shared Folders
A shared folder is like any other folder in your Cabinet, except other people have
access to it. You can create shared folders or share existing personal folders in your
Cabinet. You choose whom to share the folder with, and what rights to grant each user.
Then, users can post messages to the shared folder, drag existing items into the folder,
and create discussion threads. You can’t share system folders, which include the Cabinet,
Trash, and Work In Progress folders.

GroupWise Linux Client: E-Mailing and Calendaring 131



5.1.4 Item List
The Item List on the right side of the Main Window displays your mail and phone
messages, appointments, reminder notes, tasks, and document references. You can sort
the Item List by clicking a column heading. To reverse the sort order, click the column
heading a second time. For information about the icons used with different items, see
Section 5.3.2, “Icons Appearing Next to Items in Your Mailbox and Calendar” (page 134).

5.1.5 QuickViewer
The QuickViewer opens below the Folder and Item List. You can quickly scan items
and their attachments in the QuickViewer rather than open each item in another window.

5.2 Using Different GroupWise Modes
GroupWise provides two different ways to run the GroupWise client: Online mode and
Caching mode.

You might be able to run GroupWise in either mode, or your system administrator
might require that you use only a certain mode.

Most GroupWise features are available in all both GroupWise modes, with some excep-
tions. Subscribing to other users’ notifications is not available in Caching mode.

5.2.1 Online Mode
When you use Online mode, you are connected to your post office on the network.
Your mailbox displays the messages and information stored in your network mailbox
(also called your Online Mailbox). Online mode is connected to your network mailbox
continuously. In Online mode, if your Post Office Agent shuts down or you lose your
network connection, you temporarily lose your connection to your mailbox.

You should use this mode if you do not have a lot of network traffic, or if you use
several different workstations and do not want to download a local mailbox to each
one.
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5.2.2 Caching Mode
Caching mode stores a copy of your network mailbox, including your messages and
other information, on your local drive. This allows you to use GroupWise whether or
not your network or Post Office Agent is available. Because you are not connected to
the network all the time, this mode cuts down on network traffic and has the best per-
formance. A connection is made automatically to retrieve and send new messages. All
updates are performed in the background so your work is not interrupted.

To use Caching mode, the client installation must be a standard installation, not a
workstation installation.

You should use this mode if you have enough disk space on your local drive to store
your mailbox.

Several users can set up their Caching Mailboxes on a single shared computer.

5.3 Understanding Your Mailbox
All of your items, whether you send or receive them, are stored in your GroupWise
Mailbox. You can quickly display only received items, sent items, posted items, or draft
items by clicking a setting on the Display drop-down list. You can further restrict which
items display in your Mailbox by using filters.

You can organize your messages by moving them into folders within your Cabinet, and
you can create new folders as necessary.

5.3.1 Bolded Items in Your Mailbox
All unopened items in your Mailbox are bolded to help you easily identify which items
and documents you have not yet read. The icon appearing next to an item also indicates
if it is unopened.

Sent items are also bolded to show when they are queued but not uploaded, status infor-
mation has not been received about the item being delivered, or they have not yet been
transferred to the Internet.
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5.3.2 Icons Appearing Next to Items in Your
Mailbox and Calendar

The icons that appear next to items in your Mailbox and Calendar show information
about the items. The following table explains what each icon means.

Table 5.3 Icon Descriptions

DescriptionIcon

Next to an item you have sent in Caching mode, the icon indicates
that the item has been queued, but the queue has not been uploaded.
After the item has been uploaded, this icon indicates that status in-
formation has not been received about the item being delivered to
the destination post office or transferred to the Internet.

Next to the Sent Items folder, the icon indicates that there is at
least one item that has been queued but has not been uploaded.

Appears next to an item you have sent. If the item has been opened
by at least one person, this icon appears until all recipients have 1)
opened the mail, phone message, or reminder note; 2) accepted the
appointment; or 3) completed the task.

Appears next to an item you have sent. The item couldn’t be deliv-
ered to the destination post office or it failed to transfer to the Inter-
net.

Appears next to an item you have sent. Next to an appointment or
task, this icon indicates that at least one person has declined/deleted
the item. Next to a mail message, phone message, or reminder note,
this icon indicates that at least one person has deleted the item
without opening it.

One or more attachments are included with the item.

One or more sound annotations are included with the item, or the
item is a voice mail message.
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DescriptionIcon

Draft item.

Appears next to an item you have sent.

Appears next to an item you have replied to.

Appears next to an item you have forwarded.

Appears next to an item you have delegated.

Appears next to an item you have replied to and forwarded

Appears next to an item you have replied to and delegated.

Appears next to an item you have forwarded and delegated.

Appears next to an item you have replied to, forwarded, and dele-
gated

Posted item.

Specific version of a document.

Official version of a document.

Unopened mail message with a low, standard, or high priority.

Opened mail message with a low, standard, or high priority.

Unopened appointment with a low, standard, or high priority.

Opened appointment with a low, standard, or high priority.

Unopened task with a low, standard, or high priority.

Opened task with a low, standard, or high priority.
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DescriptionIcon

Unopened reminder note with a low, standard, or high priority.

Opened reminder note with a low, standard, or high priority.

Unopened phone message with a low, standard, or high priority.

Opened phone message with a low, standard, or high priority.

The sender has requested that you reply to this item. The item can
be a low, standard, or high priority.

Appears in a Busy Search. If it appears to the left of a username or
resource, you can click a scheduled time across from the username
or resource on the Individual Schedules tab to display more infor-
mation about the appointment in the box below. However, the user
or resource owner must give you appointment Read rights in the
Access List before this icon appears.

Appears on your Calendar, indicates an alarm is set for the item.

Appears on your Calendar, indicates the item is a group appoint-
ment, reminder note, or task.

Appears on your Calendar, indicates the item is marked private.

Appears on your Calendar, indicates that you declined the item but
didn’t delete it.

5.4 Using the Toolbar
Use the toolbar to access many of the features and options found in GroupWise. The
toolbar at the top of a folder or item is context sensitive; it changes to provide the options
you need most in that location.

136 KDE User Guide



5.5 Using Shortcut Keys
You can use a number of shortcut keys in GroupWise for accessibility or to save time
when you perform various operations. The table below lists some of these keystrokes,
what they do, and the context where they work.

Table 5.4 Shortcut Keys

Where It WorksActionKeystroke

Main Window, Calendar,
item, dialog box

Open online helpF1

In an itemSearch for text.F2

Main Window, CalendarRefresh the viewF5

In an itemOpens the Spell CheckerF7

Item ListMark the selected item privateF8

In an itemOpen the font dialog boxF9

Item List; textSelect all items; select all textCtrl+A

In textBold textCtrl+B

In textCopy selected textCtrl+C

Main Window, Calendar,
item, dialog box

Open the Find dialog boxCtrl+F

CalendarGo to today’s dateCtrl+G

In textItalicize textCtrl+I

In an itemAttach a file to a messageCtrl+L
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Where It WorksActionKeystroke

Main Window, Calendar,
item, dialog box

Open a new mail messageCtrl+M

Item ListOpen the selected messageCtrl+O

Main Window, itemOpen the Print dialog boxCtrl+P

Main Window, CalendarTurn the QuickViewer on and offCtrl+Q

Item ListMark the selected item unreadCtrl+R

In an itemSave a draft in the Work in
Progress folder

Ctrl+S

In textUnderline textCtrl+U

In textPaste selected textCtrl+V

In textCut selected textCtrl+X

In textUndo the last actionCtrl+Z

In an itemOpens the previous or next itemCtrl+Up-arrow

or

Ctrl+Down-arrow

In textSelect text one word at a timeCtrl+Shift+Left-ar-
row

or

Ctrl+Shift+Right-
arrow

Main Window, Calendar,
item, dialog box

Open a new appointmentCtrl+Shift+A
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Where It WorksActionKeystroke

Main Window, Calendar,
item, dialog box

Open a new taskCtrl+Shift+T

Main Window, Calendar,
item, dialog box

Open a new reminder noteCtrl+Shift+R

Main Window, Calendar,
item, dialog box

Open a new phone messageCtrl+Shift+P

Main Window, Calendar,
item, dialog box

From the Main Window or Calen-
dar, exit GroupWise.

Alt+F4

From an item, exit the item.

From a dialog box, exit the dialog
box.

Main Window, Calendar,
item

Activate the menu bar (Use the
underlined letters in the menu
names)

Alt + [letter]

In a new itemSend itemAlt+D

In a new itemSend itemAlt+S

Item ListDisplay the properties of the select-
ed item

Alt+Enter

In an itemDelete an itemAlt+Del

In textSelect text one character at a timeShift+Left-arrow

or

Shift+Right-arrow

In textSelect text to the end or beginning
of a line

Shift+End
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Where It WorksActionKeystroke

or

Shift+Home

Folder listIn the Folder List, Shift + the first
letter of a subfolder name goes to
the subfolder.

Shift + [letter]

Main Window, Calendar,
dialog box, item

Cycle through fields, buttons, and
areas

Tab

Main Window, Calendar,
dialog box, item

Reverse the order of cycling
through fields, buttons, and areas

Shift+Tab

In text, dialog boxIn text, indent the text.Ctrl+Tab

In a tabbed dialog box, open the
next tab.

In an itemZooms in the message body of an
item.

Alt+Up Arrow

In an itemZooms out the message body of
an item.

Alt+Down Arrow

5.6 Learning More
You can learn more about GroupWise from the following resources:

• Section 5.6.1, “Online Help” (page 141)

• Section 5.6.2, “GroupWise 7 Documentation Web Page” (page 141)

• Section 5.6.3, “GroupWise Cool Solutions Web Community” (page 141)
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5.6.1 Online Help
Complete user documentation is available in Help. In the Main Window, click Help →
Help Topics, then use the Contents tab, Index tab, or Search tab to locate the help topics
you want.

5.6.2 GroupWise 7 Documentation Web
Page

For the latest version of the GroupWise user guide and for extensive GroupWise admin-
istration documentation, go to the GroupWise 7 area on the Novell Documentation Web
site (http://www.novell.com/documentation/gw7).

This user guide is also available from the GroupWise client by clicking Help → User
Guide.

5.6.3 GroupWise Cool Solutions Web
Community

At GroupWise Cool Solutions, you’ll find tips, tricks, feature articles, and answers to
frequent questions. In the Main Window, click Help → Cool Solutions Web Community
or go to http://www.novell.com/coolsolutions/gwmag.

GroupWise Linux Client: E-Mailing and Calendaring 141

http://www.novell.com/documentation/gw7
http://www.novell.com/coolsolutions/gwmag




6Synchronizing a Handheld
Computer with KPilot
Handheld computers are in widespread use among users who need to have their
schedules, to-do lists, and notes with them everywhere they go. Often users want the
same data available on both the desktop and the portable device. This is where KPilot
comes in—it is a tool to synchronize data on a handheld with that used by the KDE
applications KAddressBook, KOrganizer, and KNotes, which are part of Kontact.

The main purpose of KPilot is to allow sharing of data between the applications of a
handheld computer and their KDE counterparts. KPilot does come with its own built-
in memo viewer, address viewer, and file installer, but these cannot be used outside the
KPilot environment. Independent KDE applications are available for all functions except
the file installer.

For communication between the handheld and the different desktop programs, KPilot
relies on conduits. KPilot itself is the program that oversees any data exchange between
the two computer devices. Using a particular function of the handheld on your desktop
computer requires that the corresponding conduit is enabled and configured. For the
most part, these conduits are designed to interact with specific KDE programs, so in
general they cannot be used with other desktop applications.

The time synchronization conduit is special in that there is no user-visible program for
it. It is activated in the background with each sync operation, but should only be enabled
on computers that use a network time server to correct their own time drift.

When a synchronization is started, the conduits are activated one after another to carry
out the data transfer. There are two different sync methods: a HotSync operation only
synchronizes the data for which any conduits have been enabled while a backup operation
performs a full backup of all data stored on the handheld.
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Some conduits open a file during a sync operation, which means that the corresponding
program should not be running at that time. Specifically, KOrganizer should not be
running during a sync operation.

6.1 Conduits Used by KPilot
The conduits used by KPilot can be enabled and configured after selecting Settings →
Configure KPilot. The following is a list of some important conduits:

Addressbook
This conduit handles the data exchange with the handheld's address book. The KDE
counterpart for managing these contacts is KAddressBook. Start it from the main
menu or with the command kaddressbook.

KNotes/Memos
This conduit allows you to transfer notes created with KNotes to the handheld's
memo application. Start the KDE application from the main menu or with the
command knotes.

Calendar (KOrganizer)
This conduit is responsible for syncing the appointments (events) of the hendheld.
The desktop equivalent is KOrganizer.

ToDos (KOrganizer)
This conduit is responsible for syncing to-do items. The desktop counterpart is
KOrganizer.

Time Synchronization
Enabling this conduit adjusts the handheld's clock to that of the desktop computer
during each sync operation. This is only a good idea if the clock of the desktop
computer itself is corrected by a time server at fairly frequent intervals.
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Figure 6.1 Configuration Dialog with the Available Conduits

6.2 Configuring the Handheld
Connection

To be able to use KPilot, first set up the connection with the handheld computer. The
configuration depends on the type of cradle (docking unit) used with the handheld.
There are two types of these: USB cradles or cables and serial cradles or cables.

6.2.1 Configuring the Connection from
within KPilot

The easiest way to set up the connection is by using the configuration assistant. Do the
following:

1 Select Settings → Configuration Wizard to start the assistant.
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2 Enter your username and the name of the device to which the handheld is con-
nected.

3 Choose from one of the following options:

• Select Autodetect Handheld & Username if you want the assistant to detect
your handheld. If the autodetection fails, refer to Section 6.2.2, “Creating a
/dev/pilot Link” (page 146).

• Click Next to configure it manually.

4 Specify the applications that should be used for synchronization. You can choose
among the KDE application suite (default), Evolution, and none. After selecting,
close the window with Finish.

6.2.2 Creating a /dev/pilot Link
The setup of the connection with a serial handheld cradle is different from that of a
USB cradle. Depending on which cradle is used, you may or may not need to create a
symbolic link named /dev/pilot.

USB
Normally, a USB cradle is autodetected and there should be no need to create the
symbolic link mentioned.

Serial
With a serial cradle, you need to know to which serial port it is actually connected.
Serial devices are named /dev/ttyS?, starting from /dev/ttyS0 for the first
port. To set up a cradle connected to the first serial port, enter the command:
ln -s /dev/ttyS0 /dev/pilot

6.3 Configuring the KAddressBook
Conduit

Initially, it should be sufficient to enable the KAddressBook conduit without changing
any of the defaults. After the data has been synchronized for the first time, configure
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the details: what to do in case of conflicts, the way in which backup databases are saved,
and how certain fields stored on the handheld should be assigned to the fields expected
by KAddressBook.

6.4 Managing To-Do Items and Events
On the KDE desktop, to-dos (tasks) and events (appointments) are managed with KOr-
ganizer. Start the application from the main menu, with the command korganizer,
or as part of Kontact. After enabling the calendar and the to-do conduit of KPilot, set
some configuration options before using them.

Figure 6.2 KPilot Configuration

KOrganizer stores its files in the directory ~/.kde/share/apps/korganizer.
However, given that the directory .kde begins with a dot, it may not be shown by the
file selection dialog. In this case, enter the complete path manually or explicitly toggle
the display of hidden files (dot files) in the file selection dialog. The default shortcut
for this is F8 .

After opening the directory ~/.kde/share/apps/korganizer, select a file that
can be used as a calendar file by KOrganizer. In this example, this is the file palm
.ics. In the case of a user called tux, the complete path and filename would be
/home/tux/.kde/share/apps/korganizer/palm.ics, as shown in Fig-
ure 6.3, “Dialog Showing the Path to a KOrganizer Calendar File” (page 148).
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Figure 6.3 Dialog Showing the Path to a KOrganizer Calendar File

KOrganizer should not be running when data is being exchanged with the handheld.
Otherwise KPilot fails to carry out the sync operation.

6.5 Working with KPilot
Synchronizing the data of KDE applications with those of the handheld computer is
easy. Simply start KPilot then press the HotSync button on the cradle or cable to initiate
the sync operation.
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Figure 6.4 The Main Window of KPilot

6.5.1 Backing Up Data from the Handheld
To do a full backup, select File → Backup. The backup is performed during the next
sync operation. After that, switch back by selecting File → HotSync from the menu.
Otherwise, the time-consuming full backup will be performed again during the next
sync operation.

After a full backup, all copies of the handheld's programs and databases are found in
~/.kde/share/apps/kpilot/DBBackup/USERNAME, where USERNAME is
the name of the user registered on the handheld.

The two built-in KPilot viewers can be used for a quick lookup of addresses or memos,
but they are not designed to actually manage this data. The KDE applications mentioned
above are much more suited for these tasks.
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6.5.2 Installing Programs on the Handheld
The File Installermodule is an interesting and useful tool for the installation of handheld
programs. These programs normally have the extension .prc and they are ready to
start immediately after uploading them to the handheld. Before using such add-on pro-
grams, read their licenses as well as the instructions included.
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7Instant Messaging with
Kopete
Kopete is an online messenger application allowing multiple partners connected to the
Internet to chat with each other. Kopete currently supports all common messenger
protocols, such as ICQ, MSN, Yahoo, SMS, Jabber, and IRC.

7.1 Configuring Kopete
Configure Kopete by entering your personal user data. Click Settings → Configure
Kopete. With Accounts, enter your user data. You must register with a provider offering
instant messaging services before using such service. ClickNew to open a configuration
assistant that can assist you in completing your user profile.

The next step lists the available messaging services. Select the service with which you
have registered and click Continue. Then enter the user data received on registration
with the messaging service. This usually consists of the nickname or e-mail address
and a password. Complete the configuration of the messenger account by clicking
Finish.
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Figure 7.1 Kopete Configuration Panels

The next item in the configuration dialog is Appearance. It influences how Kopete is
displayed. Emoticons provides a selection of various types of smileys.

Use Chat window and Colors & Fonts to adjust the appearance of the chat windows
for communication with other participants. Choose from the classic themes of the cor-
responding providers or create a custom theme by adjusting the font or color to your
preferences.

7.2 Adding Contacts
Add contacts to chat with them. If you have already created an account on another PC,
this data is imported and automatically added to your contact list. To create a contact
entry manually, click File→ Add Contact. A new assistant appears to help with creation.
However, you must be online and connect with Kopete to the selected messaging service
to add a contact to your list.

7.3 Adding Groups
Access this with File → Create New Group. Name the group and confirm this with
OK. A new folder appears in the contact list that can be used to store the desired contacts.
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Drag and drop contacts into the desired folder. Grouping contacts can give a better
overview.

Figure 7.2 The Main Kopete Window

Empty groups can be disabled by activating Settings → Hide Empty Groups.

7.4 Using Kopete
It is necessary to establish a connection to the Internet to be able to chat with other
participants. When this is done, you should set your status by clicking File→ Set Status
→ Online. This establishes a connection between Kopete and the selected messaging
service. After the successful login, you are visible to others.

The main application windows features a list of contacts. You must have contacts to
chat with others (see Section 7.2, “Adding Contacts” (page 152) for more information).
When you right-click a contact marked as online, a menu opens with various options.
Send that person a message or start a chatting session. A chat allows invitation of addi-
tional participants for real-time discussion. Connection to all participants is closed when
the creator of the chat session closes it.

If you want to see your former chatting session, select a contact and go to Edit → View
History. This menu item opens a dialog where you can search and view your chatting
sessions with this person.

You can view other options by right-clicking a username. A pop-up menu opens. An
important option is Start Chat to start a chatting session. With Rename Contact and
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Remove Contact, you can run the respective action. The pop-up menu also contains a
submenu item with the username where you can block the user or get user information.
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8Using Voice over IP
Linphone is a small Web phone application for your Linux desktop. It allows you to
make two-party calls over the Internet. There is no need for special hardware items: a
standard workstation with a properly configured sound card, microphone, and speakers
or headphones is all you need to get started with Linphone.

8.1 Configuring Linphone
Before you start using Linphone there are some basic decisions to make and some
configuration tasks to complete. First, determine and configure the run mode of Lin-
phone, determine the connection type to use, then start the Linphone configuration (Go
→ Preferences) to make the necessary adjustments.

8.1.1 Determining the Run Mode of
Linphone

Linphone can be run in two different different modes, depending on the type of desktop
you run and on its configuration.

Normal Application
After the Linphone software has been installed, it can be started via the GNOME
and KDE application menus or via the command line. When Linphone is not run-
ning, incoming calls cannot be received.
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GNOME Panel Applet
Linphone can be added to the GNOME panel. Right-click an empty area in the
panel, select Add to Panel, and select Linphone. Linphone is then permanently
added to the panel and automatically started on login. As long as you do not receive
any incoming calls, it runs in the background. As soon as you get an incoming call,
the main window opens and you can receive the call. To open the main window to
call someone, just click the applet icon.

8.1.2 Determining the Connection Type
There are several different ways to make a call in Linphone. How you make a call and
how you reach the other party is determined by the way you are connected to the network
or the Internet.

Linphone uses the session initiation protocol (SIP) to establish a connection with a re-
mote host. In SIP, each party is identified by a SIP URL:
sip:username@hostname

username is your login on your Linux machine and hostname the name of the
computer you are using. If you use a SIP provider, the URL would look like the follow-
ing example:
sip:username@sipserver

username is the username chosen when registering at a SIP server. sipserver is
the address of the SIP server or your SIP provider. For details on the registration proce-
dure, refer to Section 8.1.5, “Configuring the SIP Options” (page 158) and check the
provider's registration documentation. For a list of providers suitable for your purpose,
check the Web pages mentioned in Section 8.8, “For More Information” (page 165).

The URL to use is determined by the type of connection you choose. If you chose to
call another party directly without any further routing by a SIP provider, you would
enter a URL of the first type. If you chose to call another party via a SIP server, you
would enter a URL of the second type.

Calling in the Same Network
If you intend to call a friend or coworker belonging to the same network, you just need
the correct username and hostname to create a valid SIP URL. The same applies if this
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person wants to call you. As long as there is no firewall between you and the other
party, no further configuration is required.

Calling across Networks or the Internet (Static IP
Setup)
If you are connected to the Internet using a static IP address, anyone who wants to call
you just needs your username and the hostname or IP address of your workstation to
create a valid SIP URL, as described in Section “Calling in the Same Network”
(page 156). If you or the calling party are located behind a firewall that filters incoming
and outgoing traffic, open the SIP port (5060) and the RTP port (7078) on the firewall
machine to enable Linphone traffic across the firewall.

Calling across Networks or the Internet (Dynamic IP
Setup)
If your IP setup is not static—if you dynamically get a new IP address every time you
connect to the Internet—it is impossible for any caller to create a valid SIP URL based
on your username and an IP address. In these cases, either use the services offered by
a SIP provider or use a DynDNS setup to make sure that an external caller gets connected
to the right host machine. More information about DynDNS can be found at http://
en.wikipedia.org/wiki/Dynamic_DNS.

Calling across Networks and Firewalls
Machines hidden behind a firewall do not reveal their IP address over the Internet. Thus,
they cannot be reached directly from anyone trying to call a user working at such a
machine. Linphone supports calling across network borders and firewalls by using a
SIP proxy or relaying the calls to a SIP provider. Refer to Section 8.1.5, “Configuring
the SIP Options” (page 158) for a detailed description of the necessary adjustments for
using an external SIP server.

8.1.3 Configuring the Network Parameters
Most of the settings contained in the Network tab do not need any further adjustments.
You should be able to make your first call without changing them.
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NAT Traversal Options
Enable this option only if you find yourself in a private network behind a firewall
and if you do not use a SIP provider to route your calls. Select the check box and
enter the IP address of the firewall machine in dot notation, for example,
192.168.34.166.

RTP Properties
Linphone uses the real-time transport protocol (RTP) to transmit the audio data of
your calls. The port for RTP is set to 7078 and should not be modified, unless you
have another application using this port. The jitter compensation parameter is used
to control the number of audio packages Linphone buffers before actually playing
them. By increasing this parameter, you improve the quality of transmission. The
more packages buffered, the greater a chance for “late comers” to be played back.
On the other hand increasing the number of buffered packages also increases the
latency—you hear the voice of your counterpart with a certain delay. When
changing this parameter, carefully balance these two factors.

Other
If you use a combination of VoIP and landline telephony, you might want to use
the dual tone multiplexed frequency (DTMF) technology to trigger certain actions,
like a remote check of your voice mail just by punching certain keys. Linphone
supports two protocols for DTMF transmission, SIP INFO and RTP rfc2833. If
you need DTMF functionality in Linphone, choose a SIP provider that supports
one of these protocols. For a comprehensive list of VoIP providers, refer to Sec-
tion 8.8, “For More Information” (page 165).

8.1.4 Configuring the Sound Device
Once your sound card has been properly detected by Linux, Linphone automatically
uses the detected device as the default sound device. Leave the value ofUse sound device
as it is. Use Recording source to determine which recording source should be used. In
most cases, this would be a microphone (micro). To select a custom ring sound, use
Browse to choose one and test your choice using Listen. Click Apply to accept your
changes.

8.1.5 Configuring the SIP Options
The SIP dialog contains all SIP configuration settings.
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SIP Port
Determine on which port the SIP user agent should run. The default port for SIP
is 5060. Leave the default setting unchanged unless you know of any other appli-
cation or protocol that needs this port.

Identity
Anyone who wants to call you directly without using a SIP proxy or a SIP provider
needs to know your valid SIP address. Linphone creates a valid SIP address for
you.

Remote Services
This list holds one or more SIP service providers where you have created a user
account. Server information can be added, modified, or deleted at any time. See
Adding a SIP Proxy and Registering at a Remote SIP Server (page 159) to learn
about the registration procedure.

Authentication Information
To register at a remote SIP server, provide certain authentication data, such as a
password and username. Linphone stores this data once provided. To discard this
data for security reasons, click Clear all stored authentification data.

The Remote services list can be filled with several addresses of remote SIP proxies or
service providers.

Procedure 8.1 Adding a SIP Proxy and Registering at a Remote SIP Server

1 Choose a suitable SIP provider and create a user account there.

2 Start Linphone.

3 Go to Go → Preferences → SIP.

4 Click Add proxy/registrar to open a registration form.

5 Fill in the appropriate values for Registration Period, SIP Identity, SIP Proxy
and Route. If working from behind a firewall, always select Send registration
and enter an appropriate value for Registration Period. This resends the original
registration data after a given time to keep the firewall open at the ports needed
by Linphone. Otherwise, these ports would automatically be closed if the firewall
did not receive any more packages of this type. Resending the registration data
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is also needed to keep the SIP server informed about the current status of the
connection and the location of the caller. For SIP identity, enter the SIP URL
that should be used for local calls. To use this server also as a SIP proxy, enter
the same data for SIP Proxy. Finally, add an optional route, if needed, and leave
the dialog with OK.

8.1.6 Configuring the Audio Codecs
Linphone supports a several codecs for the transmission of voice data. Set your connec-
tion type and choose your preferred codecs from the list window. Codecs not suitable
for your current connection type are red and cannot be selected.

8.2 Testing Linphone
Check your Linphone configuration using sipomatic, a small test program that can
answer calls made from Linphone.

Procedure 8.2 Testing a Linphone Setup

1 Open a terminal.

2 Enter sipomatic at the command line prompt.

3 Start Linphone.

4 Enter sip:robot@127.0.0.1:5064 as SIP address and click Call or An-
swer.

5 If Linphone is configured correctly, you will hear a phone ringing and, after a
short while, you will hear a short announcement.

If you successfully completed this procedure, you can be sure that your audio setup and
the network setup are working. If this test fails, check whether your sound device is
correctly configured and whether the playback level is set to a reasonable value. If you
still fail to hear anything, check the network setup including the port numbers for SIP
and RTP. If any other application or protocol uses the defaults ports for these as proposed
by Linphone, consider changing ports and retry.
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8.3 Making a Call
Once Linphone is configured appropriately, making a call is straightforward. Depending
on the type of call (see Section 8.1.2, “Determining the Connection Type” (page 156)
for reference), the calling procedures differ slightly.

1 Start Linphone using the menu or a command line.

2 Enter the SIP address of the other party at the SIP address prompt. The address
should look like sip:username@domainname or username@hostname
for direct local calls or likeusername@sipserver oruserid@sipserver
for proxied calls or calls using the service of a SIP provider.

3 If using a SIP service provider or a proxy, select the appropriate proxy or provider
from Proxy to use and provide the authentication data requested by this proxy.

4 Click Call or Answer and wait for the other party to pick up the phone.

5 Once you are done or wish to end the call, click Release or Refuse and leave
Linphone.

If you need to tweak the sound parameters during a call, click Show more to show four
tabs holding more options. The first one holds the Sound options for Playback level
and Recording level. Use the sliders to adjust both volumes to fit your needs.

The Presence tab lets you set your online status. This information can be relayed to
anyone who tries to contact you. If you are permanently away and wish to inform the
calling party of this fact, just check Away. If you are just busy, but want the calling
party to retry, check Busy, I'll be back in ... min and specify how long you will not be
reachable. Once you are reachable again, set the status back to the default (Reachable).
Whether another party can check your online status is determined by the Subscribe
Policy set in the address book, as described in Section 8.5, “Using the Address Book”
(page 162). If any party listed in your address book published their online status, you
can monitor it using the My online friends tab.

The DTMF tab can be used to enter DTMF codes for checking voice mail. To check
your voice mail, enter the appropriate SIP address and use the keypad in the DTMF tab
to enter the voice mail code. Finally, click Call or Answer as if you were making an
ordinary call.
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8.4 Answering a Call
Depending on the run mode selected for Linphone, there are several ways you would
notice an incoming call:

Normal Application
Incoming calls can only be received and answered if Linphone is already running.
You then hear the ring sound on your headset or your speakers. If Linphone is not
running, the call cannot be received.

GNOME Panel Applet
Normally, the Linphone panel applet would run silently without giving any notice
of its existence. This changes as soon as a call comes in: the main window of Lin-
phone opens and you hear a ring sound on your headset or speakers.

Once you have noticed an incoming call, just click Call or Answer to pick up the phone
and start talking. If you do not want to accept this call, click Release of Refuse.

8.5 Using the Address Book
Linphone offers to manage your SIP contacts. Start the address book withGo→ Address
book. An empty list window opens. Click Add to add a contact.

The following entries need to be made for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a
nickname here. Choose something you easily remember this person as. If you
choose to see this person's online status, this name is shown in the My online friends
tab of the main window.

SIP Address
Enter a valid SIP address for your contact.

Proxy to Use
If needed, enter the proxy to use for this particular connection. In most cases, this
would just be the SIP address of the SIP server you use.
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Subscribe Policy
Your subscribe policy determines whether your presence or absence can be tracked
by others.

To call any contact from the address book, select this contact with the mouse, click
Select to make the address appear in the address field of the main window, and start
the call with Call or Answer as usual.

8.6 Troubleshooting
I try to call someone, but fail to establish a connection.

There are several reasons why a call could fail:

Your connection to the Internet is broken.
Because Liphone uses the Internet to relay your calls, make sure that your
computer is properly connected to and configured for the Internet. This can
easily be tested by trying to view a Web page using your browser. If the Internet
connection works, the other party might not be reachable.

The person you are calling is not reachable.
If the other party refused your call, you would not be connected. If Linphone
is not running on the other party's machine while you are calling, you will not
be connected. If the other party's Internet connection is broken, you cannot
make the connection.

My call seems to connect, but I cannot hear anything.
First, make sure that your sound device is properly configured. Do this by launching
any other application using sound output, such as a media player. Make sure that
Linphone has sufficient permissions to open this device. Close all other programs
using the sound device to avoid resource conflicts.

If the above checks were successful, but you still fail to hear anything, raise the
recording and playback levels under the Sound tab.

The voice output on both ends sounds strangely clipped.
Try to adjust the jitter buffer using RTP properties in Preferences → Network to
compensate for delayed voice packages. When doing this, be aware that it increases
the latency.
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DTMF does not work.
You tried to check your voice mail using the DTMF pad, but the connection could
not be established. There are three different protocols used for the transmission of
DTMF data, but only two of these are supported by Linphone (SIP INFO and RTP
rfc2833). Check with your provider whether it supports one of these. The default
protocol used by Linphone is rfc2833, but if that fails you can set the protocol to
SIP INFO in Preferences → Network → Other. If it does not work with either of
them, DTMF transmission cannot be done using Linphone.

8.7 Glossary
Find some brief explanation of the most important technical terms and protocols men-
tioned in this document:

VoIP
VoIP stands for voice over Internet protocol. This technology allows the transmis-
sion of ordinary telephone calls over the Internet using packet-linked routes. The
voice information is sent in discrete packets like any other data transmitted over
the Internet via IP.

SIP
SIP stands for session initiation protocol. This protocol is used to establish media
sessions over networks. In a Linphone context, SIP is the magic that triggers the
ring at your counterpart's machine, starts the call, and also terminates it as soon as
one of the partners decides to hang up. The actual transmission of voice data is
handled by RTP.

RTP
RTP stands for real-time transport protocol. It allows the transport of media streams
over networks and works over UDP. The data is transmitted by means of discrete
packets that are numbered and carry a time stamp to allow correct sequencing and
the detection of lost packages.

DTMF
A DTMF encoder, like a regular telephone, uses pairs of tones to represent the
various keys. Each key is associated with a unique combination of one high and
one low tone. A decoder then translates these touch-tone combinations back into
numbers. Linphone supports DTMF signalling to trigger remote actions, such as
checking voice mail.
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codec
Codecs are algorithms specially designed to compress audio and video data.

jitter
Jitter is the variance of latency (delay) in a connection. Audio devices or connection-
oriented systems, like ISDN or PSTN, need a continuous stream of data. To com-
pensate for this, VoIP terminals and gateways implement a jitter buffer that collect
the packets before relaying them onto their audio devices or connection-oriented
lines (like ISDN). Increasing the size of the jitter buffer decreases the likelihood
of data being missed, but the latency of the connection is increased.

8.8 For More Information
For general information about VoIP, check the VoIP Wiki at http://voip-info
.org/tiki-index.php. For a comprehensive list of providers offering VoIP ser-
vices in your home country, refer to http://voip-info.org/wiki-VOIP
+Service+Providers+Residential.
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9Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
SUSE® Linux Enterprise Desktop offers various different ways of accessing and creating
network shared resources:

Network Browsing
Your file manager, Konqueror, lets you browse your network for shared resources
and services. Learn more about this in Section 9.2, “Accessing Network Shares”
(page 169).

Sharing Folders in Mixed Environments
Using Konqueror, configure your files and folders to share with other members of
your network. Make your data readable or writable for users from any Windows
or Linux workstation. Learn more about this in Section 9.3, “Sharing Folders in
Mixed Environments” (page 170).

Managing Windows Files
SUSE Linux Enterprise Desktop can be configured to integrate into an existing
Windows network. Your Linux machine then behaves like a Windows client. It
takes all account information from the Active Directory domain controller, just as
the Windows clients do. Learn more about this in Section 9.4, “Managing Windows
Files” (page 173).

Configuring and Accessing a Windows Network Printer
You can configure a Windows network printer through the KDE Control Center.
Learn how to configure this in Section 9.5, “Configuring and Accessing a Windows
Network Printer” (page 176).
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Configuring Shortcuts to Network Folders
By creating shortcuts to remote network folders (FTP, WebDAV, Windows Network
Drives, and SSH), interacting with them can be greatly simplified. Learn how to
configure this in Section 9.6, “Configuring Shortcuts to Network Folders” (page 178).

Configuring a Small Web Server
If you need a simple way to share information with others, set up a lean Web
server. Learn how to do this in Section 9.7, “Configuring and Using a Small Web
Server” (page 180).

9.1 General Notes on File Sharing and
Network Browsing

Whether and to which extent you can use file sharing and network browsing on your
machine and in your network highly depends on the network structure and on the con-
figuration of your machine. Before setting up either of them, contact your system ad-
ministrator to make sure that your network structure supports this feature and to check
whether your company's security policies permit it.

Network browsing, be it SMB browsing for Windows shares or SLP browsing for remote
services, relies heavily on the machine's ability to send broadcast messages to all clients
in the network. These messages and the clients' replies to them enable your machine to
detect any available shares or services. For broadcasts to work effectively, your machine
must be part of the same subnet as all other machines it is querying. If network browsing
does not work on your machine or the detected shares and services do not match with
what you expected, contact your system administrator to make sure that you are con-
nected to the appropriate subnet.

To allow network browsing, your machine needs to keep several network ports open
to send and receive network messages that provide details on the network and the
availability of shares and services. The standard SUSE Linux Enterprise Desktop is
configured for tight security and has a firewall up and running that protects your machine
against the Internet. To adjust the firewall configuration, you would either need to ask
your system administrator to open a certain set of ports to the network or to tear down
the firewall entirely according to your company's security policy. If you try to browse
a network with a restrictive firewall running on your machine, Konqueror warns you
about your security restrictions not allowing it to query the network.
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9.2 Accessing Network Shares
Networking workstations can be set up to share folders. Typically, files and folders are
marked to let remote users access them. These are called network shares. If your system
is configured to access network shares, you can use your file manager to access these
shares and browse them just as easily as if they were located on your local machine.
Whether you have only read access or also write access to the shared folders depends
on the permissions granted to you by the owner of the shares.

To access network shares, click the Network Browsing icon on your desktop or open
Konqueror and enter remote:/ in the location bar. Konqueror then opens a virtual
folder that displays the network share types that you can access. Click a network resource
type then click the network share to access. You might be required to authenticate to
the resource by providing a username and password.

Figure 9.1 Network Browsing
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9.3 Sharing Folders in Mixed
Environments

Sharing and exchanging documents is a must-have in corporate environments. Konqueror
offers you file sharing with Samba, which makes your files and folders available to
both Linux and Windows users. To configure Samba file sharing with Konqueror,
proceed as follows:

1 Open Konqueror.

2 Right-click the window background then selectProperties from the context menu.

3 In the Properties dialog, click the Share tab. When file sharing is not yet gener-
ally enabled, you are informed about this on the tab. To enable file sharing or
select the files to share, click Configure File Sharing and enter the root pass-
word.

4 To enable or disable file sharing, select or deselect Enable Local Network File
Sharing.

Figure 9.2 Enabling File Sharing

5 Select the appropriate sharing option: Simple sharing or Advanced sharing.

170 KDE User Guide



6 To limit the number of users allowed to share folders to certain groups, click
Allowed Users, select Only users of a certain group are allowed to share folders,
click Choose Group, and select the appropriate group from the list in the window
that opens.

7 Add the folder to share to the list of shared items at the bottom of the dialog by
clicking Add and specifying the folder's exact path.

Figure 9.3 Detailed Sharing Options

8 Activate Share with Samba to enable Samba file sharing. If needed, apply some
fine-tuning to the Samba options:

Name
Specify a name other than the preset default.

Public/Writable
Determine which kind of access to grant others to your share. You can grant
users full read and write access or limit their access to just reading your
shares.
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More Samba Options
These contain basic settings like name, an optional comment, and basic access
rights as well as user and security settings and an option to hide particular
files and subfolders in the shared folder.

9 Apply your settings and leave the file sharing dialog with OK.

The folder icon now appears in Konqueror with a plug.

Figure 9.4 Shared Folder

To revoke the share, enter the file sharing dialog again and remove the folder
from the list of shared items. The folder icon then appears without a plug.

Other members of your network can reach your share by entering smb:/ in the location
bar of Konqueror and clicking the appropriate workgroup icon and hostname.

IMPORTANT: Samba Domain Browsing

Samba domain browsing only works if your system's firewall is configured ac-
cordingly. Either disable the firewall entirely or assign the browsing interface
to the internal firewall zone. Ask your system administrator about how to
proceed. This procedure is described in more detail in Section 11.3, “Configuring
a Linux Client for Active Directory” (Chapter 11, Active Directory Support,
↑Deployment Guide).
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9.4 Managing Windows Files
With your SUSE Linux Enterprise Desktop machine being an Active Directory client
as described in Chapter 11, Active Directory Support (↑Deployment Guide), you can
browse, view, and manipulate data located on Windows servers. The following examples
are just the most prominent ones:

Browsing Windows Files with Konqueror
Use Konqueror's smb:/ browsing option to browse your Windows data.

Viewing Windows Data with Konqueror
Use Konqueror to display the contents of your Windows user folder just as you
would for displaying a Linux directory. Create new files and folders on the Windows
server.

Manipulating Windows Data with KDE Applications
KDE applications, such as the Kate text editor, allow you to open files on the
Windows server, manipulate them, and save them to the Windows server.

Single-Sign-On
KDE applications, including Konqueror, support Single-Sign-On, which means
that to access other Windows resources, such as Web servers, proxy servers, or
groupware servers like MS Exchange, you do not need to reauthenticate. Authenti-
cation against all these is handled silently in the background once you provided
your username and password on login.

To access your Windows data using Konqueror, proceed as follows:

1 Press Alt + F2 and enter smb://

This opens a Konqueror window displaying all Samba workgroups and domains
that could be found in your network.

2 Click the icon of the workgroup or domain of your AD server.
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Figure 9.5 Browsing Data on the AD Server

3 Click the Users folder and select your personal user folder icon. The contents of
your My Documents folder are displayed.

To create folders in your Windows user folder using Konqueror, proceed as you would
when creating a Linux folder:

1 Right-click the background of the Konqueror folder view to open the menu.

2 Select Create New → Folder.

3 Enter the new folder's name when prompted to do so.

To create a file on the AD server, proceed as described in the following example for
the Kate text editor.

1 Press Alt + F2 and enter kate.

2 Enter your text.
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Figure 9.6 Editing a Text File with Kate

3 To save the newly created text, select Save as.

4 Click the Network Folders icon to the left and select SMB Shares.

Figure 9.7 Saving a File to a Remote Windows Folder

5 Navigate to your Windows folder.

6 Enter the filename and click Save.

The file is saved on the Windows server.

Make use of Konqueror's Single-Sign-On support, as in the following example—Web
access to your MS Exchange mailbox:
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1 Make sure that you have a valid MS Exchange account under your current Win-
dows user identity.

2 Request the Exchange server's address from your system administrator.

3 Press Alt + F2 and enter konqueror
http://address_exchange_server.

You are logged in to your Exchange account without having to reauthenticate.

Figure 9.8 Accessing MS Exchange through Konqueror

4 Write or read your e-mails and log out as usual.

9.5 Configuring and Accessing a
Windows Network Printer

Being part of a corporate network and authenticating against a Windows Active Direc-
tory server, you can access corporate resources, such as printers. KDE allows you to
configure printing from your Linux client to a Windows network printer.

To configure a Windows network printer for use through your Linux workstation, pro-
ceed as follows:

1 Start the KDE Control Center from the main menu.
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2 Select Peripherals → Printers.

Figure 9.9 Adding a Printer

3 Select Add → Add Special (pseudo) Printer.

Figure 9.10 Adding Printer Details

4 Enter the printer's name, a short description, and its location.
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5 Enter a command line similar to the following example in Command Settings:
smbclient //domain/printer -k -d 0 -c 'put %in' > /dev/null 2>&1

Replace domain and printer with the exact values matching your setup.

6 Check Enable output file and select application/postscript to pipe all your print
jobs to a postscript file.

7 Leave the printer configuration with OK.

8 Leave the KDE Control Center with File → Quit.

The printer is ready for use.

To print to the Windows network printer configured above, just select it from the list
of available printers in KPrinter.

9.6 Configuring Shortcuts to Network
Folders

With KNetAttach, you can also add new network folders to this view by clicking Add
a Network Folder in a Konqueror remote:/ view. A wizard opens where you can
select the type of network folder to access and enter the details, such as a name for the
network folder, the address of the server (either the IP address or domain name), the
login name, the port, and the path to folder to access.
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Figure 9.11 Adding a Network Folder

After finishing, you can access the network share in Konqueror by clicking the newly
created link instead of entering a lengthy URL for this share in the location bar.

Figure 9.12 New Network Folder

If you add a network folder in this way, you can also access this folder easily when
opening or saving a file from a KDE application. If you click Network Folders in the
left-hand bar of an Open File or a Save File dialog, the network folder you added ap-
pears.
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Figure 9.13 Opening a File from a Network Share

TIP: Linking to Network Shares on the Desktop

For quick access to network shares you need very often, you can also create
links to these resources on your desktop. To do so, select the desired resource
in Konqueror and drag it onto your desktop while keeping the left mouse
button pressed. From the context menu, select Link Here. A new icon appears
on your desktop. If you click that icon, Konqueror opens and displays the
content of this directory.

9.7 Configuring and Using a Small
Web Server

Thekpf utility provides simple file sharing using HTTP (Hyper Text Transfer Protocol),
which is the same protocol used by Web sites to provide data to your Web browser.
kpf is strictly a public file server, which means that there are no access restrictions to
shared files. Whatever you select for sharing is available to anyone.

IMPORTANT: Security Considerations

Before setting up a file server with kpf, check with your system administrator
whether your company's security policies allow this. You should never set up
a file server in a corporate or private environment if you are not entirely sure
that your network is protected by an outer firewall. Otherwise you might risk
accidentally leaking sensitive information to the Web. In addition to that, any
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Web server is a potential target for hacker's exploits. Setting up a Web server
in a secure way is a very hard job and kpf was not designed to act as such a
Web server.

kpf is designed to be used for sharing files with friends, not to act as a fully-fledged
Web server like Apache. kpf was primarily conceived as an easy way to share files with
others while chatting on IRC (Internet Relay Chat, or chat rooms).

kpf is typically set up to serve files from a public_html folder in your home direc-
tory. For example, if you want to make a file available to some people with whom you
are chatting online, you can use kpf to copy the file into your public_html folder
and announce to those listening that your file is available athttp://www.mymachine
.net:8001/thefile (rather than send them each an e-mail with the file attached).

1 Right-click the bottom panel in KDE then click Add Applet to Panel and select
Public File Server.

A new icon depicting a small globe appears on the bottom panel.

2 Right-click the icon then click New Server.

3 Specify the directory containing the files you want to share then click Next.
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Figure 9.14 Selecting the File Server Root Directory

All files in the folder and its subfolders, including hidden files (files that start
with a dot) and symbolic links, are made publicly available, so be careful not to
share sensitive information, such as passwords, cryptographic keys, your address
book, or documents private to your organization. Make sure that any symbolic
links included do not point outside your published folder, because that would
give others access to areas of your system that are not intended for public viewing.

4 Complete the remainder of the New Server wizard to share the folder specified
in Step 3 (page 181).

The directory icon now appears in Konqueror with a world icon at the bottom
right side.

Other parties wishing to connect to this server should just enter a URL like http://
hostname:8001 into their browsers. An overview of the published content is dis-
played.
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Figure 9.15 Published Contents

On the hosting machine, you can monitor the network traffic on your file server by
right-clicking the globe icon and selecting Monitor. A short set of statistics similar to
the following is given.

Figure 9.16 File Server Statistics
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10Encryption with KGpg
KGpg is an important component of the encryption infrastructure on your system. With
the help of this program, generate and manage all needed keys. Use its editor function
for the quick creation and encryption of files or use the applet in your panel to encrypt
or decrypt by dragging and dropping. Other programs, such as your mail program
(Kontact or Evolution), access the key data to process signed or encrypted contents.
This chapter covers the basic functions needed for daily work with encrypted files.

10.1 Generating a New Key Pair
To be able to exchange encrypted messages with other users, first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can use it to encrypt the files or e-mail messages they send. The other part of the
key pair—the private key—is used to decrypt the encrypted contents.

IMPORTANT: Private Key versus Public Key

The public key is intended for the public and should be distributed to all your
communication partners. However, only you should have access to the private
key. Do not grant other users access to this data.

Start KGpg from the main menu or press Alt + F2 and enter kgpg. When you start the
program for the first time, an assistant appears to guide you through the configuration.
Follow the instructions up to the point where you are prompted to create a key. Enter
a name, an e-mail address, and, optionally, a comment. If you do not like the default
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settings provided, also set the expiration time for the key, the key size, and the encryption
algorithm used. See Figure 10.1, “KGpg: Creating a Key” (page 186).

When you start KGpg in later sessions, only a small icon with a padlock appears in the
system tray. Click that icon to display the main KGpg window on your desktop.

Figure 10.1 KGpg: Creating a Key

Confirm your settings withOK. The next dialog prompts you to enter a password twice.
The relative strength of your chosen password is measured and displayed by the Pass-
word strength meter. The program then generates the key pair and displays a summary.
It is a good idea to save or print a revocation certificate right away. Such a certificate
is needed if you forget the password for your private key so need to revoke it. After
you confirm with OK, KGpg displays its main window. See Figure 10.2, “The Key
Manager” (page 187).
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Figure 10.2 The Key Manager

10.2 Exporting the Public Key
After generating your key pair, make the public key available to other users. This enables
them to use it to encrypt or sign the messages or files they send you. To make the public
key available for others, select Keys → Export Public Key(s). The dialog that opens
offers four options:

Email
Your public key is sent to a recipient of your choice by e-mail. If you activate this
option and confirm with OK, the dialog for creating a new e-mail message with
KMail appears. Enter the recipient and click Send. The recipient receives your key
and can then send you encrypted contents.

Clipboard
You can place your public key here before continuing to process it.

Default Key Server
To make your public key available to a wide audience, export it to one of the key
servers on the Internet. For more information, refer to Section 10.4, “The Key
Server Dialog” (page 189).

File
If you prefer to distribute your key as a file on a data medium instead of sending
it by e-mail, click this option, confirm or change the file path and name, and click
OK.
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10.3 Importing Keys
If you receive a key in a file (for example, as an e-mail attachment), integrate it in your
key ring with Import Key and use it for encrypted communication with the sender. The
procedure is similar to the procedure for exporting keys already described.

10.3.1 Signing Keys
Keys can be signed like every other file to guarantee their authenticity and integrity. If
you are absolutely sure an imported key belongs to the individual specified as the
owner, express your trust in the authenticity of the key with your signature.

IMPORTANT: Establishing a Web of Trust

Encrypted communication is only secure to the extent that you can positively
associate public keys in circulation with the specified user. By cross-checking
and signing these keys, you contribute to the establishment of a web of trust.

Select the key to sign in the key list. Select Keys → Sign Keys. In the following dialog,
designate the private key to use for the signature. An alert reminds you to check the
authenticity of this key before signing it. If you have performed this check, click Con-
tinue and enter the password for the selected private key in the next step. Other users
can now check the signature by means of your public key.

10.3.2 Trusting Keys
Normally, you are asked by the corresponding program whether you trust the key
(whether you assume it is really used by its authorized owner). This happens each time
a message needs to be decrypted or a signature must be checked. To avoid this, edit the
trust level of the newly imported key. By default, a newly imported key is listed with
a white box, meaning that no concrete value has been assigned for the trust level.

Right-click the newly imported key to access a small context menu for key management.
Select Sign Keys from it. KGpg opens a text a message box and asks the user to recheck
the fingerprint of the key. Use Continue to access the key signing dialog.
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Select your trust level, for example, select I Have Done Very Careful Checking. After
finishing this dialog, you need to enter your passphrase to finish the key signing process.
The newly imported key now displays a green trust level for a trusted key.

The trust level of the keys in your key ring is indicated by a colored bar next to the key
name. The lower the trust level is, the less you trust the signer of the key to have checked
the true identity of the keys signed. You may be entirely sure about the signer's identity,
but he may still be lazy in regard to checking other people's identities before signing
their keys. Therefore, you could still trust him and his own key, but assign lower trust
levels to the keys of others that have been signed by him. The trust level's purpose is
solely one of a reminder. It does not trigger any automatic actions by KGpg.

10.4 The Key Server Dialog
Several Internet-based key servers offer the public keys of many users. To engage in
encrypted communication with a large number of users, use these servers to distribute
your public key. For this purpose, export your public key to one of these servers. Simi-
larly, KGpg enables you to search one of these servers for the keys of certain people
and import their public keys from the server. Open the key server dialog with File →
Key Server Dialog.

10.4.1 Importing a Key from a Key Server
By means of the Import tab in the key server dialog, import public keys from one of
the Internet-based key servers. Select one of the preconfigured key servers and enter a
search string (e-mail address of the communication partner) or the ID of the key to find.
When you click Search, your system connects to the Internet and searches the specified
key server for a key that matches your specifications. Refer to Figure 10.3, “Search
Screen for Importing a Key” (page 190).

Encryption with KGpg 189



Figure 10.3 Search Screen for Importing a Key

If your search on the key server is successful, a list of all retrieved server entries is
displayed in a new window. Select the key to include in your key ring and click Import.
See Figure 10.4, “Hits and Import” (page 190). Confirm the following message with
OK then exit the key server dialog with Close. The imported key then appears in the
main overview of the key manager and is ready for use.

Figure 10.4 Hits and Import
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10.4.2 Exporting Your Keys to a Key Server
To export your key to one of the freely accessible key servers on the Internet, select
the Export tab in the key server dialog. Designate the target server and the key to export
by means of two drop-down menus. Then start the export with Export.

Figure 10.5 Exporting a Key to a Key Server

10.5 Text and File Encryption
KGpg also offers the possibility to encrypt text or clipboard contents. Right-click the
padlock icon and find the options Encrypt clipboard and Decrypt clipboard as well as
the option for opening the integrated editor.

10.5.1 Encrypting and Decrypting the
Clipboard

Files copied to the clipboard can easily be encrypted with a few clicks. Open the function
overview by right-clicking the KGpg padlock icon. Select Encrypt Clipboard and des-
ignate the key to use. A status message about the encryption procedure is displayed on
the desktop. The encrypted contents can now be processed from the clipboard as
needed. The decryption of clipboard contents is just as easy. Simply open the menu on
the panel, selectDecrypt Clipboard, and enter the password associated with your private
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key. The decrypted version is now available for processing in the clipboard and in the
KGpg editor.

10.5.2 Encrypting and Decrypting by
Dragging and Dropping

To encrypt or decrypt files, click the icons on the desktop or in the file manager, drag
them to the padlock in the panel, and drop them there. If the file is not encrypted, KGpg
asks for the key to use. As soon as you select a key, the file is encrypted without any
further messages. In the file manager, encrypted files are designated with the suffix
.asc and the padlock icon. These files can be decrypted by clicking the file icon,
dragging it to the KGpg symbol in the panel, and dropping it there. If the original file-
name already exists, a dialog opens that asks how to name the file or if it should be
overwritten.

10.5.3 The KGpg Editor
Instead of creating contents for encryption in an external editor then encrypting the file
with one of the methods described above, you can use the integrated editor of KGpg
to create the file. Open the editor (Open Editor from the context menu), enter the desired
text, and clickEncrypt. Then select the key to use and complete the encryption procedure.
To decrypt files, use Decrypt and enter the password associated with the key.

Generating and checking signatures on documents is just as easy as encrypting directly
from the editor. Select a file in the file manager and copy it to the clipboard. Right-click
the padlock icon in the panel and select Sign/Verify Clipboard. Then choose the private
key to use and enter the associated password. KGpg informs about the successful gen-
eration of the signature. Files can also be signed from the editor by simply clicking
Sign/Verify. To check a signed file, go to File → Open Editor, load the file to check in
the editor, and click Sign/Verify.

10.6 For More Information
For theoretical background information about the encryption method, refer to the brief
and clear introduction on the GnuPG project pages at http://www.gnupg.org/
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documentation/howtos.html.en. This document also provides a list of further
information sources.
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11Searching with Kerry
Kerry is a KDE front-end for the Beagle search tool, which indexes your personal in-
formation space to help you find whatever you need. You can use Kerry to find docu-
ments, e-mails, Web history, IM/ITC conversations, source code, images, music files,
applications, and much more.

Because Kerry is a front-end to Beagle, it needs the beagle daemon to be functional.
Kerry and Beagle can now index many KDE-specific sources of information, such as
Kopete conversations, Konqueror history, or KMail messages. The result is a smooth
integration into the KDE environment through the Kerry interface.

Find more about Beagle in GNOME User Guide.

11.1 Searching Using Kerry
To find data using the Kerry tool, follow these steps:

1 Press F12 to open the Kerry Beagle Search window. Alternatively, open the
search window by left-clicking on the Kerry applet icon (a magnifying glass over
a sheet of paper) in the system tray.

2 Enter the term to find in Search. To quickly clear the previously entered text,
press the black arrow on the left.

The search is case insensitive. It does not matter whether you use uppercase or
lowercase characters. To search for optional terms, use the OR keyword (in up-
percase). For example, Mars OR Venus finds all data containing any occurrence
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of Mars, Venus, or both. To exclude search terms, use a minus symbol (–) in
front of them. For example, Mars -Venus finds all data containing any occur-
rence of Mars but without any occurrence of Venus. To search for an exact phrase,
enclose the phrase in quotes. If you want to include only certain file type in results,
specify its extension with ext:. For example, Mars ext:xml finds xml files
containing Mars.

3 Select the scope of the search in Within on the right. To search all the indexed
content, choose Everything. However, you can limit the search only to indexed
applications, office documents, instant messenger conversations, image files,
media files, or Web pages by making an appropriate choice from the menu.

4 Press Find to start the search. Results are displayed in the main area of the win-
dow.

Results are displayed in a window, sorted according to your settings. Click any item to
activate it. To open a folder containing a found file instead of the file itself, click Reveal
in Filemanager.

You can change the sort order at any time by right-clicking the result window and
choosing your preferred sorting method from the context menu.

Use Previous results and Next results to move between pages of the result list. The
number of items found is shown in the bottom part of the window.

11.2 Configuring Kerry
You can configure Kerry by right-clicking its icon in the tray and choosing Configure
Kerry. On the Search tab, keep Start search and indexing services automatically acti-
vated if you want Kerry to index your data automatically. Use Maximum number of
results displayed to determine the number of results to show per page and Default sort
order to determine the default order of the results displayed. They can be sorted by
relevance, name, or modification date.

11.2.1 Indexing More Directories
By default, Kerry indexes your home folder only. If you want to index more folders,
follow these steps:
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1 Right-click the Kerry icon in the tray and choose Configure Kerry.

2 Click the Indexing tab.

3 If you do not want to stop indexing your home folder, keep the option Index my
home folder checked. Add more folders to the list of indexed folders by pressing
Add and choosing a folder in the dialog that opens.

To add all folders with application-related data automatically, use Applications.

To remove a folder from the list of indexed folders, select it in the list, press
Remove, and confirm.

4 Press OK.

11.2.2 Preventing Files and Directories from
Being Indexed

To exclude some folders or files from being indexed by Kerry, follow these steps:

1 Right-click the Kerry icon in the tray and choose Configure Kerry.

2 Click the Indexing tab.

3 Press Add in the lower part of the dialog (Privacy).

4 In the dialog that opens, choose a folder not to index by selecting the Folder
option. Specify the path to the folder in the text field or press the folder button
and choose the folder in a file dialog.

You can also specify files not to index by selecting the File name pattern option
and specifying the file pattern.

5 Press OK.
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12Managing Printers
Printers can either be connected to your system locally or accessed over a network.
There are several ways to set up a printer in SUSE® Linux Enterprise Desktop: with
YaST, with the KDE Printing Manager, or on the command line. This chapter describes
how to set up printers with the KDE Printing Manager. After configuring the printer
correctly, you can address it from any application.

For information about how to manage printers with iPrint® refer to the iPrint User
Guide at http://www.novell.com/documentation/sled10/.

NOTE: Troubleshooting

If you have problems configuring your printer, ask your system administrator.
An in-depth coverage of printer configuration for administrators can be found
in Chapter 19, Printer Operation (↑Deployment Guide).

12.1 Installing a Printer
Before you can install a printer, you need to have the root password and your printer
information ready. Depending on how you connect to the printer, you might need the
printer URI, TCP/IP address or host, and the driver for the printer. A number of common
printer drivers ship with SLED. If you cannot find a driver for the printer, check the
printer manufacturer’s Web site.

To set up a printer in KDE, start the Printing Manager from the main menu (Tools →
Printing → Printing Manager). Alternatively, press Alt + F2 and enter kcontrol.
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In the left-hand navigation bar of the KDE Control Center, clickPeripherals→ Printers.

Figure 12.1 Printing Manager

You can set up a printer as rootwith the help of a wizard, as described in the following.
If you are not sure which option to choose and which information to enter, ask your
system administrator.

For detailed information about how to access and configure a Windows network printer,
refer to Section 9.5, “Configuring and Accessing a Windows Network Printer” (page 176).

1 Click Administrator Mode and enter the root password.

2 Click Add and select Add Printer/Class. The Add Printer Wizard opens.

3 Click Next.

4 Select the type of connection for this printer. The following options are available:

• Local printer (parallel, serial, USB): A printer that is attached to your
workstation through a parallel, serial, or USB connection.
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• Remote LPD queue: A printer attached to a different UNIX or Linux system
that can be accessed over a TCP/IP network (for example, a printer attached
to another Linux system on your network).

• SMB shared printer (Windows): A printer attached to a different system that
is sharing the printer over a SMB network (for example, a printer attached
to a Microsoft Windows machine).

• Network Printer (TCP): A printer connected to the network using the TCP
protocol.

• Remote CUPS server (IPP/HTTP): A printer attached to a different Linux
system on the same network running CUPS or a printer configured on another
operating system using IPP.

• Network printer w/IPP (IPP/HTTP) : A printer connected to the network
using the IPP/HTTP protocol.

• Other printer type: If your printer does not fit one of the classes above, choose
this option.

• Class of printers: To find printers by a specific class, choose this option.

5 Click Next and enter the information required for your choice. In the last wizard
dialog, click Finish. The wizard closes.

6 Click OK to close the Printing Manager dialog.

When printing from an application in KDE, you can now select the printer in the
KPrinter dialog and start a print job. For more information about sending and monitoring
print jobs in KDE, refer to Section 12.4, “Starting Print Jobs in KDE” (page 202).

12.2 Modifying Printer Settings
1 Start the Printer Manager from the main menu (Utilities → Printing → Printing

Manager).

2 Click Administrator Mode and enter your root password.
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3 In the display field showing the list of available printers, select the printer to
modify.

4 Right-click and select Configure.

5 Modify the properties in the configuration dialog then click OK.

12.3 Deleting a Printer
1 Start the Printer Manager from the main menu (Utilities → Printing → Printing

Manager).

2 Click Administrator Mode and enter your root password.

3 In the display field showing the list of available printers, select the printer to
delete.

4 Right-click and select Remove.

5 Click OK to close the Printing Manager dialog.

12.4 Starting Print Jobs in KDE
In KDE, you usually start print jobs with KPrinter. This application is started automat-
ically each time you print from a KDE application. In the KPrinter dialog, choose a
printer and edit the Properties of your print job, such as page orientation, pages per
sheet, and duplex printing.

TIP: Sending Files to a Printer without Opening the Application

You can also start KPrinter manually by pressing Alt + F2 and entering
kprinter. This is useful if you want to print one or several files without
starting the application to view or edit the file. The KPrinter dialog then addi-
tionally includes the Files tab, where you can determine the files to print. Either
drag them from the desktop and drop them into the list or use the file dialog
to locate them.
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To specify the number of copies and various other options, click Expand at the bottom
left. The window then expands and shows three tabs: Copies, Advanced Options, and
Additional Tags. See Figure 12.2, “Starting a Print Job with KPrinter” (page 203).

Figure 12.2 Starting a Print Job with KPrinter

The Copies tab determines the page selection (all pages of the selected document, the
currently selected one, or a range) and the number of copies. You may also choose to
print only the even or only the odd numbered pages of the selected document. Use Ad-
vanced Options to specify any additional information for the print job. Enter any Billing
information if needed or set a custom page label at the top and bottom of the page. The
Job Priority can also be set here. The last tab, Additional Tags is rarely needed. Once
your print job has been filed, you can watch its progress using KJobViewer.
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12.5 Monitoring Print Jobs in KDE
Start KJobViewer from the main menu or with kjobviewer from the command line.
A window like that in Figure 12.3, “Monitoring Print Jobs with KJobViewer” (page 204)
opens, listing all the print jobs queued on your printer. As long as your print job is not
active, you can edit it. Do this using the entries of the Jobs menu.

Figure 12.3 Monitoring Print Jobs with KJobViewer

If, for example, you want to check if you sent the correct document to the printer, you
can stop the job and resume it if you decide to print it. Remove your own print jobs
from the queue with Remove. To change the printer, select a different printer with Move
to Printer.

With Restart, reprint a document. To do this, select Filter → Toggle Completed Jobs,
select the desired document, and click Jobs→ Restart. Clicking Jobs→ Job IPP Report
shows the technical details of a job. Use Jobs→ Increase Priority and Jobs→Decrease
Priority to set the priority, depending on how quickly you need the document.

Filter enables you to switch between various printers, toggle completed jobs, and limit
the view to your own print jobs by selecting Show Only User Jobs. The current user is
then displayed in the top right field.

Settings → Configure KJobViewer opens a configuration dialog. Here, determine the
maximum number of print jobs to display. Enter a number in the field or use the slider
to the right to determine a value. Press OK to save the setting or Cancel to exit the dialog
without saving.
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The icons in the toolbar correspond to the functions you can access by way of the menu.
Display a help text explaining the function by holding the mouse pointer over one of
the icons.

The job list consists of eight columns. The job ID is automatically assigned by the print
system to identify the various jobs. The next column contains the login of the user who
sent the job followed by the filename of the document. The status column indicates
whether a job is still in the queue, currently being printed, or already completed. Next,
the size of the document is displayed in kilobytes and number of pages. The default
priority of 50 can be increased or reduced if necessary. Billing information can be cost
centers or other company-specific information. If you right-click a job in the list, the
Jobs menu opens under the mouse pointer, allowing you to select an action. Only a few
functions are available for completed jobs. If you activate Keep window permanent,
KJobViewer opens automatically the next time you log in.
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Part III. Internet





13Browsing with Konqueror
Konqueror is not only a versatile file manager. It is also a modern Web browser. If you
start the browser with the icon in the panel, Konqueror opens with the Web browser
profile. As a browser, Konqueror offers tabbed browsing, the possibility of saving Web
pages with graphics, Internet keywords, bookmarks, and support for Java and JavaScript.

Figure 13.1 The Browser Window of Konqueror
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Start Konqueror from the main menu or by entering the command konqueror. To
load a Web page, enter its address in the location bar, for example, http://www
.suse.com. Konqueror now tries to reach the address and display the page. Entering
the protocol at the beginning of the address (http:// in this case) is not strictly re-
quired. The program is able to complete the address automatically, but this only works
reliably with Web addresses. For an FTP address, always enter ftp:// at the beginning
of the input field.

13.1 Tabbed Browsing
If you often use more than one Web page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window. The ad-
vantage is that you keep more control over your desktop because you only have one
main window. After logout, the KDE session management allows for saving your Web
session in Konqueror. The next time you log in, Konqueror loads the exact URLs visited
last time.

To open a new tab, select Window → New Tab or press Ctrl + Shift + N . To change
the behavior of tabs, go to Settings → Configure Konqueror. In the dialog box that
opens, selectWeb Behavior→ Tabbed Browsing. To open new tabs instead of windows,
enable Open links in new tab instead of in new window. You can also hide the tab bar
with Hide the tab bar when only one tab is open. To see more options, press Advanced
Options.

13.2 Automatic Scrolling
In general, scrolling with the mouse is the normal way to view information farther down
a Web page. However, there are sometimes occasions when it is preferable not to use
a mouse. It can be very convenient to use key combinations instead of removing hands
from the keyboard.

To scroll down automatically, use Shift + ↓ . This scrolls down the page without further
intervention. Increase the speed by pressing Shift + ↓ again. Pressing Shift + ↑ slows
down. To stop scrolling, use ↓ .

210 KDE User Guide

http://www.suse.com
http://www.suse.com


13.3 Profiles
Section 13.1, “Tabbed Browsing” (page 210) described how to handle tabs in Konqueror.
You can save your tabs with URLs and the position of the window in a profile. This
differs from the session management already mentioned. With profiles, your saved tabs
are at hand without the intensive start-up time of session management.

To create a profile, do the following:

1 Go to Settings → Configure View Profiles.

2 In the dialog box that appears, insert a name in Profile name.

3 To save your URLs, select Save URLs in profile.

4 To freeze the position and size of the windows, select Save window size in profile.

5 Approve with Save.

The next time you need your tab collection, go to Settings → Load View Profile and
find the name listed in the menu. After you select it, Konqueror restores your tabs.

13.4 Saving Web Pages and Graphics
As in other browsers, you can save Web pages. To do this, select Location → Save as
and specify a name for your HTML file. However, images are not saved. To archive
an entire Web page including the images, select Tools → Archive Web Page. Konqueror
suggests a filename that you can usually accept. The filename ends with .war, the
extension for Web archives. To view the saved Web archive later, simply click the re-
spective file and the Web page is displayed in Konqueror along with its images.

13.5 Searching with Konqueror
Searching with Konqueror is very convenient. You can use the search bar or Web
shortcuts.
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13.5.1 Using the Search Bar
Konqueror contains a search bar where you can choose from many search engines. If
you want to search for a specific term, proceed as follows:

1 Start Konqueror.

2 Locate the search bar. It is on the right side after the location bar.

3 Click the icon inside the search bar. Choose a search engine from the pop-up
menu.

4 Insert your search term and press Enter . The result is displayed in Konqueror.

If you need a search engine that is not listed in the pop-up menu, add it as follows:

Procedure 13.1 Adding More Search Engines

1 Start Konqueror.

2 Click the icon in the search bar.

3 Choose Select Search Engines.

4 Make sure that Enable Web shortcuts is activated.

5 Enable the respective search engine and close the dialog with Ok. You can see
your selected search engine if you click the icon in the search bar.

13.5.2 Using Web Shortcuts
Each search engine defined is attached to a web shortcut. This shortcut can be entered
in the location bar.

To see which are already defined, go to Settings → Configure Konqueror → Web
Shortcuts. You can see the names of the search providers and the shortcuts. Konqueror
defines many search engines: Google, Yahoo, and Lycos, and a number of less common
resources, like an acronym database, the Internet movie database, and KDE application
searches.
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If you do not find your preferred search engine here, easily define a new one. For ex-
ample, to search our support database for some interesting articles, normally go to
http://portal.suse.com/, find the search page, and enter your query. This
can be simplified

Procedure 13.2 Creating New Web Shortcuts

1 Go to the search bar, click the icon, and select Select Search Engines.

2 Make sure that Enable Web Shortcuts is activated.

3 Click New.

4 Create a new Web shortcut:

a Assign your Web shortcut a name in Search provider name.

b Enter the search URI. Pressing Shift + F1 and clicking in the field opens a
small help. The search query is specified as \{@}. The challenge is inserting
this at the correct position. For example, if you want to search in the SUSE
Support Database, use https://portal.suse.com/PM/page/
search.pm?q=\{@}&t=optionSdbKeywords&m=25&l=en&x=
true.

c Enter your abbreviations in URI shortcuts. There can more than one, sepa-
rated by commas.

5 Proceed with Ok.

TIP: Using Shortcuts Directly without Opening Konqueror

You do not need to open Konqueror and enter the Web shortcut. It is also
possible to call it directly. Select Run command from the main menu or press
Alt + F2 . After the dialog box appears, enter your shortcut with the search
term.

After creating a new Web shortcut, for example, sdb_en, you can use this in the loca-
tion bar. The result is displayed in the current window.
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13.6 Bookmarks
Instead of remembering and reentering addresses for sites visited often, you can book-
mark these URLs using the Bookmark menu. As well as Web page addresses, you can
also bookmark any directories of your local disk in this way.

To create a new bookmark in Konqueror, click Bookmarks → Add Bookmark. Any
bookmarks added previously are included as items in the menu. It is a good idea to ar-
range the bookmark collection by subjects in a hierarchical structure, so that you do
not lose track of the different items. Create a new subgroup for your bookmarks with
New Bookmark Folder. Selecting Bookmarks → Edit Bookmarks opens the bookmark
editor. Use this program to organize, rearrange, add, and delete bookmarks.

If you are using Netscape, Mozilla, or Firefox as additional browsers, it is not necessary
to recreate your bookmarks. File → Import → Import Netscape Bookmarks in the
bookmark editor enables you to integrate your Netscape and Mozilla bookmarks into
your most current collection. The reverse is also possible via Export as Netscape
Bookmarks.

Change your bookmarks by right-clicking the entry. A pop-up menu appears in which
to select the desired action (cut, copy, delete, etc.). When you are satisfied with the result,
save the bookmarks with File → Save. If you only want to change the name or link,
just right-click the entry in the bookmark toolbar and select Properties. Change the
name and location and confirm with Update.

To save your bookmark list and have instant access to it, make your bookmarks visible
in Konqueror. Select Settings → Toolbars → Bookmark Toolbar (Konqueror). A
bookmark panel is automatically displayed in the current Konqueror window.

13.7 Java and JavaScript
Do not confuse these two languages. Java is an object-oriented, platform-independent
programming language from Sun Microsystems. It is frequently used for small programs
(applets), which are executed over the Internet for things like online banking, chatting,
and shopping. JavaScript is an interpreted scripting language mainly used for the dy-
namic structuring of Web pages, for example, for menus and other effects.
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Konqueror allows you to enable or disable these two languages. This can even be done
in a domain-specific way, which means that you can permit access for some hosts and
block access for others. Java and JavaScript are often disabled for security reasons.
Unfortunately, some Web pages require JavaScript for correct display.

13.8 Enabling Advertisment Blockers
Some Web pages open annoying advertisments. With the help of Konqueror, these
windows can be blocked. Proceed as follows:

Procedure 13.3 Blocking Annoying Advertisments

1 Start Konqueror.

2 Go to Settings → Configure Konqueror → AdBlock Filter.

3 Activate Enable filters.

4 Click Insert.

5 Enter an expression for the Web page to filter. For example:
http://www.example.com/*

This filters everything that comes from that URL.

13.9 For More Information
For any questions or problems that arise when working with Konqueror, refer to the
application's handbook, which is available from the Help menu. Konqueror also has a
Web page, located at http://www.konqueror.org.
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14Browsing with Firefox
Included with your SUSE® Linux Enterprise Desktop is the Mozilla Firefox Web
browser. With features like tabs, pop-up window blocking, and download and image
management, Firefox combines the latest Web technologies. You can view more than
one Web page in a single window. You can suppress annoying advertisements and
disable images that only slow you down. Its easy access to different search engines
helps you find the information you need. Start the program from the main menu or by
entering the command firefox. The main program features are described in the fol-
lowing sections.

14.1 Navigating Web Sites
Firefox has much the same look and feel as other browsers. It is shown in Figure 14.1,
“The Browser Window of Firefox” (page 218). The navigation toolbar includesForward
and Back and a location bar for a Web address. Bookmarks are also available for quick
access. For more information about the various Firefox features, use the Help menu.
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Figure 14.1 The Browser Window of Firefox

14.1.1 Tabbed Browsing
If you often use more than one Web page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window.

To open a new tab, select File → New Tab. This opens an empty tab in the Firefox
window. Alternatively, right-click a link and select Open link in new tab. Right-click
the tab itself to access more tab options. You can create a new tab, reload one or all
existing tabs, or close them. You can also change the sequence of the tabs by dragging
and dropping them on a requested position.
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14.1.2 Using the Sidebar
Use the left side of your browser window for viewing bookmarks or the browsing his-
tory. Extensions may add new ways to use the sidebar as well. To display the Sidebar,
select View → Sidebar and select the desired contents.

14.2 Finding Information
There are two ways to find information in Firefox: the search bar and the find bar. The
search bar looks for pages while the find bar looks for things on the current page.

14.2.1 Finding Information on the Web
Firefox has a search bar that can access different engines, like Google, Yahoo, or
Amazon. For example, if you want to find information about SUSE using the current
engine, click in the search bar, type SUSE, and hit Enter . The results appear in your
window. To choose your search engine, click the icon in the search bar. A menu opens
with a list of available search engines.

14.2.2 Installing a Different Search Engine
If you favorite search engine is not listed, Firefox gives you the possibility to configure
it. Try the following steps:

1 Establish an Internet connection first.

2 Click in the search bar on the icon.

3 Select Add Engines from the menu.

4 Firefox displays a Web page with available search engines. It is also sorted by
categories. You can choose from Wikipdedia, Leo, and others. Click the desired
search plug-in.

5 Install your search plug-in with Ok or abort with Cancel.
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14.2.3 Searching in the Current Page
To search inside a Web page, click Edit → Find in This Page or press Ctrl + F . The
find bar opens. Usually, it is displayed at the bottom of a window. Type your query in
the input field. Firefox finds the first occurence of this phrase. You can find other oc-
curences of the phrase by pressing F3 or Find Next button in the find bar. You can also
highlight all occurences by pressing the Highlight all button.

14.3 Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite Web sites. To add
the current Web site to your list of bookmarks, click Bookmarks → Bookmark This
Page. If your browser currently displays multiple Web sites on tabs, only the URL on
the currently selected tab is added to your list of bookmarks.

When adding a bookmark, you can specify an alternative name for the bookmark and
select a folder where Firefox should store it. To bookmark Web sites on multiple tabs,
select Bookmark All Tabs. Firefox creates a new folder that includes bookmarks of each
site displayed on each tab. To remove a Web site from the bookmarks list, click Book-
marks, right-click the bookmark in the list, then click Delete.

14.3.1 Using the Bookmark Manager
The bookmark manager can be used to manage the properties (name and address loca-
tion) for each bookmark and organize the bookmarks into folders and sections. It resem-
bles Figure 14.2, “Using the Firefox Bookmark Manager” (page 221).
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Figure 14.2 Using the Firefox Bookmark Manager

To open the bookmark manager, click Bookmark → Manage Bookmarks. A window
opens and displays your bookmarks. With New Folder, create a new folder with a name
and a description. If you need a new bookmark, click New Bookmark. This lets you
insert the name, location, keywords, and also a description. The keyword is a shortcut
to your bookmark. If you need your newly created bookmark in the sidebar, check Load
this bookmark in the sidebar.

14.3.2 Importing Bookmarks from Other
Browsers

If you used a different browser in the past, you probably want to use your preferences
and bookmarks in Firefox, too. At the moment, you can import from Netscape 4.x, 6,
7, Mozilla 1.x, and Opera.

To import your settings, click File → Import. Select the browser from which to import
settings. After you clickNext, your settings are imported. Find your imported bookmarks
in a newly created folder, beginning with From.
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14.3.3 Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date
with the latest news. This enables you to save time with one glance at your favorite
sites.

Many sites and blogs support this format. A Web site indicates this by showing an orange
icon in the right part of the location bar. Click it and choose Add NAMEOF THE FEED
as Live Bookmark. A dialog box opens where you can select the name and location of
your live bookmark. Confirm with Add.

Some sites do not tell Firefox that they support a news feed, although they actually do.
To add a live bookmark manually, you need the URL of the feed. Do the following:

Procedure 14.1 Adding a Live Bookmark Manually

1 Open the bookmark manager with Bookmarks → Manage Bookmarks. A new
window opens.

2 Select File → New Live Bookmark. A dialog box opens.

3 Insert a name for the live bookmark and add your URL, for example, http://
www.novell.com/newsfeeds/rss/coolsolutions.xml. Firefox
updates your live bookmarks.

4 Close your bookmark manager.

14.4 Using the Download Manager
With the help of the download manager, keep track of your current and past downloads.
To open the download manager, click Tools → Downloads. Firefox opens a window
with your downloads. While downloading a file, see a progress bar and the current file.
If necessary, pause a download and resume it later. To open a downloaded file, click
Open. With Remove, remove it from the list. If you need information about the file,
right-click the filename and choose Properties.

222 KDE User Guide

http://www.novell.com/newsfeeds/rss/coolsolutions.xml
http://www.novell.com/newsfeeds/rss/coolsolutions.xml


If you need further control of the download manager, open the configuration window
from Edit → Preferences and go to the Downloads tab. Here, determine the download
folder, how the manager behaves, and some configuration of file types.

14.5 Customizing Firefox
Firefox can be customized extensively. You can install extensions, change themes, and
add smart keywords for your online searches.

14.5.1 Extensions
Mozilla Firefox is a multifunctional application, which means that you can download
and install add-ons, known as extensions. For example, add a new download manager
and mouse gestures. This has the advantage that Firefox itself stays small and unbloated.

To add an extension, click Tools → Extensions. In the bottom-right corner, click Get
More Extensions to open the Mozilla extensions update Web page where you can choose
from a variety of available extensions. Click the extension to install then click the install
link to download and install it. When you restart Firefox, the new extension is functional.
You can also look at the various extensions at http://addons.mozilla.org/
.

Figure 14.3 Installing Firefox Extensions
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14.5.2 Changing Themes
If you do not like the standard look and feel of Firefox, install a new theme. Themes
do not change the functionality, only the appearance of the browser. When installing a
theme, Firefox asks for confirmation first. Allow the installation or cancel it. After a
successful installation, you can enable the new theme.

1 Click Tools → Themes.

2 In the new dialog that appears, click Get More Themes. If you already installed
a theme, find it in the list, as in Figure 14.4, “Installing Firefox Themes”
(page 224).

Figure 14.4 Installing Firefox Themes

3 A new window appears with the Web sitehttps://addons.mozilla.org.

4 Choose a theme and click Install Now.

5 Confirm the download and installation.

6 After downloading the theme, a dialog appears and informs you about your list
of themes. Activate the new theme with Use Theme.

7 Close the window and restart Firefox.
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If a theme is installed, you can always switch to a different theme without restarting
by clicking Tools → Themes then Use Theme. If you do not use a theme anymore, you
can delete it in the same dialog with Uninstall.

14.5.3 Adding Smart Keywords to Your
Online Searches

Searching the Internet is one of the main tasks a browser can perform for you. Firefox
lets you define your own smart keywords: abbreviations to use as a “command” for
searching the Web. For example, if you use Wikipedia often, use a smart keyword to
simplify this task:

1 Go to http://en.wikipedia.org.

2 After Firefox displays the Web page, see the search text field. Right-click it then
choose Add a Keyword for this Search from the menu that opens.

3 The Add Bookmark dialog appears. In Name, name this Web page, for example,
Wikipedia (en).

4 For Keyword, enter your abbreviation of this Web page, for example, wiki.

5 With Create in, choose the location of the entry in your bookmarks section. You
can put it into Quick Searches, but any other level is also appropriate.

6 Finalize with Add.

You have successfully generated a new keyword. Whenever you need to look into
Wikipedia, you do not have to use the entire URL. Just type wiki Linux to view an
entry about Linux.

14.6 Printing from Firefox
Configure the way Firefox prints the content it displays using the Page Setup dialog.
Click File → Page Setup then go to the Format & Options tab to select the orientation
of your print jobs. You can scale or make it adjust automatically. To print a background,
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select Print Background (colors & images). Click the Margins & Header/Footer tab
to adjust margins and select what to include in the headers and footers.

After you configured your settings, print a Web page with File → Print. Select the
printer or a file in which to save the output. With Properties, set the paper size, specify
the print command, choose grayscale or color, and determine the margins. When satisfied
with your settings, approve with Print.

14.7 For More Information
Get more information about Firefox from the official home page at http://www
.mozilla.com/firefox/. Refer to the integrated help to find out more about
certain options or features.
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15Transferring Data from the
Internet
KGet is the download manager for KDE. It manages your transfers in a window. You
can stop, resume, delete, queue, and add transfers. Start KGet from the main menu or
by pressing Alt + F2 then entering kget.

When KGet is started for the first time, you can choose to have it integrated with Kon-
queror. If you integrate KGet with Konqueror, KGet is added to the system tray as an
icon with a downward arrow. Click this arrow to view KGet transfers.

Figure 15.1 KGet

15.1 Adding Transfers to the List
To add a transfer, click File → Paste. Specify a URL then click OK. Finally, select
where to save the downloaded file. The entry for the transfer is added to the main window
of KGet and the download starts. Another way to add a transfer is to simply drag a file
(for example, from an FTP server) from Konqueror and drop it in the main KGet window.
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Modify the preferences for your downloads by clicking Settings → Configure KGet.

15.2 Timer-Controller Transfers
You can configure KGet to perform transfers at a specific time.

1 Start KGet.

2 Click Options → Offline Mode. All transfers inserted from this point are not
started immediately but are queued.

3 To start the clock, double-click the entry then click Advanced.

4 Enter the day, month, year, and time to start the transfer, click the Timer icon,
then close the dialog.

5 After making the desired settings for all your transfers, click Options → Offline
Mode to set KGet back in online mode.

The transfers should start at the specified times.
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16Reading News Feeds with
Akregator
If you want to get the latest news, get your information with a news feed reader. One
reader is Akregator. It connects to a server that contains a newsticker file and downloads
it then shows the headlines and sometimes a small text to give an overview. See Fig-
ure 16.1, “Akregator Showing Some News” (page 229). If interested in this news, click
it and view it in a separate tab.

Figure 16.1 Akregator Showing Some News

Akregator contains some predefined news feeds for KDE. You can add news feeds
manually or some Web sites announce it. For example, a Web site with feed support
contains an orange rectangle in the bottom right corner. Click it to open a pop-up menu
where you can select Add Feed to Akregator. Sometimes a Web site does not announce
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that it supports a news feed. Then you can search this site with some keywords like
feed or rss. Sometimes you are successful and can obtain a link.

To add a news feed, do the following:

Procedure 16.1 Adding a News Feed to Akregator

1 Determine the URL of your news feed. Normally this can be found on your pre-
ferred Web site. More links can be found in the KNewsticker tool, an applet for
the KDE panel.

2 Open Akregator by pressing Alt + F2 and entering akregator. It opens a new
window with the list of all feeds in your configuration. If you close this window,
it docks in the system tray.

3 Create a new folder with Feed → New Folder. This gives you the opportunity
to group your feeds in categories.

4 Name your new folder.

5 Click this folder and choose Feed → Add Feed.

6 Insert the feed URL, for example,http://www.novell.com/newsfeeds/
rss/coolsolutions.xml. A new window opens where you can change
the feed name, URL, or the update interval. With the Feed Archive tab, change
how long articles should be stored.

7 Proceed with Ok. Akregator downloads the latest articles.

After the download of the latest headers is finished, you can click an entry. Depending
on the feed, this can list a small summary or just a link. With Complete Story, read the
entire article.

Check for new news manually with Fetch Feed. Another option is to specify an update
interval. Configure this by clicking Settings → Configure Akregator. A window opens
where you can select the interval in General → Use interval fetching. Confirm with
Ok.

You can read the complete story in Akregator or an external browser. ClickingComplete
Story lets you select which.
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Part IV. Multimedia





17Manipulating Graphics with
The GIMP
The GIMP (The GNU Image Manipulation Program) is a program for creating and
editing pixel graphics. In most aspects, its features are comparable to those of Adobe
Photoshop and other commercial programs. Use it to resize and retouch photographs,
design graphics for Web pages, make covers for your custom CDs, or almost any other
graphics project. It meets the needs of both amateurs and professionals.

Like many other Linux programs, The GIMP is developed as a cooperative effort of
developers worldwide who volunteer their time and code to the project. The program
is under constant development, so the version included in your system may vary
slightly from the version discussed here. The layout of the individual windows and
window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and
menu items are discussed in this chapter. See Section 17.6, “For More Information”
(page 240) for ideas of where to find more information about the program.

17.1 Graphics Formats
There are two main formats for graphics—pixel and vector. The GIMP works only with
pixel graphics, which is the normal format for photographs and scanned images. Pixel
graphics consist of small blocks of color that together create the entire image. The files
can easily become quite large because of this. It is also not possible to increase the size
of a pixel image without losing quality.
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Unlike pixel graphics, vector graphics do not store information for all individual pixels.
Instead, they store information about how image points, lines, or areas are grouped to-
gether. Vector images can also be scaled very easily. The drawing application of
OpenOffice.org, for example, uses this format.

17.2 Starting GIMP
Start GIMP from the main menu. Alternatively, enter gimp & in a command line.

17.2.1 Initial Configuration
When starting GIMP for the first time, a configuration wizard opens for preparatory
configuration. The default settings are acceptable for most purposes. Press Continue in
each dialog unless you are familiar with the settings and prefer another setup.

17.2.2 The Default Windows
Three windows appear by default. They can be arranged on the screen and, except the
toolbox, closed if no longer needed. Closing the toolbox closes the application. In the
default configuration, GIMP saves your window layout when you exit. Dialogs left
open reappear when you next start the program.

The Toolbox
The main window of GIMP, shown in Figure 17.1, “The Main Window” (page 234),
contains the main controls of the application. Closing it exits the application. At the
very top, the menu bar offers access to file functions, extensions, and help. Below that,
find icons for the various tools. Hover the mouse over an icon to display information
about it.

Figure 17.1 The Main Window
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The current foreground and background color are shown in two overlapping boxes. The
default colors are black for the foreground and white for the background. Click the box
to open a color selection dialog. Swap the foreground and background color with the
bent arrow symbol to the upper right of the boxes. Use the black and white symbol to
the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one
to access the selection dialog. The lower portion of the window allows configuration
of various options for the current tool.

Layers, Channels, Paths, Undo
In the first section, use the drop-down box to select the image to which the tabs refer.
By clicking Auto, control whether the active image is chosen automatically. By default,
Auto is enabled.

Layers shows the different layers in the current images and can be used to manipulate
the layers. Channels shows and can manipulate the color channels of the image.

Paths are a vector-based method of selecting parts of an image. They can also be used
for drawing. Paths shows the paths available for an image and provides access to path
functions. Undo shows a limited history of modifications made to the current image.

17.3 Getting Started in GIMP
Although GIMP can be a bit overwhelming for new users, most quickly find it easy to
use once they work out a few basics. Crucial basic functions are creating, opening, and
saving images.

17.3.1 Creating a New Image
To create a new image, select File → New or press Ctrl + N . This opens a dialog in
which to make settings for the new image. If desired, select a predefined setting called
a Template. To create a custom template, select File → Dialogs → Templates and use
the controls offered by the window that opens.
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In the Image Size section, set the size of the image to create in pixels or another unit.
Click the unit to select another unit from the list of available units. The ratio between
pixels and a unit is set inResolution, which appears when theAdvanced Options section
is open. A resolution of 72 pixels per inch corresponds to screen display. It is sufficient
for Web page graphics. A higher resolution should be used for images to print. For
most printers, a resolution of 300 pixels per inch results in an acceptable quality.

In Colorspace, select whether the image should be in color (RGB) or Grayscale. Select
the Fill Type for the new image. Foreground Color and Background Color use the
colors selected in the toolbox. White uses a white background in the image. Transparent
creates a clear image. Transparency is represented by a gray checkerboard pattern. Enter
a comment for the new image in Comment.

When the settings meet your needs, press OK. To restore the default settings, press
Reset. Pressing Cancel aborts creation of a new image.

17.3.2 Opening an Existing Image
To open an existing image, select File → Open or press Ctrl + O . In the dialog that
opens, select the desired file. You can also press Ctrl + L and type directly the URI of
the desired image. Then click OK to open the selected image or press Cancel to skip
opening an image.

17.3.3 Scanning an Image
Instead of opening an existing image or creating a new one, you can scan one. To scan
directly from the GIMP, make sure that the package xsane is installed. To open the
scanning dialog, select File → Acquire → XSane: scanning device.

Create a preview when the object to scan is smaller than the total scanning area. Press
Acquire preview in the Preview dialog to create a preview. If you want to scan only
part of the area, select the desired rectangular part with the mouse.

In the xsane dialog, select whether to scan a grayscale or color image and the required
scan resolution. The higher the resolution, the better the quality of the scanned image
is. However, this also results in a correspondingly larger file and the scanning process
can take a very long time at higher resolutions. The size of the final image (both in
pixels and bytes) is shown in the lower part of the dialog.
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In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values.
Changes are visible in the preview immediately. Once all settings have been made,
click Scan to scan the image.

17.3.4 The Image Window
The new, opened, or scanned image appears in its own window. The menu bar in the
top of the window provides access to all image functions. Alternatively, access the
menu by right-clicking the image or clicking the small arrow button in the left corner
of the rulers.

File offers the standard file options, such as Save and Print. Close closes the current
image. Quit closes the entire application.

With the items in the Viewmenu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one
view are reflected in all other views of that image. Alternate views are useful for mag-
nifying a part of an image for manipulation while seeing the complete image in another
view. Adjust the magnification level of the current window with Zoom. When Shrink
Wrap is selected, the image window is resized to fit the current image display exactly.

17.4 Saving Images
No image function is as important as File → Save. It is better to save too often than too
rarely. Use File → Save as to save the image with a new filename. It is a good idea to
save image stages under different names or make backups in another directory so you
can easily restore a previous state.

When saving for the first time or using Save as, a dialog opens in which to specify the
filename and type. Enter the filename in the field at the top. For Save in folder, select
the directory in which to save the file from a list of commonly used directories. To use
a different directory or create a new one, open Browse for other folders. It is recom-
mended to leave Select File Type set toBy Extension. With that setting, GIMP determines
the file type based on the extension appended to the filename. The following file types
are frequently useful:
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XCF
This is the native format of the application. It saves all layer and path information
along with the image itself. Even if you need an image in another format, it is
usually a good idea to save a copy as XCF to simplify future modifications.

PAT
This is the format used for GIMP patterns. Saving an image in this format enables
using the image as a fill pattern in GIMP.

JPG
JPG or JPEG is a common format for photographs and Web page graphics without
transparency. Its compression method enables reduction of file sizes, but information
is lost when compressing. It may be a good idea to use the preview option when
adjusting the compression level. Levels of 85% to 75% often result in an acceptable
image quality with reasonable compression. Saving a backup in a lossless format,
like XCF, is also recommended. If editing an image, save only the finished image
as JPG. Repeatedly loading a JPG then saving can quickly result in poor image
quality.

GIF
Although very popular in the past for graphics with transparency, GIF is less often
used now because of license issues. GIF is also used for animated images. The
format can only save indexed images. The file size can often be quite small if only
a few colors are used.

PNG
With its support for transparency, lossless compression, free availability, and in-
creasing browser support, PNG is replacing GIF as the preferred format for Web
graphics with transparency. An added advantage is that PNG offers partial trans-
parency, which is not offered by GIF. This enables smoother transitions from colored
areas to transparent areas (antialiasing).

To save the image in the chosen format, press Save. To abort, press Cancel. If the image
has features that cannot be saved in the chosen format, a dialog appears with choices
for resolving the situation. Choosing Export, if offered, normally gives the desired re-
sults. A window then opens with the options of the format. Reasonable default values
are provided.
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17.5 Printing Images
To print an image, selectFile→ Print from the image menu. If your printer is configured
in the system, it should appear in the list. In some cases, it may be necessary to select
an appropriate driver with Setup Printer. Select the appropriate paper size with Media
Size and the type in Media Type. Other settings are available in the Image / Output
Settings tab.

Figure 17.2 The Print Dialog

In the bottom portion of the window, adjust the image size. Press Use Original Image
Size to take these settings from the image itself. This is recommended if you set an ap-
propriate print size and resolution in the image. Adjust the image's position on the page
with the fields in Position or by dragging the image in Preview.

When satisfied with the settings, press Print. To save the settings for future use, instead
use Print and Save Settings. Cancel aborts printing.
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17.6 For More Information
The following resources are useful for a GIMP user, even if some of them apply to
older versions.

• Help provides access to the internal help system. This documentation is also
available in HTML and PDF formats at http://docs.gimp.org.

• The GIMP User Group offers an informative Web site athttp://gug.sunsite
.dk.

• http://www.gimp.org is the official home page of The GIMP.

• Grokking the GIMP by Carey Bunks is an excellent book based on an older GIMP
version. Although some aspects of the program have changed, it can provide excel-
lent guidance for image manipulation. An online version is available at http://
gimp-savvy.com/BOOK/.
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18Using Digital Cameras with
Linux
Managing photos from your camera can be fun if you have the right tools. Linux offers
several handy utilities for sorting and organizing your photographs. These include
gphoto2, Konqueror, Digikam, and f-spot.

A comprehensive list of supported cameras is available at http://www.gphoto
.org/proj/libgphoto2/support.php. If gphoto2 is installed, retrieve the
list with the command gphoto2 --list-cameras. Get information about the
available commands with gphoto2 --help.

TIP: Unsupported Cameras

If you do not find your camera in the list from gphoto, do not despair. It is
very likely that your camera is supported as a USB mass storage device. Find
more information in Section 18.2, “Accessing the Camera” (page 242).

18.1 Connecting to the Camera
The fastest and most convenient way to connect digital cameras to the computer is USB,
provided the kernel, the camera, and the computer support it. The standard SUSE kernel
provides this support. A suitable cable is also required.

Simply connect the camera to the USB port and turn on the camera. You may need to
switch your camera to a special data transfer mode. For this procedure, consult the
manual of your digital camera.
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18.2 Accessing the Camera
There are three possibilities for accessing the pictures on the camera. It depends on
your camera and which protocol it supports. Usually it is USB mass storage, which is
handled by the hotplug system, or PTP (also known as PictBridge). Some camera
models do not work with either protocol. To support these, gphoto2 includes specific
drivers.

It is easiest if your camera supports USB mass storage. Read the documentation of your
camera if you are unsure if this is possible. Some support two protocols, like both PTP
and USB mass storage. Unfortunately, there are also some that communicate with a
proprietary protocol, which can complicate the tasks. If your camera does not support
USB mass storage or PTP, the following descriptions will not work. Try gphoto2
--list-cameras and the information at http://www.gphoto.org/.

If your camera can be switched to a USB mass storage device, select this option. After
you connect it with the USB port of your computer and turn it on, it is detected by the
hotplug system. This takes care of mounting the device automatically, so it is easily
accessible. The KDE desktop shows a camera icon after a successful mount.

After the camera is successfully mounted, see a new directory under /media, beginning
with usb and lots of numbers. Each vendor and product has a number, so when you
connect a device on your computer it has always the same name. Depending on what
you have connected to the USB bus, find different entries. The only problem left is to
find the correct entry for your camera. Try to list one of these directories (DCIM/xxx)
and see what happens. Each camera has a different tree structure, so there is no general
rule. If you can see JPEG files in a directory, you probably found it.

After you find your correct directory, you can copy, move, or delete the files from your
camera with a file manager, such as Konqueror, or simple shell commands (see Sec-
tion 14.3, “Important Linux Commands” (Chapter 14, Working with the Shell, ↑Deploy-
ment Guide) and Section 1.4, “Managing Folders and Files with Konqueror” (page 29)).

18.3 Using Digikam
Digikam is a KDE program for downloading photographs from digital cameras. The
first time it is run, Digikam asks where to store your photo album. If you enter a direc-
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tory that already contains a collection of photographs, Digikam treats each subfolder
as an album.

On start-up, Digikam presents a window with two sections: your albums are displayed
to the left and the photographs of the current album are displayed to the right. See Fig-
ure 18.1, “The Main Window of Digikam” (page 243).

Figure 18.1 The Main Window of Digikam

18.3.1 Configuring Your Camera
To set up a camera in Digikam, select Camera → Add Camera. First, try to autodetect
the camera with Auto-Detect. If this fails, browse the list for your model with Add. If
your camera model is not included in the list, try an older model or use USB/IEEEmass
storage camera. Confirm with Ok.

18.3.2 Downloading Pictures from Your
Camera

After your camera has been configured correctly, connect to your camera with the
Camera menu and the name that you gave in the dialog from Section 18.3.1, “Config-
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uring Your Camera” (page 243). Digikam opens a window and begins to download
thumbnails and displays them as in Figure 18.2, “Downloading Pictures from Camera”
(page 244). Right-click an image to open a pop-up menu with the options toView, display
some Properties or EXIF Information,Download, orDelete the image. With Advanced,
select renaming options and how the camera-provided information (EXIF) should be
handled.

Figure 18.2 Downloading Pictures from Camera

The renaming options can be very convenient if your camera does not use meaningful
filenames. You can let Digikam rename your photographs automatically. Give a unique
prefix and, optionally, a date, time, or sequence number. The rest is done by Digikam.

Select all photographs to download from the camera by pressing the left mouse button
or clicking individual photographs with Ctrl pressed. Selected photographs appear with
inverted colors. Click Download. Select the destination from the list or by creating a
new album with New Album. This automatically suggests a filename with the current
date. Confirm with Ok to start the download process.

18.3.3 Getting Information
Getting information about the photograph is not difficult. A short summary is displayed
as a tool tip if you point with the mouse cursor at the thumbnail. For longer information,
right-click the photograph and choose Properties from the menu. A dialog box opens
with three tabs, General, EXIF, and Histogram.
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General lists the name, type, owner, and some other basic information. The more inter-
esting part is the EXIF tab. The camera stores some metadata for each photograph.
Digikam reads these properties and displays them in this list. Find the exposure time,
pixel dimensions, and others. To get more information for the selected list entry, press
Shift + F1 . This shows a small tool tip. The last tab, Histogram, shows some statistical
information.

18.3.4 Managing Albums
Digikam inserts a My Albums folder by default, which collects all your photographs.
You can store these into subfolders later. The albums can be sorted by their directory
layout, by the collection name that has been set in the album properties or by the date
that the albums were first created (this date can also be changed in the properties of
each album).

To create a new album, you have some possibilities:

• Uploading new photographs from the camera

• Creating a new album by clicking the New Album button in the toolbar

• Importing an existing folder of photographs from your hard disk (select Album →
Import → Import Folders)

• Right-clicking My Albums and selecting New Album

After selecting to create an album in your preferred way, a dialog box appears. Give
your album a title. Optionally, choose a collection, insert some comments, and select
an album date. The collection is a way of organizing your albums by a common label.
This label is used when you select View→ Sort Albums→ By Collection. The comment
is shown in the banner at the top of the main window. The album date is used when
you select View → Albums → By Date.

Digikam uses the first photograph in the album as the preview icon in the My Albums
list. To select a different one, right-click the respective photograph and select Set as
Album Thumbnail from the context menu.

Using Digital Cameras with Linux 245



18.3.5 Managing Tags
Managing lots of different photographs with different albums can sometimes be complex.
To organize individual photographs, Digikam provides the My Tag system.

For example, you have photographed your friend John at different times and you want
to collect all images, independent of your album. This let you find all photographs very
easily. First, create a new tag by clicking My Tags → People. From the context menu,
choose New Tag. In the dialog box that appears, enter John as title and optionally set
an icon. Confirm with Ok.

After creating your tag, assign it to the desired pictures. Go to each album and select
the respective photographs. Right-click and choose Assign Tag → People→ John from
the menu that appears. Alternativly, drag the photographs to the tag name under My
Tags and drop them there. Repeat as necessary with other albums. View all the images
by clicking My Tags → People → John. You can assign more than one tag to each
photograph.

Editing tags and comments can be tedious. To simplify this task, right-click a photograph
and select Edit Comments & Tags. This opens a dialog box with a preview, a comment
field, and a tag list. Now you can insert all the needed tags and add a comment. With
Forward and Back, navigate in your album. Store your changes with Apply and leave
with Ok.

18.3.6 Exporting Image Collections
Digikam provides several export options that help you archive and publish your personal
image collections. It offers archiving to CD or DVD (via k3b), HTML export, and export
to a remote gallery.

To save your image collection to CD or DVD, proceed as follows:

1 Select File → Export → Archive to CD/DVD.

2 Make your adjustments in the Create CD/DVD Archive dialog using its various
submenus. After that, click OK to initiate the burning process.

a Selection: Determine which part of your collection should be archived by
selecting albums and tags.
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b HTML Interface: Decide whether your image collection should be accessible
via an HTML interface and whether autorun functionality should be added
to your CD/DVD archive. Set a selection title and image, font, and back-
ground properties.

c Media Volume Descriptor: Change the settings for volume description, if
necessary.

d Media Burning: Adjust the burning options to your needs, if necessary.

To create an HTML export of your image collection, proceed as follows:

1 Select File → Export → HTML Export.

2 Adjust the settings in Create Image Galleries to your needs, using the various
submenus. When you are done, click OK to initiate the gallery creation.

a Selection: Determine which part of your collection should be archived by
selecting albums and tags.

b Look: Set the title and appearance of your HTML gallery.

c Album: Determine the location of the gallery on disk as well as image size,
compression, format, and the amount of metadata displayed in the resulting
gallery.

d Thumbnails: As with the target images, specify size, compression and file
type for the thumbnails used for gallery navitation.

To export your collection to an external image gallery on the Internet, proceed as
follows:

1 Get an account for an external web site holding your gallery.

2 Select File → Export → Export to Remote Gallery and provide URL, username,
and password for the external site when asked for them.

Digikam establishes a connection to the site specified and opens a new window
called Gallery Export.
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3 Determine the location of your new album inside the gallery.

4 Click New Album and provide the information requested by Digikam.

5 Upload the images to the new album with Add Photos.

18.3.7 Useful Tools
Digikam provides several tools to simplify some tasks. Find them in the Tools menu.
The following is a small selection of the available tools.

Creating a Calendar
If you want to please someone, a custom calendar can be a nice gift. Go to Tools →
Create Calendar, which opens a wizard dialog like that in Figure 18.3, “Creating a
Template for a Calendar” (page 249).

Customize the settings (paper size, image position, font, etc.) and confirm with Next.
Now you can enter the year and select the images to use. After clicking Next again, see
a summary. The final Next opens the KDE Printer dialog. Here, decide if you want to
see a preview, save as PDF, or just print directly.

248 KDE User Guide



Figure 18.3 Creating a Template for a Calendar

Finding Duplicate Photographs
Sometimes you photograph similar scenes repeatedly and want to keep only the best
shots. This is the perfect task for the Find Duplicate plug-in.

Go to Tools → Find Duplicate Images. Select the albums or tags to handle. Under
Method & Cache, choose the search method: a more accurate or a faster method. After
you confirm with Ok, Digikam proceeds with the investigation.

If it finds some duplicates, it shows the result in a window like Figure 18.4, “Results
of Find” (page 250). Decide which images to delete by activating the desired check
boxes then clicking Delete. Leave the window with Close.

Using Digital Cameras with Linux 249



Figure 18.4 Results of Find

Batch Processes
Digikam also provides some batch processes that perform a specific task on lots of files.
This can be renaming, converting, resizing, and much more. Find them under Tools →
Batch Processes.

18.3.8 Basic Image Viewing and Editing with
Digikam

Digikam includes its own lean image viewing and editing program. It automatically
opens if you double-click an image's thumbnail.

Use this tool to do some basic image editing on the images you just downloaded from
your camera. You can crop, rotate or flip the image, do some basic color adjustments,
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apply various colored filters (for example, to export a colored image to black and white),
and efficiently reduce red eyes in portrait shots.

The most important menus are:

Image
Use Edit Comments & Tags to enter comments to a particular image and to assign
a tag (category) to this image. Properties takes you to a window consisting of three
tabs providing general information, EXIF information, and the histogram of this
image.

Fix
This menu contains some of the editing functions most needed in digital photogra-
phy. Colors takes you to a submenu where you can modify all basic color settings.
You can also blur or sharpen either the entire picture or just a part of the image
you selected. To reduce red eyes in a portrait shot, roughly select the eye region
of the face by just clicking and holding the left mouse pointer and gradually expand-
ing the selection, select Red Eye Reduction and choose either mild or aggressive
reduction depending on whether you selected a whole region or just the eyes.

Transform
The Transform menu offers the crop, rotate, flip, and resize functions. You can also
use the Aspect Ratio Crop option to produce crops in a fixed aspect ratio.

Filters
If you need to transform your color shots into black and white or want to achieve
an aged look in your photographs, check out the Filters menu and choose from the
various export options.

A more detailed description of this tool can be found in Digikam's online help in digiKam
Image Editor, which can be reached with the Help button in Digikam's menu bar.

TIP: Advanced Image Processing

Professional image editing can be done with the GIMP. More information about
The GIMP can be found in Chapter 17, Manipulating Graphics with The GIMP
(page 233).

Using Digital Cameras with Linux 251



18.4 For More Information
For more information about using digital cameras with Linux, refer to the following
Web sites:

• http://digikam.sourceforge.net/—Information about Digikam

• http://www.gphoto.org—Information about gPhoto2

• http://www.gphoto.org/proj/libgphoto2/support.php—A
comprehensive list of supported cameras

• http://www.thekompany.com/projects/gphoto/—Information about
Kamera, a KDE front-end for gPhoto2
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19Playing Music and Movies
During installation, YaST normally identifies and configures the sound cards of your
computer automatically. Otherwise (or if you installed a new sound card), start YaST
and configure the sound card manually in the Sound module. When your sound card
has been configured, you can control the volume and balance with a mixer and start
other sound applications.

Linux includes a wide range of sound and multimedia applications. Some of these ap-
plications are installed on your Linux system by default. With the applications described
here, control the volume and balance of playback and play CDs, music and movie files.

In case one of the listed applications is not installed by default on your system, use
YaST to install the missing packages. Use the search function of the YaST package
management tool to find the package names.

19.1 Mixers
Mixers provide a convenient means of controlling the volume and balance of the sound
output and input of computers. For a description of the default KDE and GNOME
mixer applets refer to the KDE and GNOME chapters.

The main difference between the various mixers is the outer appearance of the user in-
terface. However, there are a number of mixers that are designed for specific hardware.
One example is envy24control, a mixer for the Envy 24 sound chip. Another one is
hdspmixer, which is for RME Hammerfall cards. From the mixers available, select the
one that best suits your needs.
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TIP: Starting the Mixer

Generally, it is advisable to open a mixer application before opening other
sound applications. Use the mixer to test and adjust the control settings for
the input and output of the sound card.

19.2 Playing Music Files
In Linux, find a variety of programs for playing music files, such as OGG or WAV
files. KDE offers amaroK and JuK, for example.

19.2.1 amaroK Media Player
The amaroK media player handles various audio formats and plays the streaming audio
broadcasts of radio stations on the Internet. The file types supported depend on the engine
used, currently xine or Helix.

On first start, amaroK launches a First-Run Wizard, which helps set up amaroK. In the
first step, configure your preferred look and feel for amaroK. Choose to display player
and playlist in separate windows (see Figure 19.1, “The amaroK Media Player”
(page 255)) or combine their functionality in one single window (default). In the second
step, determine where amaroK should look for your music collection. amaroK scans
these folders for playable media. By default, amaroK is configured to scan the selected
folders recursively (to include all their subdirectories in the scan), monitor changes to
the content of the selected directories, and import any playlists located there. All the
settings made with the wizard can be modified later by starting the wizard again with
Tools → First-Run Wizard.
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Figure 19.1 The amaroK Media Player

Quick Start
On start-up, amaroK scans the folders that are part of your collection for music files.
Although you can use amaroK without building a collection, it is recommended to do
so, because most of the powerful, advanced features are only available with an existing
collection.

The amaroK main window is divided into two parts. The sidebar browsers on the left
contain different views of your music collection and your playlists, a file browser, and
an interface to an iPod. Change the browser by clicking a tab on the far left. The right
part contains the playlist window and, below it, the player (if you have not configured
it to be shown in a separate window).

To play music, first create a playlist. Just drag and drop items from any of the sidebar
browsers to the playlist window. Use Shift or Ctrl to select multiple items. Double-click
an item in the playlist to play it. You can add or delete items from the list during play-
back. Use the icons in the bottom right corner to Undo and Redo changes or to Clear
the entire list.
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The Sidebar Browsers
Context

With this tab, view information and statistics about your collection and the current
artist. Switch to different views using the tabs on top of the Context browser. The
Home view provides statistics on your listening habits, listing your favorite, newest,
and least-played tracks or albums. Current provides data related to the track cur-
rently being played, such as the album cover (see Section “The Cover Manager”
(page 258)) and the listening statistics related to this track. If available, Lyrics dis-
plays the lyrics of the track currently played. You need to be connected to the In-
ternet to use this feature. Artist shows information about the artist. This information
is fetched from Wikipedia, so an Internet connection is needed as well.

Collection
Use this view to manage and display your personal collection of titles. The toolbar
on top of the browser allows you to configure the way your collection is displayed
and to rescan or reorganize the collection. Define the order your titles are displayed
in the browser withGroup By. You can choose between predefined criteria or create
your own sort criteria using Primary, Secondary, and Tertiary. The next two icons
let you toggle between tree and flat view. Use the update icon to rescan your entire
collection for changes and add or delete folders to scan by clicking the wrench
icon.

If you are searching for a particular album, title, genre, or year, use Filter here.
The selection in the browser is adjusted as you type. You can only search in criteria
used to group the collection. If you have grouped your collection by Artist / Album,
it is not possible to search for titles belonging to a certain genre.

Playlists
You can access different playlists with the playlist browser. Playlists holds your
personal playlists found in your collection folders. Every time you create and save
a new playlist from the playlist window, it appears here. Right-click to open a menu
where you can manually add a new playlist or a subfolder. To add new items from
the playlist window to an existing playlist, just drag and drop them on the playlist
in the browser window.
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IMPORTANT: Sharing Playlists with Other Players

Save playlists in m3u or pls format, so you can share them with any other
players using these formats.

Smart Playlists offer various views of your collection, such as tracks never played,
newest tracks, or tracks by genre. Right-click to add subfolders or to create your
own smart playlists.

Radio Streams lets you listen to live radio streams from the Internet. An extensive
list is already shipped with amaroK. Right-click to add more or create subfolders.

Podcasts imports podcasts to amaroK. Right-clicking opens a menu where you can
add podcasts and subfolders, refresh all podcasts, or set the scan interval.

At the bottom of the playlist browser window, you can Enable dynamic mode and
configure it with Show Options. Dynamic mode is a feature that allows you the
flexibility of picking music from your entire collection while keeping a relatively
small playlist that is easy to maintain. Refer to the online documentation (open it
with F1 ) for details.

Media Device
If you own an iPod, you can use this browser to play music from it or to add music
from your collection to the iPod. It must be mounted at /mnt/ipod before starting
amaroK. To listen to tracks from the iPod, drag and drop them from the list view
to the playlist window. To add tracks from the collection to the iPod, drag tracks
from the playlist window to the list view.

File Browser
This tab opens a file browser. It corresponds to the standard KDE file selector dialog
with the usual controls for navigating the file system. Enter a URL or a path directly
into the text input field. From the contents displayed, drag elements to the playlist
to include them. You can also perform a recursive search for a file in a given direc-
tory. To do so, enter a text string for the title and the location at which to start the
search. Then select Search and wait for the results to appear in the lower section
of the window.
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The Cover Manager
With amaroK, you can assign a cover to each album of your collection. With the Cover
Manager, easily add, delete, and retrieve album covers.

Start the cover manager with Tools → Cover Manager. A tree view in the left part of
the window lists all artists in your collection. The main part of the window lists the
covers of all albums. To filter the covers displayed, click an individual artist in the tree
view or enter a term in the input field at the top of the window. Use View to toggle be-
tween displaying all albums, albums with covers, or albums without covers.

There are three different methods for assigning covers to the albums:

Automatically Assign Covers
amaroK can automatically fetch all missing covers displayed in the main windows
from Amazon. Use Amazon Locale to determine from which Amazon Web server
the covers should be fetched then click Fetch Missing Covers.

IMPORTANT: Proper Tagging Needed

amaroK fetches the covers from Amazon using the query string Artist
- Album. This information is extracted from the tags of your music files.
The better they are tagged, the better the hit rate is when automatically
fetching covers.

Manually Choose a Cover Fetched from Amazon
If you want more control over what image to use and what query string to use to
retrieve a cover, right-click an album in the main window and choose Fetch from
amazon. Next Cover lets you cycle through all images available. Save selects the
actual cover and assigns it to the album selected. If you are not satisfied with the
covers displayed, use New Search to refine the search. Use Amazon Locale from
the toolbar of the main window to determine from which Amazon Web server the
covers should be fetched.

Manually Assign Covers
If you already have your own cover images, you can assign them by right-clicking
an album and choosing Set Custom Image.
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Visualizations
amaroK comes with a number of visualizations that display a graphical effect for the
music played. Native amaroK visualizations are displayed in the player window. Cycle
through the various available display modes by clicking the animation.

In addition to the above, amaroK also supports the visualization plug-ins of the XMMS
media player. To use these, first install the xmms-plugins package then select Tools
→ Visualizations from the amaroK menu. This opens a window listing the available
plug-ins. XMMS plug-ins are always displayed in separate windows. In some cases,
there is an option to display them in full-screen mode. For some plug-ins, you may not
get a smooth visual effect unless you use a 3D-accelerated graphics card.

The amaroK Tray Icon
Like other KDE applications, amaroK adds an icon to the KDE system tray. You can
use this icon to control a large number of amaroK's features. Hovering the mouse over
the icon displays information about the track currently played. A single left-click closes
the application window without affecting playback. Click again to reopen the window.
Clicking with the middle mouse button pauses playback—middle-click again to resume
playback. Right-clicking opens a context menu where you have access to the player
controls and can exit amaroK. Scrolling the mouse wheel changes the playback volume.

Using the Shift and Ctrl keys together with the mouse gives you access to more advanced
features. Holding Shift while scrolling the mouse wheel seeks through the current track.
Holding Ctrl while scrolling the mouse wheel skips through tracks in the playlist.

You may also drag items and drop them on the tray icon to add them to the current
playlist. A pop-up menu opens, asking whether to append the track to the playlist, append
and play it, or queue it after the current track.

19.2.2 JuK Jukebox
JuK (kdemultimedia3-jukebox package) is a jukebox application that lets you
manage your music file collection and playlists. JuK maintains a list of all files it knows
about. This is called the collection list. The list is specific to JuK and is not shared with
other applications. Independent of the collection list are playlists. You can have as many
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playlists as you want and you can share your JuK playlists with other media players.
You can also edit the tags of your music files.

Start JuK with the main menu or press Alt + F2 and enter juk. Find more information
about JuK in the online help.

19.3 Handling Audio CDs
There are many ways to listen to your favorite music tracks. Either play a CD or play
digitized versions of them. The following section features some CD player applications
as well as some applications that can be used for digitizing audio CDs.

For information about how to create your own CDs, refer to Chapter 20, Burning CDs
and DVDs (page 267).

IMPORTANT: CDDA and Analog CD Playback

There are two different ways of playing audio CDs. CD and DVD drives capable
of analog CD playback read the audio data and send it to the sound output
device. Some external drives connected via PCMCIA, FireWire, or USB need to
use CDDA (Compact Disk Digital Audio) to extract the audio data first then
play it as digital PCM. The players featured in the following sections do not
support CDDA. Use XMMS if you need CDDA support.

19.3.1 KsCD—Audio CD Player
KsCD is an easy-to-use audio CD player. Press Alt + F2 and enter kscd to start the
application. KsCD integrates into your KDE panel and can be configured to start playing
automatically after a CD has been inserted. To access the configuration menu, select
Extras → Configure KsCD. Fetch album and track information from a CDDB server
on the Internet if KsCD is configured accordingly. You can also upload CDDB infor-
mation to share it with others. Use theCDDB dialog for information retrieval and upload.
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Figure 19.2 The KsCD User Interface

19.3.2 Compressing Audio Data: Ripping
Audio compression can be handled by various tools. The following sections feature a
command line approach to encoding and playing audio data as well as some graphical
applications capable of audio compression.

Command Line Tools for Encoding and Playback of
Audio Data
Ogg Vorbis (package vorbis-tools) is a free audio compression format that is now
supported by the majority of audio players and even portable MP3 players. The Web
page of the project is http://www.xiph.org/ogg/vorbis.

Your system comes with several tools supporting Ogg Vorbis. oggenc is a command
line tool used for encoding WAV files to Ogg. Just run oggenc myfile.wav to
transform a given .wav file into Ogg Vorbis. The -h option displays an overview of
the other parameters. Oggenc supports encoding with a variable bit rate. In this way,
an even higher degree of compression can be achieved. Instead of the bit rate, specify
the desired quality with the parameter -q. -b determines the average bit rate. -m and
-M specify the minimum and maximum bit rate.

ogg123 is a command line Ogg player. Start it with a command like ogg123
mysong.ogg.
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Compressing Audio Data Using KAudioCreator
KAudioCreator is a lean CD ripper application (see Figure 19.3, “Ripping Audio CDs
with KAudioCreator” (page 262)). Once started, it lists all the tracks of your CD in the
CD Tracks tab. Select the tracks to rip and encode. To edit the track information, use
theAlbumEditor underFile→Edit Album. Otherwise just start the ripping and encoding
with File → Rip Selection. Watch the progress of these jobs using the Jobs tab. If con-
figured accordingly, KAudioCreator also generates playlist files for your selection that
can be used by players like amaroK, XMMS, or Helix Banshee.

Figure 19.3 Ripping Audio CDs with KAudioCreator

Compressing Audio CDs Using Konqueror
Before you start the actual ripping process with Konqueror, configure the handling of
audio CDs and the Ogg Vorbis encoder in the KDE Control Center. Select Sound &
Multimedia→Audio CDs. The configuration module is divided into three tabs:General,
Names, and Ogg Vorbis Encoder. Normally, a suitable CD device is detected automat-
ically. Do not change this default setting unless the autodetection failed and you need
to set the CD device manually. Error correction and encoder priority can also be set
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here. The Ogg Vorbis Encoder tab determines the quality of the encoding. To configure
online lookup of album, track, and artist information for your ripped audio data, select
Add Track Information.

Start the ripping process by inserting the CD into the CD-ROM drive and entering
audiocd:/ in the Location bar. Konqueror then lists the tracks of the CD and some
folders (see Figure 19.4, “Ripping Audio Data with Konqueror” (page 263)).

Figure 19.4 Ripping Audio Data with Konqueror

To keep uncompressed audio data on your disk, just select the .wav files and drag
them into another Konqueror window to copy them to their final destination. To start
the Ogg Vorbis encoding, drag the Ogg Vorbis folder or files from this folder to
another Konqueror window. The encoding starts as soon as you drop the Ogg Vorbis
folder at its destination.

19.4 Playing Movie Files
You can choose between several movie players shipped with your SUSE Linux Enter-
prise Desktop. Kaffeine is the default KDE movie player and can be run with several
back-ends, such as Xine and MPlayer.
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Figure 19.5 Kaffeine Main Window

The formats you can view with Kaffeine depends on the back-end (by default, Xine is
used). Xine interprets many of the most common multimedia formats available. For
more information, refer to http://xinehq.de/.

Kaffeine can also play multimedia streamed over the Internet and can be used as a plug-
in for Konqueror. It provides the usual options for playing files in full screen mode,
navigating through files, and more. You can also take a snapshot of the video and save
it as an image.

Apart from Kaffeine, SUSE Linux Enterprise Desktop also ships RealPlayer for Linux.
RealPlayer supports RealAudio, RealVideo, Ogg Vorbis, Theora, and more.
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Figure 19.6 RealPlayer for Linux
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20Burning CDs and DVDs
K3b is a comprehensive program for writing data and audio CDs and DVDs. Start the
program from the main menu or by entering the command k3b. The following sections
brief you on how to start a basic burning process to get your first Linux-made CD or
DVD.

20.1 Creating a Data CD
To create a data CD, go to File → New Project → New Data CD Project. The project
view appears in the lower part of the window, as shown in Figure 20.1, “Creating a
New Data CD” (page 268). Drag the desired directories or individual files from your
home directory to the project folder and drop them there. Save the project under a name
of your choice with File → Save as.
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Figure 20.1 Creating a New Data CD

Then select Burn from the toolbar or hit Ctrl + B . A dialog with six tabs offering various
options for writing the CD opens. See Figure 20.2, “Customizing the Burning Process”
(page 268).

Figure 20.2 Customizing the Burning Process
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The Writing tab has various settings for the burning device, the speed, and the burning
options. The following options are offered here:

Burning Device
The detected writer is displayed under this pop-up menu. You can select the speed
here too.

WARNING: Select the Writing Speed with Care

Normally, you should select Auto, which chooses the maximum writing
speed possible. However, if you increase this value but your system is not
able to send the data fast enough, the likelihood of buffer underruns in-
creases.

Writing Mode
This option determines how the laser writes a CD. In DAO (disk at once) mode,
the laser is not deactivated while the CD is written. This mode is recommended for
the creation of audio CDs. However, it is not supported by all CD writers. In the
TAO mode (track at once), a separate write process is used for each individual
track. The RAW mode is not used very often, because the writer does not perform
any data corrections. The best setting is Auto, because it allows K3b to use the most
suitable settings.

Simulate
This function can be used to check if your system supports the selected writing
speed. The writing is performed with the laser deactivated to test the system.

On the Fly
Burns the desired data without first creating an image file (do not use this feature
on low-performance machines). An image file—also known as an ISO image—is
a file containing the entire CD content that is subsequently written to the CD exactly
as it is.

Only Create Image
This option creates an image file. Set the path for this file under Temporary File.
The image file can be written to CD at a later time. To do this, use Tools → CD
→ Burn CD Image. If this option is used, all other options in this section are deac-
tivated.

Burning CDs and DVDs 269



Remove Image
Remove the temporary image file from hard disk when finished.

Verify Written Data
Check the integrity of the written data by comparing the MD5 sums of the original
and the burned data.

The Image tab is only accessible if the option Only create image from the previous tab
is selected. If this is the case, you can determine the file where the ISO is written.

The Settings tab contains two options: Datatrack Mode and Multisession Mode. The
Datatrack Mode options contains configuration of how data tracks may be written. In
general, auto is considered the best suited method. The Multisession Mode is used to
append data to an already written but not finalized CD.

In the Volume Desc tab, enter some general information that can be used to identify
this particular data project, its publisher and preparer, and the application and operating
system used in the creation of this project. Under File system, specify settings for the
file system on the CD (RockRidge, Joliet, UDF). Also determine how symbolic links,
file permissions, and blanks are treated. In the Advanced tab, experienced users can
make additional settings.

After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment with Save.

20.2 Creating an Audio CD
Basically, there are no significant differences between creating an audio CD and creating
a data CD. Select File → New Audio CD Project. Drag and drop the individual audio
tracks to the project folder. The audio data must be in WAV or Ogg Vorbis format.
Determine the sequence of the tracks by moving them up or down in the project folder.

With the help of CD Text, you are able to add certain text information to a CD, such
as CD title, artist name, and track name. CD players that support this feature can read
and display this information. To add CD Text information to your audio tracks, select
the track first. Right-click and select Properties. A new window opens in which to enter
your information.
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The dialog for burning an audio CD is not very different from the dialog for burning a
data CD. However, the Disc at once and the Track at once modes have greater impor-
tance. The Track at once mode inserts an intermission of two seconds after each track.

TIP: Preserving Data Integrity

When burning audio CDs, choose a lower burning speed to reduce the risk of
burning errors.

After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment with Save.

20.3 Copying a CD or DVD
Select Tools→Copy CD or Tools→Copy DVD depending on your media. In the dialog
that opens, make the settings for the reading and writing device as shown in Figure 20.3,
“Copying a CD” (page 272). The writing options discussed are also available here. An
additional function enables the creation of several copies of the CD or DVD.
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Figure 20.3 Copying a CD

Check On the fly to burn the CD as soon as it has been read or select Only create image
to create an image in the path specified on the Image tab in the Write image file to option
and burn the image later.

20.4 Writing ISO Images
If you already have an ISO image, go to Tools → CD → Burn CD image. A window
opens in which to enter the location of the Image to Burn. K3b calculates a check sum
and displays it in MD5 Sum. If the ISO file was downloaded from the Internet, this sum
shows if the download was successful.

Use the Options and Advanced tabs to set your preferences. To burn the CD, click Start.
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20.5 Creating a Multisession CD or
DVD

Multisession discs can be used to write data in more than one burning session. This is
useful, for example, for writing backups that are smaller than the media. In each session,
you can add another backup file. The interesting part is that you are not only limited to
data CDs or DVDs. You can also add audio sessions in a multisession disc.

To start a new multisession disc, do the following:

1 Create your data disc first and add all your files. You cannot start with an audio
CD session. Make sure that you do not fill up the entire disc, because otherwise
you cannot append a new session.

2 Burn your data with Project → Burn.

3 In the dialog box that appears, go to the Settings tab and select Start Multisession.

4 Configure other options if needed. See also Section 20.1, “Creating a Data CD”
(page 267).

5 Start the burning session with Burn.

After a successful burning process, you have created a multisession disc. As long as
the media contains enough space, you can append more sessions if you like. Finish
discs only if you are sure you do not need any new sessions or the space is occupied.

NOTE: About Storage Space on Multisession Discs

Be aware that multisession discs need space for bookkeeping all the entries
from your sessions. This leads to a smaller amount of available space on your
disc. The amount depends on the number of sessions.
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20.6 For More Information
Apart from the two main functions described above, K3b offers other functions, such
as the creation of DVD copies, reading audio data in WAV format, rewriting CDs, and
playing music with the integrated audio player. A detailed description of all available
program features is available at http://k3b.sourceforge.net.
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AFinding the Information You
Need
To support you in your everyday work with SUSE® Linux Enterprise Desktop and to
help you explore your Linux system, Novell and the open source community at large
have created a wealth of information. We have compiled relevant information and made
it available to you in various formats. You can access detailed documentation provided
with your product as well as additional information over the Internet.

A.1 Included Documentation
There are several places where you can find online documentation shipped with your
product. The KDE desktop includes a help center that offers a wide range of online
documentation for your SUSE Linux Enterprise Desktop. There, you can access SLED-
specific information as well as application descriptions provided by the open source
community.

When installing new software with YaST, the software documentation is installed au-
tomatically in most cases and usually appears in the help center of your KDE desktop.
However, some applications, such as The GIMP, may have different online help packages
that can be installed separately with YaST and do not integrate into the help center.

A.1.1 Using the Help Center
You can access the Help Center in various ways: Clicking the Help button in an appli-
cation or pressing F1 takes you directly to that application's documentation in the Help
Center. However, if you start the Help Center from the main menu, by clicking the icon



in the panel, or by entering the susehelp command, you are taken to the main window
of the Help Center as shown below.

Figure A.1 Main Window of the Help Center

The menu and the toolbar provide options for printing contents from the Help Center,
searching the currently displayed page, and navigating and customizing the Help Center.
The display field in the right part of the window always shows the currently selected
contents, such as online manuals, search results, or Web pages.

The navigation area in the left part of the window contains several tabs.

Contents
Presents a tree view of all available information sources. The Help Center addresses
various target groups, such as users, administrators, and developers. Click the book
icons to open and browse the individual categories. Under the heading Administra-
tion, for example, you can also browse man (manual) and info (information) pages
associated with command line programs. The Help Center also provides access to
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some online databases that cover special hardware and software issues for your
product. All these sources can be searched comfortably once a search index has
been generated.

The contents of your Help Center depends on which software packages are currently
installed and which languages are selected as your system languages.

Glossary
Provides a quick reference where you can look up the definitions of words that
might be unfamiliar to you.

Search Options
Holds options for the full text search of the Help Center. You can combine several
search criteria.

To use the full text search, generate a search index and set the search parameters. If the
search index has not yet been generated, the system automatically prompts you to do
so when you click the Search tab or type a search string and click Search.

Procedure A.1 Generating a Search Index

1 To create a new search index, select Settings → Build Search Index from the
menu. A window opens, showing a list of documentation currently available in
the Help Center.

2 Select the documents to integrate in the search index and click Build Index. After
the index has been generated, you can use the full text search.
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Figure A.2 Generating a Search Index

Procedure A.2 Using the Full Text Search

1 Click Search Options and enter the string to find.

2 To combine your search strings with operands, click Method and select the
operand to use.

3 To limit the number of hits to display, choose an option from Max. Results.

4 To restrict your search to certain types of documentation, choose an option from
Scope. WithDefault, a predefined selection of documents is searched.All includes
all types of documents in the search. Custom lets you define which documents
to include in your search. Just activate the documents you want in the list.
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Figure A.3 Combining Search Options

5 When you have set the options according to your wishes, click Search. The search
results are then displayed as a list of links in the display field and can be navigated
with mouse clicks.

A.2 Additional Resources and More
Information

You can also access the specific manuals and documentation delivered with your
product on the Internet at http://www.novell.com/documentation/
sled10/.

If you are searching for additional information, you can also refer to the following In-
ternet sites:
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• SUSE Support Database [http://en.opensuse.org/SDB:SDB]

• Novell Technical Support Knowledgebase [http://support.novell.com/
search/kb_index.jsp]

• Novell Discussion Groups [http://support.novell.com/forums/index
.html]

• KDE Documentation Web site [http://www.kde.org/documentation]

• Documentation Web site for KDE applications [http://www.kde-apps.org/
]

In addition, general-purpose search engines are often helpful. For example, you might
try the search terms “Linux CD-RW help” or “OpenOffice file conversion problem” if
you were having trouble with the CD burning or with OpenOffice.org file conversion.
Google™ also has a specific Linux search engine at http://www.google.com/
linux that you might find useful.
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BMoving from Windows to
Linux
If you are coming from Microsoft Windows, take a look at how familiar elements of
Windows translate to SUSE® Linux Enterprise Desktop. After logging in, you will
notice that the desktop has a familiar layout and recognizable icons, many of them
similar to the Windows and Macintosh desktops.

Figure B.1 KDE Desktop



B.1 Starting Applications from the
Main Menu

Similar to the Start menu on Windows, you can access all the programs installed on
your system from the main menu. To open the menu click the green SUSE icon in the
left corner of the panel. The function-oriented menu structure makes it easy to find the
right application for your purpose even if you do not know the application names yet.
Find more information about the main menu in Section 1.3.1, “Accessing the Main
Menu” (page 22).

Figure B.2 Main Menu in KDE

Alternatively, you can also start programs from the command line. Press Alt + F2 to
open a dialog where you can enter a command to start the application. The name of the
command is often (but not always) the application name written in lowercase.
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B.2 Managing Files
To start Konqueror, the default KDE file manager (and Internet browser), press Alt +
F2 and enter konqueror. To view the contents of your home directory, click Personal
Files. To open this view directly, use the quick start icon with a house in the panel.

Figure B.3 Windows Explorer and Konqueror

For more information about Konqueror as a file manager, see Section 1.4, “Managing
Folders and Files with Konqueror” (page 29).

B.3 Using the Command Line
To run commands in a command line environment, similar to a command prompt on
Windows, press Alt + F2 and enter konsole or use the quick start icon in the panel.
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Figure B.4 Windows Command Prompt and Konsole Terminal

Read more about working with the command line in Chapter 14, Working with the Shell
(↑Deployment Guide).

B.4 Customizing Your Desktop
To change to the way your KDE desktops looks and behaves, press Alt + F2 and enter
kcontrol. Some of the settings you might want to change include the desktop back-
ground, screen saver, keyboard and mouse configuration, sounds, and file associations.
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Figure B.5 Windows Control Panel and KDE Control Center

For more information, see Section 2.2, “Configuring Your Desktop with the Control
Center” (page 64).

B.5 Setting Up Printers
To set up or add a printer to SUSE Linux Enterprise Desktop, start the Printing Manager
from the main menu. You can add and delete printers, manage print jobs, and configure
your print system. For more information, see Chapter 12,Managing Printers (page 199).
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Figure B.6 Windows Printers and Faxes and KDE Printing Manager

B.6 Switching between Applications
Similar to the taskbar on Windows, the bottom panel in KDE lets you easily switch
between open windows. Unlike Windows, KDE lets you set up multiple desktops where
each one can run different programs. Switch between them with a single click.

TIP: Using Shortcut Keys

You can also use shortcut keys to switch between your multiple desktops and
the applications running. Use the familiar Alt + →| to switch between applica-
tions. With Ctrl + F1 , Ctrl + F2 , etc., switch between desktops.

Figure B.7 Windows Panel and KDE Panel
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B.7 Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
SUSE Linux Enterprise Desktop offers various different ways of accessing and creating
network-shared resources. Given that the network structure and the configuration of
your computer allow for it, you can easily browse your network for shared resources
and services with your file manager, Konqueror.

Figure B.8 Windows My Network Places and Konqueror Network Browsing

To learn more about the various possibilities of accessing network resources, refer to
Chapter 9, Accessing Network Resources (page 167).
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CGetting to Know Linux
Software
Linux comes with a wealth of applications, often offering more than one solution to
specific needs. The difficulty is finding the application that suits your needs best. The
next few sections introduce some of the most powerful Linux counterparts of common
Windows software. Each section is dedicated to one particular field of application and
presents an overview of the Windows applications and Linux equivalents for several
tasks. Below each table, find further information about the Linux applications with
links to more information. This list is by no means complete, because software devel-
opment is an evolutionary process and new applications are being created every minute.

TIP: Missing Applications

Not all applications mentioned below are installed on your system by default
and some may not be shipped with your product. If the application you want
to use is missing, ask your system administrator. If the application is provided
by your product, you can install it with YaST. Use the search function of the
YaST software management tool to find the package names.

C.1 Office
This section features the most popular and powerful Linux office and business software
solutions. These include office suites, databases, accounting software, and project
management software.



Table C.1 Office Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

OpenOffice.org, StarOffice,
KOffice

MS Office, StarOffice,
OpenOffice.org

Office Suite

OpenOffice.org/StarOffice
Writer, KWord

MS Word, StarOf-
fice/OpenOffice.org Writer,
WordPerfect

Word Processor

OpenOffice.org/StarOffice Calc,
Gnumeric, KSpread

MS Excel, StarOf-
fice/OpenOffice.org Calc

Spreadsheet

OpenOffice.org/StarOffice Im-
press, KPresenter

MS PowerPoint, StarOf-
fice/OpenOffice.org Impress

Presentation

OpenOffice.org Calc, Kst, Gnu-
plot, Grace (Xmgr), LabPlot

MS Excel, MicroCall OriginData Plotting

OpenOffice.org Base, Rekall,
kexi, Mergeant, PostgreSQL

MS Access, OpenOffice.org
Base

Local Database

GnuCash, moneyplex, KMy-
Money

MS Money, Quicken, money-
plex

Financial Account-
ing

Planner, TaskjugglerMS ProjectProject Manage-
ment

VYM (View Your Mind), Free
Mind, KDissert

MindManager, Free MindMind Mapping

FreeMind
FreeMind helps you to visualize your thoughts by creating and editing a mind map.
You can easily copy nodes or the style of nodes and paste texts from sources such
as HTML, RTF, and mails. The mind maps can be exported into various formats,
such as HTML and XML. For more information, refer to http://freemind
.sourceforge.net/wiki/index.php/Main_Page.
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GnuCash
GnuCash is a software tool to control both your personal and business finances.
Keep track of income and expenses and manage your bank accounts and stock
portfolios all using one piece of software. Learn more about GnuCash at http://
www.gnucash.org.

Gnumeric
Gnumeric is a spreadsheet solution for the GNOME desktop environment. Find
more information about Gnumeric at http://www.gnumeric.org.

Gnuplot
Gnuplot is a very powerful and portable command line–controlled data plotting
software. It is also available for MacOS and Windows platforms. Plots created by
Gnuplot can be exported to various formats, such as PostScript, PDF, and SVG,
allowing you to process these plots easily. Find more information about Gnuplot
at http://www.gnuplot.info/index.html.

Grace
Grace is a very mature 2D plotting tool for almost all flavors of Unix including
Linux. Create and edit plots with a graphical user interface. Grace supports an un-
limited number of graphs per plot. Its export formats include JPEG, PNG, SVG,
PDF, PS, and EPS. Find more information at http://plasma-gate
.weizmann.ac.il/Grace/.

Kdissert
Kdissert is an application for structuring ideas and concepts, mostly aimed at stu-
dents but also helpful for teachers, decision makers, engineers, and businessmen.
Ideas are first laid down on a canvas then associated into a tree. You can generate
various outputs from the mind map, such as PDF files, text documents (also for
OpenOffice.org Writer), and HTML files. Find more information at http://
freehackers.org/~tnagy/kdissert/.

Kexi
See KOffice (page 292).

KMyMoney
KMyMoney is a personal finance manager for KDE. It enables users of open source
operating systems to keep track of their personal finances by providing a broad
array of financial features and tools. Learn more about KMyMoney at http://
kmymoney2.sourceforge.net.
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KOffice
KOffice is an integrated office suite for the KDE desktop. It comes with various
modules like word processing (KWord), spreadsheets (KSpread), presentations
(KPresenter), several image processing applications (Kivio, Karbon14, Krita), a
database front-end (Kexi), and many more. Find more information about KOffice
at http://www.koffice.org/.

KPresenter
See KOffice (page 292).

Kst
Kst is a KDE application for real-time data viewing and plotting with basic data
analysis functionality. Kst contains many powerful built-in features, such as robust
plotting of live streaming data, and is expandable with plug-ins and extensions.
Find more about Kst at http://kst.kde.org/.

KWord
See KOffice (page 292).

LabPlot
LabPlot is a program for creating and managing two or three-dimensional data
plots. Graphs can be produced both from data and functions and one plot might
include multiple graphs. It also offers various data analysis methods. Find more
information about LabPlot at http://labplot.sourceforge.net/.

Mergeant
Mergeant is a database front-end for the GNOME desktop. Find more information
at http://www.gnome-db.org.

moneyplex
moneyplex is a tool to control your finances. All tasks from managing incoming
resources and expenses and monitoring your stock portfolio to online transactions
via the HBCI standard are handled by moneyplex. Keep track of your financial
transactions over time using various analysis options. Because this tool is also
available for Windows, users can migrate very easily without having to learn a
whole new application interface. Find more information about moneyplex at
http://www.matrica.de.

OpenOffice.org
OpenOffice.org is the open source equivalent of MS Office. It is a very powerful
office suite including a word processor (Write), a spreadsheet (Calc), a database
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manager (Base), a presentation manager (Impress), a drawing program (Draw),
and a formula editor for generating mathematical equations and formulas (Math).
Users familiar with the MS Office family of applications find a very similar appli-
cation interface and all the functionality to which they are accustomed. Because
OpenOffice.org is capable of importing data from MS Office applications, the
transition from one office suite to the other is very smooth. A Windows version of
OpenOffice.org even exists, enabling Windows users to switch to an open source
alternative while still using Windows. Find more information about OpenOffice.org
at http://www.openoffice.org/ and read our OpenOffice.org chapter for
a short introduction to the office suite.

Planner
Planner is a project management tool for the GNOME desktop aiming to provide
functionality similar to the project management tools used under Windows. Among
its various features are Gantt charting abilities and different kinds of views of tasks
and resources. Find more information about Planner at http://www.imendio
.com/projects/planner/.

PostgreSQL
PostgreSQL is an object-relational database management system that supports an
extended subset of the SQL standard, including transactions, foreign keys, sub-
queries, triggers, and user-defined types and functions. Find more information
about PostgreSQL at http://www.postgresql.org/.

Rekall
Rekall is a tool for manipulating databases. Supported databases include MySQL,
PostgreSQL, XBase with XBSQL, IBM DB2, and ODBC. Use Rekall to generate
different sorts of reports and forms, design database queries, or import and export
data to various formats. Find more information about Rekall at http://www
.thekompany.com/products/rekall/.

StarOffice
StarOffice is a proprietary version of OpenOffice.org and is distributed by Sun
Microsystems. It is available on multiple platforms including Windows and Solaris.
It includes certain advanced features not available with the free version (OpenOf-
fice.org). Find more information about StarOffice at http://www.sun.com/
software/star/staroffice/.
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Taskjuggler
Taskjuggler is a lean, but very powerful project management software. Take control
of your projects using the Gantt charting features or by generating all kinds of reports
(in XML, HTML, or CSV format). Those users who are not comfortable with
controlling applications from the command line can use a graphical front-end to
Taskjuggler. Find more information about Taskjuggler at http://www
.taskjuggler.org.

VYM (View Your Mind)
VYM is a software for visualizing your thoughts by creating and manipulating
mind maps. Most manipulations do not require more than one mouse click.
Branches can be inserted, deleted, and reordered very easily. VYM also offers a
set of flags allowing you to mark certain parts of the map (important, time critical,
etc.). Links, notes, and images can be added to a mind map as well. VYM mind
maps use an XML format, allowing you to export your mind maps to HTML easily.
Find more information about VYM at http://www.insilmaril.de/vym.

C.2 Network
The following section features various Linux applications for networking purposes.
Get to know the most popular Linux browsers and e-mail and chat clients.

Table C.2 Network Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, Firefox, Opera,
Epiphany

Internet Explorer, Firefox,
Opera

Web Browser

Evolution, Kontact, Mozilla
Thunderbird

MS Outlook, Lotus Notes,
Mozilla Thunderbird

E-Mail Client/Personal
Information Management

Gaim, Kopete, Konversa-
tion, XChat

MSN, AIM, Yahoo Messen-
ger, XChat, Gaim

Instant Messaging/IRC
Clients

GnomeMeeting/EkigaNetMeetingConferencing (Video and
Audio)
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Linux ApplicationWindows ApplicationTask

Linphone, SkypeX-LiteVoice over IP

gftp, kbearleechftp, wsftpFTP Clients

Epiphany
Epiphany is a lean, but powerful Web browser for the GNOME desktop. Many of
its features and extensions resemble Firefox. Find more information about Epiphany
at http://www.gnome.org/projects/epiphany/.

Evolution
Evolution is personal information management software for the GNOME desktop
combining mail, calendar, and address book functionality. It offers advanced e-
mail filter and search options, provides sync functionality for Palm devices, and
allows you to run Evolution as an Exchange or GroupWise client to integrate better
into heterogeneous environments. Find more information about Evolution at
http://www.gnome.org/projects/evolution/.

Firefox
Firefox is the youngest member of the Mozilla browser family. It runs on various
platforms, including Linux, MacOS, and Windows. Its main features include built-
in customizable searches, pop-up blocking, RSS news feeds, password management,
tabbed browsing, and some advanced security and privacy options. Firefox is very
flexible, allowing you to customize almost anything you want (searches, toolbars,
skins, buttons, etc.). Neat add-ons and extensions can be downloaded from the
Firefox Web site (https://addons.update.mozilla.org/
?application=firefox). Find more information about Firefox at http://
www.mozilla.org/products/firefox/. You can also read our Firefox
chapter.

Gaim
Gaim is a smart instant messenger program supporting multiple protocols, such as
AIM and ICQ (Oscar protocol), MSN Messenger, Yahoo!, IRC, Jabber, SILC, and
GroupWise Messenger. It is possible to log in to different accounts on different
IM networks and chat on different channels simultaneously. Gaim also exists in a
Windows version. Find more information about Gaim at http://gaim
.sourceforge.net/about.php.
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gftp
gftp is an FTP client using the GTK toolkit. Its features include simultaneous
downloads, resume of interrupted file transfers, file transfer queues, download of
entire directories, FTP proxy support, remote directory caching, passive and non-
passive file transfers, and drag and drop support. Find more information at
http://gftp.seul.org.

GnomeMeeting/Ekiga
GnomeMeeting (recently renamed Ekiga) is the open source equivalent of Mi-
crosoft's NetMeeting. It features LDAP and ILS support for address lookup and
integrates with Evolution to share the address data stored there. GnomeMeeting/Eki-
ga supports PC-to-phone calls, allowing you to call another party with just your
computer, sound card, and microphone without any additional hardware. Find more
information about GnomeMeeting/Ekiga at http://www.ekiga.org.

kbear
KBear is a KDE FTP client with the ability to have concurrent connections to
multiple hosts, three separate view modes, support for multiple protocols (like FTP
and SFTP), a site manager plug-in, firewall support, logging capabilities, and much
more. Find more information at http://sourceforge.net/projects/
kbear.

Konqueror
Konqueror is a multitalented application created by the KDE developers. It acts as
file manager and document viewer, but is also a very powerful and highly customiz-
able Web browser. It supports the current Web standards, such as CSS(2), Java
applets, JavaScript and Netscape plug-ins (Flash and RealVideo), DOM, and SSL.
It offers neat helpers like an integrated search bar and supports tabbed browsing.
Bookmarks can be imported from various other Web browsers, like Internet Explor-
er, Mozilla, and Opera. Find more information about Konqueror at http://www
.konqueror.org/. You can also read our chapter about Konqueror as a Web
browser in KDE User Guide.

Kontact
Kontact is the KDE personal information management suite. It includes e-mail,
calendar, address book, and Palm sync functionalities. Like Evolution, it can act
as an Exchange or GroupWise client. Kontact combines several stand-alone KDE
applications (KMail, KAddressbook, KOrganizer, and KPilot) to form an entity
providing all the PIM functionality you need. Find more information about Kontact

296 KDE User Guide

http://gftp.seul.org
http://www.ekiga.org
http://sourceforge.net/projects/kbear
http://sourceforge.net/projects/kbear
http://www.konqueror.org/
http://www.konqueror.org/


at http://www.kontact.org/. You can also read our Kontact chapter in
KDE User Guide.

Konversation
Konversation is an easy-to-use IRC client for KDE. Its features include support
for SSL connections, strikeout, multichannel joins, away and unaway messages,
ignore list functionality, Unicode, autoconnect to a server, optional time stamps in
chat windows, and configurable background colors. Find more information about
Konversation at http://konversation.kde.org.

Kopete
Kopete is a very intuitive and easy-to-use instant messenger tool supporting proto-
cols including IRC, ICQ, AIM, GroupWise Messenger, Yahoo, MSN, Gadu-Gadu,
Lotus Sametime, SMS messages, and Jabber. Find more information about Kopete
at http://kopete.kde.org/.

Linphone
Linphone is a smart and lean Voice over IP client using the SIP protocol to establish
calls. Find more information at http://www.linphone.org. You can also
read our Linphone chapter.

Mozilla Thunderbird
Thunderbird is an e-mail client application that comes as part of the Mozilla suite.
It is also available for Microsoft Windows and MacOS, which facilitates the tran-
sition from one of these operating systems to Linux. Find more information about
Mozilla Thunderbird at http://www.mozilla.org/products/
thunderbird/.

Opera
Opera is a powerful Web browser with neat add-ons like an optional e-mail client
and a chat module. Opera offers pop-up blocking, RSS feeds, built-in and customiz-
able searches, a password manager, and tabbed browsing. The main functionalities
are easily reached through their respective panels. Because this tool is also available
for Windows, it allows a much easier transition to Linux for those who have been
using it under Windows. Find more information about Opera at http://www
.opera.com/.

Skype
Skype is an application for several platforms (Linux, Windows, Mac Os X) that
can be used for phone calls over the Internet with a good sound quality and with
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end-to-end encryption. When using Skype, configuring the firewall or router is not
necessary. For more information, refer to http://www.skype.com/
products/.

XChat
XChat is an IRC client that runs on most Linux and UNIX platforms as well as
under Windows and MacOS X. Find more information about XChat at http://
www.xchat.org/.

C.3 Multimedia
The following section introduces the most popular multimedia applications for Linux.
Get to know media players, sound editing solutions, and video editing tools.

Table C.3 Multimedia Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KsCD, Grip, Helix BansheeCD Player, Winamp, Windows
Media Player

Audio CD Player

K3bNero, Roxio Easy CD CreatorCD Burner

kaudiocreator, Sound Juicer,
Helix Banshee

WMPlayerCD Ripper

amaroK, XMMS, Rhythmbox,
Helix Banshee

Winamp, Windows Media
Player, iTunes

Audio Player

Kaffeine, MPlayer, Xine,
XMMS, Totem, RealPlayer

Winamp, Windows Media
Player

Video Player

AudacitySoundForge, Cooledit, Auda-
city

Audio Editor

alsamixer, Kmixsndvol32Sound Mixer
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Linux ApplicationWindows ApplicationTask

LilyPond, MusE, Noteedit,
Rosegarden

Finale, SmartScore, SibeliusMusic Notation

MainActor, KinoWindows Movie Maker,
Adobe Premiere, Media Studio
Pro, MainActor

Video Creator and
Editor

xawtv (analog), motv (ana-
log), xawtv4, tvtime, kdetv,
zapping, Kaffeine

AVerTV, PowerVCR 3.0,
CinePlayer DVR

TV Viewer

amaroK
The amaroK media player handles various audio formats and plays the streaming
audio broadcasts of radio stations on the Internet. The program handles all file
types supported by the sound server acting as a back-end—currently aRts or
GStreamer. Find more information about amaroK at http://amarok.kde
.org/.

Audacity
Audacity is a powerful, free sound editing tool. Record, edit, and play any Ogg
Vorbis or WAV file. Mix tracks, apply effects to them, and export the results to
WAV or Ogg Vorbis. Find more information about Audacity at http://
audacity.sourceforge.net/.

Helix Banshee
Helix Banshee is a music management and playback application for the GNOME
desktop. With Helix Banshee, import CDs, sync your music collection to an iPod,
play music directly from an iPod, create playlists with songs from your library, and
create audio and MP3 CDs from subsets of your library. For more information,
refer to GNOME User Guide.

Grip
Grip provides CD player functionalities for the GNOME desktop. It supports CDDB
lookups for track and album data. Find more information at http://www
.nostatic.org/grip/.
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Kaffeine
Kaffeine is a versatile multimedia application supporting a wide range of audio
and video formats including Ogg Vorbis, WMV, MOV, and AVI. Import and edit
play lists of various types, create screen shots, and save media streams to your local
hard disk. Find more information about Kaffeine at http://kaffeine
.sourceforge.net/.

KAudiocreator
KAudioCreator is a lean CD ripper application. If configured accordingly, KAu-
dioCreator also generates playlist files for your selection that can be used by players
like amaroK, XMMS, or Helix Banshee. Read more about using KAudioCreator
in KDE User Guide or go to http://www.icefox.net/programs/
?program=KAudioCreator.

kdetv
A TV viewer and recorder application for the KDE desktop supporting analog TV.
Find more information about kdetv at http://www.kdetv.org/.

KsCD
KsCD is a neat little CD player application for the KDE desktop. Its user interface
very much resembles that of a normal hardware CD player, guaranteeing ease of
use. KsCD supports CDDB, enabling you to get any track and album information
from the Internet or your local file system. Find more information at http://
docs.kde.org/en/3.3/kdemultimedia/kscd/.

K3b
K3b is a multitalented media creation tool. Create data, audio, or video CD and
DVD projects by dragging and dropping. Find more information about K3b at
http://www.k3b.org/. You can also refer to our K3b chapter.

LilyPond
LilyPond is a free music sheet editor. Because the input format is text-based, you
can use any text editor to create note sheets. Users do not need to tackle any format-
ting or notation issues, like spacing, line-breaking, or polyphonic collisions. All
these issues are automatically resolved by LilyPond. It supports many special nota-
tions like chord names and tablatures. The output can be exported to PNG, TeX,
PDF, PostScript, and MIDI. Find more information about LilyPond at http://
lilypond.org/web/.
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MainActor
MainActor is a fully fledged video authoring software. Because there is a Windows
version of MainActor, transition from Windows is easy. Find more information
about MainActor at http://www.mainactor.com/.

MPlayer
MPlayer is a movie player that runs on several systems. Find more information
about MPlayer at http://www.mplayerhq.hu/homepage/design7/
info.html.

MusE
MusE's goal is to be a complete multitrack virtual studio for Linux. Find more in-
formation about MusE at http://www.muse-sequencer.org/index
.php.

Noteedit
Noteedit is a powerful score editor for Linux. Use it to create sheets of notes and
to export and import scores to and from many formats, such as MIDI, MusicXML
and LilyPond. Find more information about Noteedit at http://developer
.berlios.de/projects/noteedit/.

Rhythmbox
Rhythmbox is a powerful, multitalented media player for the GNOME desktop. It
allows you to organize and browse your music collection using playlists and even
supports Internet radio. Find more information about Rhythmbox at http://www
.gnome.org/projects/rhythmbox/.

Rosegarden
Rosegarden is a free music composition and editing environment. It features an
audio and MIDI sequencer and a score editor. Find more information about
Rosegarden at http://rosegardenmusic.com/.

Sound Juicer
Sound Juicer is a lean CD ripper application for the GNOME desktop. Find more
information about Sound Juicer at http://www.burtonini.com/blog/
computers/sound-juicer.

Totem
Totem is a movie player application for the GNOME desktop. It supports Shoutcast,
m3u, asx, SMIL, and ra playlists, lets you use keyboard controls, and plays a wide
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range of audio and video formats. Find more information about Totem at http://
www.gnome.org/projects/totem/.

tvtime
tvtime is a lean TV viewer application supporting analog TV. Find more information
about tvtime, including a comprehensive usage guide, at http://tvtime
.sourceforge.net/.

xawtv and motv
xawtv is a TV viewer and recorder application supporting analog TV. motv is ba-
sically the same as xawtv, but with a slightly different user interface. Find more
information about the xawtv project athttp://linux.bytesex.org/xawtv/
.

xawtv4
xawtv4 is a successor of the xawtv application. It supports both analog and digital
audio and video broadcasts. For more information, refer to http://linux
.bytesex.org/xawtv/.

Xine
Xine is a multimedia player that plays CDs, DVDs, and VCDs. It interprets many
multimedia formats. For more information, refer to http://xinehq.de/.

XMMS
XMMS is the traditional choice for multimedia playback. It is focused on music
playback, offering support for CD playback and Ogg Vorbis files. Users of Winamp
should find XMMS comfortable because of its similarity. Find more information
about XMMS at http://www.xmms.org/.

zapping
A TV viewer and recorder application for the GNOME desktop supporting analog
TV. Find more information about Zapping athttp://zapping.sourceforge
.net/cgi-bin/view/Main/WebHome.

C.4 Graphics
The following section presents some of the Linux software solutions for graphics work.
These include simple drawing applications as well as fully-fledged image editing tools
and powerful rendering and animation programs.
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Table C.4 Graphics Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KolourPaintMS PaintSimple Graphic Edit-
ing

The GIMP, KritaAdobe Photoshop, Paint Shop
Pro, Corel PhotoPaint, The
GIMP

Professional Graphic
Editing

OpenOffice.org Draw,
Inkscape, Dia

Adobe Illustrator, CorelDraw,
OpenOffice.org Draw, Free-
hand

Creating Vector
Graphics

Inkscape, Dia, KivioWebDraw, Freehand, Adobe
Illustrator

SVG Editing

POV-Ray, Blender,
KPovmodeler

3D Studio MAX, Maya, POV-
Ray, Blender

Creating 3D Graphics

Digikam, f-spotSoftware provided by the cam-
era manufacturer

Managing Digital Pho-
tographs

Vuescan, The GIMPVuescanScanning

gwenview, gThumb, Eye
of Gnome, f-spot

ACDSeeImage Viewing

Blender
Blender is a powerful rendering and animation tool available on many platforms,
including Windows, MacOS, and Linux. Find more information about Blender at
http://www.blender3d.com/.

Dia
Dia is a Linux application aiming to be the Linux equivalent of Visio. It supports
many types of special diagrams, such as network or UML charts. Export formats
include SVG, PNG, and EPS. To support your own custom diagram types, provide
the new shapes in a special XML format. Find more information about Dia at
http://www.gnome.org/projects/dia/.
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Digikam
Digikam is a smart digital photo management tool for the KDE desktop. Importing
and organizing your digital images is a matter of a few clicks. Create albums, add
tags to spare you from copying images around different subdirectories, and eventu-
ally export your images to your own Web site. Find more information about Digikam
at http://www.digikam.org/. You can also refer to our Digikam chapter
in KDE User Guide.

Eye of Gnome (eog)
Eye of Gnome is an image viewer application for the GNOME desktop. Find more
information at http://www.gnome.org/gnome-office/eog.shtml.

f-spot
f-spot is a flexible digital photograph management tool for the GNOME desktop.
It lets you create and manage albums and supports various export options like
HTML pages or burning of image archives to CD. You can also use it as an image
viewer on the command line. Find more information about f-spot at http://www
.gnome.org/projects/f-spot/. You can also refer to our chapter in
GNOME User Guide.

gThumb
gThumb is an image viewer, browser, and organizer for the GNOME desktop. It
supports the import of your digital images via gphoto2, allows you to carry out
basic transformation and modifications, and lets you tag your images to create al-
bums matching certain categories. Find more information about gThumb at
http://gthumb.sourceforge.net/.

Gwenview
Gwenview is a simple image viewer for KDE. It features a folder tree window and
a file list window that provides easy navigation of your file hierarchy. Find more
information at http://gwenview.sourceforge.net/home/.

Inkscape
Inkscape is a free SVG editor. Users of Adobe Illustrator, Corel Draw, and Visio
can find a similar range of features and a familiar user interface in Inkscape. Among
its features, find SVG-to-PNG export, layering, transforms, gradients, and grouping
of objects. Find more information about Inkscape at http://www.inkscape
.org/.
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Kivio
Kivio is a flow-charting application that integrates into the KOffice suite. Former
users of Visio find a familiar look and feel in Kivio. Find more information about
Kivio at http://www.koffice.org/kivio/.

KolourPaint
KolourPaint is an easy-to-use paint program for the KDE desktop. You can use it
for tasks such as painting or drawing diagrams and editing screen shots, photos,
and icons. For more information, refer to http://kolourpaint
.sourceforge.net/.

KPovmodeler
KPovmodeler is a POV-Ray front-end that integrates with the KDE desktop.
KPovmodeler saves users from needing a detailed knowledge of POV-Ray scripting
by translating the POV-Ray language in an easy-to-understand tree view. Native
POV-Ray scripts can be imported to KPovmodeler as well. Find more information
at http://www.kpovmodeler.org.

Krita
Krita is KOffice's answer to Adobe Photoshop and The GIMP. It can be used for
pixel-based image creation and editing. Its features include many of the advanced
image editing capabilities you would normally expect with Adobe Photoshop or
The GIMP. Find more information at http://www.koffice.org/krita.

OpenOffice.org Draw
See OpenOffice.org (page 292).

POV-Ray
The Persistence of Vision Raytracer creates three-dimensional, photo-realistic im-
ages using a rendering technique called ray tracing. Because there is a Windows
version of POV-Ray, it does not take much for Windows users to switch to the
Linux version of this application. Find more information about POV-Ray at
http://www.povray.org/.

The GIMP
The GIMP is the open source alternative to Adobe Photoshop. Its feature list rivals
that of Photoshop, so it is well suited for professional image manipulation. There
is even a Windows version of GIMP available. Find more information at http://
www.gimp.org/. You can also refer to our GIMP chapter.
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VueScan
VueScan is a scanning software available for several platforms. You can install it
parallel to your vendor's scanner software. It supports the scanner's special hardware,
like batch scanning, autofocus, infrared channels for dust and scratch suppression,
and multiscan to reduce scanner noise in the dark areas of slides. It features simple
and accurate color correction from color negatives. Find out more at http://
www.hamrick.com/index.html.

C.5 System and File Management
The following section provides an overview of Linux tools for system and file manage-
ment. Get to know text and source code editors, backup solutions, and archiving tools.

Table C.5 System and File Management Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, NautilusWindows ExplorerFile Manager

kate, GEdit, (X)Emacs,
vim

NotePad, WordPad,
(X)Emacs

Text Editor

ScribusAdobe DistillerPDF Creator

Adobe Reader, Evince,
KPDF, Xpdf

Adobe ReaderPDF Viewer

GOCRRecognita, FineReaderText Recognition

zip, tar, gzip, bzip2, etc.zip, rar, arj, lha, etc.Command Line Pack
Programs

Ark, File RollerWinZipGUI Based Pack Pro-
grams

YaST, GNU PartedPowerQuest, Acronis, Parti-
tion Commander

Hard Disk Partitioner
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Linux ApplicationWindows ApplicationTask

KDar, taper, dumpntbackup, VeritasBackup Software

Adobe Reader
Adobe Reader for Linux is the exact counterpart of the Windows and Mac versions
of this application. The look and feel on Linux are the same as on other platforms.
The other parts of the Adobe Acrobat suite have not been ported to Linux. Find
more information at http://www.adobe.com/products/acrobat/
readermain.html.

Ark
Ark is a GUI-based pack program for the KDE desktop. It supports common formats,
such as zip, tar.gz, tar.bz2, lha, and rar. You can view, select, pack, and
unpack single files within an archive. Due to Ark's integration with Konqueror,
you can also trigger actions (such as unpacking an archive) from the context menu
in the file manager, similar to WinZip.

dump
The dump package contains both dump and restore. dump examines files in a file
system, determines which ones need to be backed up, and copies those files to a
specified disk, tape, or other storage medium. The restore command performs the
inverse function of dump—it can restore a full backup of a file system. Find more
information at http://dump.sourceforge.net/.

Evince
Evince is a document viewer for PDF and PostScript formats for the GNOME
desktop. Find more information at http://www.gnome.org/projects/
evince/.

File Roller
File Roller is a GUI-based pack program for the GNOME desktop. It provides
features similar to Ark's. For more information, refer to http://fileroller
.sourceforge.net/home.html.

GEdit
GEdit is the official text editor of the GNOME desktop. It provides features similar
to Kate's. Find more information at http://www.gnome.org/projects/
gedit/.
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GNU Parted
GNU Parted is a command line tool for creating, destroying, resizing, checking,
and copying partitions and the file systems on them. If you need to create space
for new operating systems, use this tool to reorganize disk usage and copy data
between different hard disks. Find more information athttp://www.gnu.org/
software/parted/.

GOCR
GOCR is an OCR (optical character recognition) tool. It converts scanned images
of text into text files. Find more information at http://jocr.sourceforge
.net/.

gzip, tar, bzip2
There are plenty of packaging programs for reducing disk usage. In general, they
differ only in their pack algorithm. Linux can also handle the packaging formats
used on Windows. bzip2 is a bit more efficient than gzip, but needs more time,
depending on the pack algorithm.

kate
Kate is part of the KDE suite. It has the ability to open several files at once either
locally or remotely. With syntax highlighting, project file creation, and external
scripts execution, it is a perfect tool for a programmer. Find more information at
http://kate.kde.org/.

KDar
KDar stands for KDE disk archiver and is a hardware-independent backup solution.
KDar uses catalogs (unlike tar), so it is possible to extract a single file without
reading the whole archive and it is also possible to create incremental backups.
KDar can split an archive into multiple slices and trigger the burning of a data CD
or DVD for each slice. Find more information about KDar at http://kdar
.sourceforge.net/.

Konqueror
Konqueror is the default file manager for the KDE desktop, which can also be used
as a Web browser, document and image viewer, and CD ripper. Find more infor-
mation about this multifunctional application at http://www.konqueror
.org/.
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KPDF
KPDF is a PDF viewing application for the KDE desktop. Its features include
searching the PDF and full screen reading mode like in Adobe Reader. Find more
information at http://kpdf.kde.org/.

Nautilus
Nautilus is the default file manager of the GNOME desktop. It can be used to create
folders and documents, display and manage your files and folders, run scripts, write
data to a CD, and open URI locations. For an introduction to using Nautilus as a
file manager, see GNOME User Guide. Find information about Nautilus on the
Internet at http://www.gnome.org/projects/nautilus/.

taper
Taper is a backup and restore program that provides a friendly user interface to allow
backup and restoration of files to and from a tape drive. Alternatively, files can be
backed up to archive files. Recursively selected directories are supported. Find
more information at http://taper.sourceforge.net/.

vim
vim (vi improved) is a program similar to the text editor vi. Users may need time
to adjust to vim, because it distinguishes between command mode and insert mode.
The basic features are the same as in all text editors. vim offers some unique options,
like macro recording, file format detection and conversion, and multiple buffers in
a screen. Find more information at http://www.vim.org/.

(X)Emacs
GNU Emacs and XEmacs are very professional editors. XEmacs is based on GNU
Emacs. To quote the GNU Emacs Manual, “Emacs is the extensible, customizable,
self-documenting real-time display editor.” Both offer nearly the same functional-
ity with minor differences. Used by experienced developers, they are highly exten-
sible through the Emacs Lisp language. They support many languages, like Russian,
Greek, Japanese, Chinese, and Korean. Find more information at http://www
.xemacs.org/ and http://www.gnu.org/software/emacs/emacs
.html.

Xpdf
Xpdf is lean PDF viewing suite for Linux and Unix platforms. It includes a viewer
application and some export plug-ins for PostScript or text formats. Find more in-
formation at http://www.foolabs.com/xpdf/.
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C.6 Software Development
This section introduces Linux IDEs, toolkits, development tools, and versioning systems
for professional software development.

Table C.6 Development Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KDevelop, Eric, Eclipse,
MonoDevelop, Anjuta

Borland C++, Delphi, Visual
Studio, .NET

Integrated Development
Environments

Qt, GTK+MFC, Qt, GTK+Toolkits

GCCVisualStudioCompilers

GDB, valgrindVisual StudioDebugging Tools

Glade, Qt DesignerVisual Basic, Visual C++GUI Design

CVS, SubversionClearcase, Perforce, Source-
Safe

Versioning Systems

Anjuta
Anjuta is an IDE for GNOME/GTK+ application development. It includes an editor
with automated formatting, code completion, and highlighting. As well as GTK+,
it supports Perl, Pascal, and Java development. A GDB-based debugger is also in-
cluded. Find more information about Anjuta athttp://anjuta.sourceforge
.net.

CVS
CVS, the Concurrent Versions System, is one of the most important version control
systems for open source. It is a front-end to the Revision Control System (RCS)
included in the standard Linux distributions. Find more information at the home
page http://www.cvshome.org/.

Eclipse
The Eclipse Platform is designed for building integrated development environments
that can be extended with custom plug-ins. The base distribution also contains a
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full-featured Java development environment. Find more information at http://
www.eclipse.org.

Eric
Eric is an IDE optimized for Python and Python-Qt development. Find more infor-
mation about Eric athttp://www.die-offenbachs.de/detlev/eric3
.html.

GCC
GCC is a compiler collection with front-ends for various programming languages.
Check out a complete list of features and find extensive documentation at http://
gcc.gnu.org.

GDB
GDB is a debugging tool for programs written in various programming languages.
Find more information about GDB at http://www.gnu.org/software/
gdb/gdb.html.

Glade
Glade is a user interface builder for GTK+ and GNOME development. As well as
GTK+ support, it offers support for C, C++, C#, Perl, Python, Java, and others.
Find more information about Glade at http://glade.gnome.org/.

GTK+
GTK+ is a multiplatform toolkit for creating graphical user interfaces. It is used
for all GNOME applications, The GIMP, and several others. GTK+ has been de-
signed to support a range of languages, not only C/C++. Originally it was written
for GIMP, hence the name “GIMP Toolkit.” Find more information at http://
www.gtk.org. Language bindings for GTK+ are summarized under http://
www.gtk.org/bindings.html.

KDevelop
KDevelop allows you to write programs for different languages (C/C++, Python,
Perl, etc.). It includes a documentation browser, a source code editor with syntax
highlighting, a GUI for the compiler, and much more. Find more information at
http://www.kdevelop.org.

MonoDevelop
The Mono Project is an open development initiative that is working to develop an
open source Unix version of the .NET development platform. Its objective is to
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enable Unix developers to build and deploy cross-platform .NET applications.
MonoDevelop complements the Mono development with an IDE. Find more infor-
mation about MonoDevelop at http://www.monodevelop.com/.

Qt
Qt is a program library for developing applications with graphical user interfaces.
It allows you to develop professional programs rapidly. The Qt library is available
not only for Linux, but for a number of Unix flavors and even for Windows and
Macintosh. Thus it is possible to write programs that can be easily ported to those
platforms. Find more information athttp://www.trolltech.com. Language
bindings for Qt development are summarized under http://developer.kde
.org/language-bindings/.

Qt Designer
Qt Designer is a user interface and form builder for Qt and KDE development. It
can be run as part of the KDevelop IDE or in stand-alone mode. QtDesigner can
be run under Windows and even integrates into the Visual Studio development
suite. Find more information about Qt Designer at http://www.trolltech
.com/products/qt/designer.html.

Subversion
Subversion does the same thing CVS does but has major enhancements, like moving,
renaming, and attaching meta information to files and directories. The Subversion
home page is http://subversion.tigris.org/.

Valgrind
Valgrind is a suite of programs for debugging and profiling x86 applications. Find
more information about Valgrind at http://valgrind.org/info/.
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